MinimServer Forum

Full Version: Minimserver recent in Audiolinux
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I use now Audiolinux and it seems that I cannot save the settings in indexTags "RecentAdded and RecentPlayed"
Minimserver restart in red and show issue "opt/minimserver/recent"
And if I look for in ssh there is no minimserver/recent folder!
What's the reason? Because Minimserver in Audiolinux is no update? (2.1.2)
And it seems impossible to install new update 218
The author of AudioLinux has created a nonstandard unofficial MinimServer package. I think the problems you are seeing are related to using this package. I can only support the official MinimServer package for Linux and I have explained this to the author of AudioLinux.

I suggest you uninstall this unofficial MinimServer package and download and install the official MinimServer package from the MinimServer Downloads page. To install this package, you need to follow the instructions on this page. You need be logged in as the username audiolinux (not root) and install MinimServer in the /home/audiolinux/minimserver directory (not /opt/minimserver). To configure MinimServer to start automatically, you should use the minimserver/bin/setup command.

When you have installed MinimServer in this way, it should be working correctly. If you are still having problems after doing this, please post back here.
I installed Minimserver in /home/audiolinux/minimserver and it works completly with recent added an played.
But when I am in ramboot mode Minimserver doesnt launch automaticly.
I must launch Minimwatch and make "restart" with click in the icon.
Is there an automatic solution to launch Minimserver in ramroot?
If MinimWatch can see MinimServer, this means MinimServer is running and should be visible to UPnP control points after it has finished scanning the library.

Your control points might not be able to see MinimServer after a reboot because MinimServer is still doing its initial startup scan. This might take longer than usual because the previous cache file might have been written to ramdisk and lost when you reboot AudioLinux. Does MinimWatch show a yellow icon when you launch it? If so, MinimServer is still doing its initial scan.

If this is the cause of the problem, the solution is to save the contents of the minimserver/data directory to persistent storage before you reboot AudioLinux. You should also save the minimserver/recent directory so that your lists of recently added and recently played files are preserved.
Yes I see Minimserver icon on my control point, but the folder is empty. (in ramroot)
With Minimwatch, the Minimserver Audiolinux is green and just a click on restart and the files appear immediately on my control point without any rescan I think.
This means there is some kind of race condition between MinimServer starting and scanning your library and the ramroot copying of your library files from disk to RAM.

When MinimServer is started, it has detected an empty folder for your library. Your control point has queried MinimServer for the library contents and MinimServer has returned an empty folder.

By the time you do the restart from MinimWatch, the library contents have been copied to RAM. The restart causes the control point to refresh its view of the MinimServer library and by now MinimServer has detected and scanned the folder contents from RAM. I am not quite sure how this is happening without a rescan.

The solution should be to set the MinimServer delayStart property to a large enough value to enable the library copying to RAM to finish before MinimServer starts its initial scan of the library. You could start with a value of 30 to delay the scan by 30 seconds and adjust this value up or down until you find the optimal setting.
Ok I understand…
But could you help me with the command lines I must write to delay start and rescan Minimserver? And in which folder
I’m a linux newbie, sorry. Thanks
In MinimWatch, select Properties and then select the Advanced tab. Enter the delay value into the delayStart property and click OK.
It works!!! Even with 1s delay start
Thanks
Thanks for this. It is interesting that a 1s delay is long enough.
Reference URL's