MinimServer Forum

Full Version: Playlist offset by one track
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello

I'm having a consistent issue when I select a new track or stream for playback: my renderer plays the prior active track instead. I guess that this is most likely a renderer issue.

Renderer: RPi running Ropieee XL (upmpdcli) with Openhome disabled
Bridge: BubbleUPnPServer to make Ropieee an Openhome renderer
Controller: most of them (mainly Kazoo, Bubble, etc).
Server: Minimserver / Streamer on Synology Docker

Selecting play again on the requested track normally clears it. Does anyone else get this, or have any clues how to solve it?

Edit: actually it is not one track offset or the prior track played, just another track in the current playlist - maybe the first in the prior batch of tracks added.

Thanks!
Do you have random play activated somewhere in the renderer layers (renderer, bubble server)?
(03-04-2022 13:49)tarnkappe Wrote: [ -> ]Do you have random play activated somewhere in the renderer layers (renderer, bubble server)?

No, but it was a great clue. I saw that I had "Gapless playback" enabled for the renderer in Bubble Server. Turning this off seems to have fixed the problem. This of course made gapless playback not work.

I went to the Ropieee config and turned on Openhome support (which has been shaky in the past). Gapless seems to work. The renderer now isn't visible in BubbleUPnP Server - I guess I don't need this anyway if OH support in RopieeeXL is working ok.

At the moment, I think thinks are happier... let's see.

Thanks for your help.
Reference URL's