MinimServer Forum

Full Version: New install Mac M1 Minimserver Java error?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Finally getting around to installing MinimServer 2 on my M1 Mac. I followed instructions and installed Java SE Development Kit 18. I was greeted by the following error on startup

An unexpected exception has occurred:
java.lang.InternalError: java.lang.IllegalAcces sException: static
Diagnostic information has been written to a crash log file.
Click OK to relaunch MinimServer or Cancel to exit.


Any ideas?
This is caused by a change in Java 18. For now, you need to use Java 17. I am working on a solution.
Thank you Simon (Gregg here from original Linn forum back in the day when you first developed Server)
The problem is the error message I linked to was from the Java 17 install.
Any further ideas? In the meanwhile I will uninstall Java 17 an reinstall to see what happens.

Best
Gregg
OK figured things out.
JAVA was not properly uninstalled. Java 17 installed and MinimServer successfully started and running
THANKS!

Simon - PS - after using my KDS in my Naim 500 system since 2011 I finally moved to a dCS Rossini+Clock in 2020. The Linn KDS/3 is now running in my dedicated headphone systems - and (hopefully) waiting for an Organik upgrade (fingers crossed)
I am also using a dCS Rossini (without clock), connected by USB to a Melco N1Z and streaming from MinimServer running on a Melco N1A. It sounds great!
As for me, on my new M1 mac, when launching MinimWatch, I have the following error msg:

LibjliOpenError

Is it same issue ?
(27-03-2022 19:12)glevethan Wrote: [ -> ]Simon - PS - after using my KDS in my Naim 500 system since 2011 I finally moved to a dCS Rossini+Clock in 2020. The Linn KDS/3 is now running in my dedicated headphone systems - and (hopefully) waiting for an Organik upgrade (fingers crossed)

Do you really believe Linn will make an Organik upgrade ?

I have the last but one Klimax, and had the opportunity to compare with Organik DSM/3; there is a true difference.

But the form factor is so different...
(29-03-2022 08:58)lyapounov Wrote: [ -> ]As for me, on my new M1 mac, when launching MinimWatch, I have the following error msg:

LibjliOpenError

Is it same issue ?

This is not the same issue. It means you have installed the wrong Java download (Intel instead of M1).

A fix for the java.lang.IllegalAccessException problem with Java 18 will be available soon.
(29-03-2022 10:01)simoncn Wrote: [ -> ]This is not the same issue. It means you have installed the wrong Java download (Intel instead of M1).

Java web site does propose only one download for Mac OSx; does not offer to choose Intel or Apple M1
OK: I launch MinimWatch.
MinimWatch says "download Java" with a link.
This link (https://java.com/fr/download/) does not propose to choose M1

The only place I could see a choice is OpenJDK

So what to do ?
Pages: 1 2
Reference URL's