MinimServer Forum

Full Version: unexpected audio type avc1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Simon
Since the introduction of mp4 in Minimserver I'm getting the following log message when rescanning:

------------------------------------------
Warning: unexpected audio type 'avc1' in file Mendelssohn/Mendelssohn - The Complete String Quartets/Recording Octet.mp4 (length 296292369)
MinimServer internal error: expected offset 295929278, stream offset 300647774 in file Mendelssohn/Mendelssohn - The Complete String Quartets/Recording Octet.mp4 (length 296292369)
com.minimserver.reader.FileReader$FileReadException: expected offset 295929278, stream offset 300647774

remaining log java messages removed to get through 403 block
------------------------------------

Regards
David
Is it just one file that produces this message? If it is happening with more than one file, what is the length of the smallest file that does this?
Simon
This is the only file which produces this message. It is a video associated with an album so I keep them together.
I have attached the full log file which hopefully helps.
Regards
David
Thanks for this log file. It is useful but unfortunately it doesn't contain enough information for me to find and fix the problem.

If possible, please upload this mp4 file to my FTP server so that I can look at the contents of the file. I will send you a PM with the server details. Many thanks for your help with this.
This happens on any mp4 files encoded using H.264, a lot of youtube videos are in that format. I can send you lots of examples.
For example, https://www.youtube.com/watch?v=ddoyDzcBqd4 .
tom
Thans for sending the file. Having looked at this file and another smaller file selected randomly from YouTube, I understand why this isn't working. I am working on a fix that will enable MinimServer to read the audio portion of a file like this without also trying to read the video portion. I will post back here when a fix is available. Many thanks for your help with this.
Thanks Simon
This problem should be fixed now in MinimServer update 215.
Message gone. Thanks Simon
Reference URL's