MinimServer Forum

Full Version: Roku Soundbrigde did not show minimserver
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello experts,

I have been using the MinimServer for many years and it works perfectly with my Roku Soundbridges. Because I now need the MinimStreamer again, I finally upgraded to version 2.1 and purchased the license.

I have the problem that after switching on the soundbridge the Minimserver is not displayed as a source. I seem to remember that there was this problem in the past, which can be solved by a parameter, which was something with a time setting regarding the reporting frequency of the service in the network, but I can not find the old thread.

The minimserver here is running on a Synology NAS.

kind regards
Alhifi
If you stop and restart MinimServer from Synology DSM Package Center after switching on the SoundBridge, does MinimServer show in the SoundBridge?
Hi simoncn,

no, that's the reason why I opened the thread here. In the past there was a similar issues with an older (veryyyy old) version and I remember (or I though so) I have changed a value of a parameter outside the GUI to fix that.

Maybe you have another solution!

Bye
Alhifi
When you opened the thread, you said it doesn't work if MinimServer is started before the SoundBridge. My question was whether it doesn't work if the SoundBridge is started before MinimServer.

Do you have a firewall running on the Synology? This might be blocking MinimServer if you haven't set the firewall rules correctly.
Hi simoncn,

sorry for the misunderstanding.

The minimserver was running fine for ages in the old version 0.8x. But because of the many HTTPS URLs of the radio stations I now have to revert to the Minimstreamer, so that the Roku soundbridges continue to work, I have updated to the new 2.1 version. Since then, the four soundbridges here on the net no longer find the minimserver. There is no firewall in the private network. I just clicked through the NAS settings again, there are no restrictions. The normal media server of the synology NAS is immediately displayed on the soundbridge, but it only does video and photos on the home network, because MinimServer is much better.

So what's the difference between the old 0.8x and the actual 2.1 ?

kind regards
Alhifi
STOP

Damned!

My fault!

Minimserver was not really started! The NAS showed "started" so I did not check the configuration and state with Minimwatch or the Web-GUI.

Sometimes I use different dates for album and title, as an example, a compilation named "Best Of The 90s" is released in 2015 (albumdate = 2015), but the tracks have the original dates like 1994, 1996 and so on (titledate = 1994). The album was displayed like "Album Title [1994, 1996 ...]".
So I defined additional tags like "yearcd" and "yeartitle" which I use within Minimserver. I always use at the "tagValue" the string

date.default={yeartitle,yearcd},titledate.default={date}

to define the value for the title, therefor I added

albumdate.default={yearcd}

and that did not work and was shown as an error in the Minimserver Web-GUI. If I remove the wrong "albumdate.default" Minimserver is up again and recocnized by the soundbridges.

Maybe you have an idea to define the date of the album ... ;-)

kind regards
Alhifi
If there is an error message, it is helpful if you can post the exact wording of the error message. This makes it easier to identify the cause of the problem.

Have you added albumdate to itemTags or indexTags? If not, the setting

albumdate.default={yearcd}

would produce an error message.
I added the

albumdate.default={yearcd}

at the tagValue like the other definitions, here the complete config

[Image: minim21.jpg]

(Do not know why the pic is not shown, here the URL to the screenshot)

http://www.planet-lumumba.de/pic/minim21.jpg

The error was

Incorrect tag name 'albumdate' in property 'tagValue'

kind regards
Alhifi
The screenshot shows that you don't have albumdate in either indexTags or itemTags. If you want to use albumdate in tagValue, you need to add albumdate to either indexTags or itemTags.
(12-02-2022 11:08)simoncn Wrote: [ -> ]The screenshot shows that you don't have albumdate in either indexTags or itemTags. If you want to use albumdate in tagValue, you need to add albumdate to either indexTags or itemTags.

Thanks a lot, now it works again!

Apologies for the circumstances, but I have lost my configuration during the update to 2.1 ... and did not make a screenshot of the configuration.

Bye
Alhifi
Reference URL's