MinimServer Forum

Full Version: Little problem upgrading to minimserver 2.1 on Synology D216j - DSM 7
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Having been a long time happy minimserver 1 user (many thanks Simon), I have finally followed the detailed instructions, and started updating my installation to 2. So far:

Installed minimwatch 2 on my PC
Java 8 removed
Synology D216J DSM OS from 6 to 7
Repaired minimserver on the NAS

Package Centre now tells me that I have 2.0.18-2003 installed.

All is running and working well but I believe I should be able to upgrade to version 2.1 but I cannot install IAW the instuctions.

I do not have an update button against minimserver in the installed section, minimserver 2.1 does not show in the available packages.

So I downloaded MinimServer-2.1-2100-armv7.spk (for Arm 7 I believe) in order to manually install, but my Package Centre settings do not have an option to change the trust settings. I have 'general', 'auto-update' and 'package sources', but not 'certificate'. I did try to add minimworld/https://minimworld.com in the package sources but it says invalid location.

If I select manual install and select the .spk file I get a grave warning about the evil that Simon Nash products wreak upon the world, but there is an agree and continue button - is it OK to do it this way?

I would prefer to have it all as described with the trust settings. But I have probably made an error somewhere...
For information--

On my Synology DS414 running DSM 7, MinimServer 2.1 doesn't install. I get the popup (on my Windows 10 PC, where I have MinimWatch) saying the update is available, but when I click OK, nothing happens. I have not gone further, such as downloading packages and such. From other posts, I guess Simon is working on this and we'll see a fix shortly.
Quote:If I select manual install and select the .spk file I get a grave warning about the evil that Simon Nash products wreak upon the world, but there is an agree and continue button - is it OK to do it this way?

Yes this is ok. You get the warning because the package is downloaded elsewhere (not from a synology site) and (I guess) not signed with a synology certificate.
(19-12-2021 17:58)Dragon77 Wrote: [ -> ]So I downloaded MinimServer-2.1-2100-armv7.spk (for Arm 7 I believe) in order to manually install, but my Package Centre settings do not have an option to change the trust settings. I have 'general', 'auto-update' and 'package sources', but not 'certificate'. I did try to add minimworld/https://minimworld.com in the package sources but it says invalid location.

If I select manual install and select the .spk file I get a grave warning about the evil that Simon Nash products wreak upon the world, but there is an agree and continue button - is it OK to do it this way?

I would prefer to have it all as described with the trust settings. But I have probably made an error somewhere...

This is a change in DSM 7. In DSM 6, package developers could sign their packages using a certificate provided by Synology and users could choose to trust these signed packages, as you describe. This facility was removed by Synology in DSM 7 with no explanation. Because of this, you cannot avoid getting a red warning on DSM 7 for any non-Synology package that isn't installed from the Package Center.
(19-12-2021 19:50)Mike48 Wrote: [ -> ]On my Synology DS414 running DSM 7, MinimServer 2.1 doesn't install. I get the popup (on my Windows 10 PC, where I have MinimWatch) saying the update is available, but when I click OK, nothing happens. I have not gone further, such as downloading packages and such. From other posts, I guess Simon is working on this and we'll see a fix shortly.

This "version update" popup is for your information only. New versions (such as version 2.1) are installed by logging into DSM and using the Package Center. It has always been this way when there is a new version. Online updates (such as update 201) can be installed from the MinimWatch popup.
(19-12-2021 22:01)simoncn Wrote: [ -> ]This "version update" popup is for your information only. New versions (such as version 2.1) are installed by logging into DSM and using the Package Center. It has always been this way when there is a new version. Online updates (such as update 201) can be installed from the MinimWatch popup.

Thanks, Simon. Has it also always been that the update needs be done through Manual Install?
Thanks tarnkappe, simon and mike48 for all the information.

So DSM 6 to 7 is different and I didn't screw it up! And it's OK to continue with the manual install - great.

Maybe there could be something we can add in the 'Package Sources' tab for the future?


edit:

All upgraded to 2.1 and working perfectly - thanks.
As far as I know, all packages in the community repository (Package Sources) are not in the official Synology repository. It would be confusing to have two different versions of MinimServer available from two different repositories as it might not be clear which of these is the current and supported version.
(20-12-2021 00:55)Mike48 Wrote: [ -> ]Thanks, Simon. Has it also always been that the update needs be done through Manual Install?

It depends how soon the new version is available in the Synology Package Center and how soon you want to update to it. If you want to update when a new version is first released, you will usually need to use manual install.
Reference URL's