MinimServer Forum

Full Version: MinimServer on Synology Problems
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I forgot to change the license to starter before I removed MinimServer and now it shows a "repair" icon, but won't repair.

Will it help to reset the license on bobbym625?
I presume the "repair" icon is coming fom DSM, not from MinimServer. To do the repair, you need to install the DSM 7 version of MinimServer from the DSM 7 Package Center. There is no need to reset the license.
Yes, the repair comes from DSM. I had already upgraded DSM when I wrote the first message. I installed MinimServer tonight with the DSM 7 version download and on the Synology NAS. I also tried installing a docker on the same NAS and I still get the same repair button. In both cases the repair fails and I can't uninstall unless I deactivate the license. I can't do that unless I can get to the web page.

Do you have any advice>
You won't be able to run MinimServer in a Docker container until you have repaired and started the MinimServer DSM package.

As repairing by reinstalling has not worked, you will need to repair MinimServer by uninstalling and reinstalling. To do this, use the following steps:

1) In File Station, open the MinimServer/appData folder
2) Delete the minimserver.config file
3) Uninstall MinimServer, choosing the option to save the configuration
4) Install the DSM 7 version of MinimServer
5) If MinimServer isn't running, click Run from Package Center
6) When MinimServer is running click Open from Package Center
7) Click through the Welcome page to the Status page
8) Select the License tab
9) MinimServer will show a page saying that your license has been updated from Starter to Full. If this page has a Restart button, click Restart. If there is no Restart button, click OK.

MinimServer should now be running with your previous configuration settings.
It still won't run. I can uninstall MinimServer, but if I reinstall it has the repair button.
I don't know what causes DSM to show the Repair button. The only time I have seen this is when I had the DSM 6 version of MinimServer installed on DSM 7.

Do you see MinimServer in the Package Center? If so, you could try installing this version. Also, if you have the JRE package installed, you need to uninstall this.

The next step would be either to contact Synology technical support or reinstall DSM 7 after uninstalling MinimServer.
I don't have jre installed. I'm going to wipe it and reinstall.
I got MinimServer installed after resetting the NAS. I did it without losing my data. Thank you for your help, Simon.
I reset again and after installing MinimServer from the Synology Package Center it worked. I installed the version I downloaded from your downloads page. I saw earlier tonight that my file permissions caused it not to start and when I reset the permissions on the MinimServer shared directory it worked fine.

I know how to safely reset my NAS, now Smile
Reference URL's