MinimServer Forum

Full Version: minimserver on centos
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I've installed minimserver on a headless centos6 server using openjdk 1.7. Running minimserver from a ssh session everything seems to run properly and I installed minimwatch on a win7 x64 laptop to configure but the minimwatch icon stays greyConfused I opened up the firewall from the server and the windows firewall but still no go
any ideas????
(20-05-2013 04:54)gillecaluim Wrote: [ -> ]I've installed minimserver on a headless centos6 server using openjdk 1.7. Running minimserver from a ssh session everything seems to run properly and I installed minimwatch on a win7 x64 laptop to configure but the minimwatch icon stays greyConfused I opened up the firewall from the server and the windows firewall but still no go
any ideas????

Is it obvious that MinimServer is activated on your centos6 ?
Perhaps MiminServer is in status deactivated, so MinimWatch could not find it
(20-05-2013 04:54)gillecaluim Wrote: [ -> ]I've installed minimserver on a headless centos6 server using openjdk 1.7. Running minimserver from a ssh session everything seems to run properly and I installed minimwatch on a win7 x64 laptop to configure but the minimwatch icon stays greyConfused I opened up the firewall from the server and the windows firewall but still no go
any ideas????

Did you start MinimServer using the autostart.sh script? This includes the --nohup option, which is needed on some versions of Linux to prevent the MinimServer process being terminated when the ssh window is closed.

As a first step in diagnosing the problem, you can login with ssh and use ps -ef to make sure the MinimServer process is running when you start MinimWatch on the laptop. If the MinimServer process is running, the next step is to run MinimWatch on the centos6 machine using another ssh window and see whether it can find the running MinimServer instance.
(20-05-2013 09:58)simoncn Wrote: [ -> ]
(20-05-2013 04:54)gillecaluim Wrote: [ -> ]I've installed minimserver on a headless centos6 server using openjdk 1.7. Running minimserver from a ssh session everything seems to run properly and I installed minimwatch on a win7 x64 laptop to configure but the minimwatch icon stays greyConfused I opened up the firewall from the server and the windows firewall but still no go
any ideas????

Did you start MinimServer using the autostart.sh script? This includes the --nohup option, which is needed on some versions of Linux to prevent the MinimServer process being terminated when the ssh window is closed.

As a first step in diagnosing the problem, you can login with ssh and use ps -ef to make sure the MinimServer process is running when you start MinimWatch on the laptop. If the MinimServer process is running, the next step is to run MinimWatch on the centos6 machine using another ssh window and see whether it can find the running MinimServer instance.

started minimserver

[root@server data]# java -jar ../lib/minimserver.jar
MinimServer 0.72, Copyright © 2012, 2013 Simon Nash. All rights reserved.
starting MinimServer
Enter command (? for help), or null to exit:
MinimServer[server.ourhome.net] is running
>?
Commands:
stop stops the media server without exiting the application
restart restarts the stopped or running media server
props shows current properties for the media server
prop n=v sets media server property name n to value v
about shows version and status information for the media server
sleep t delays execution for t seconds (can be useful for scripting)
exit (or null line) exits the media server application
help (or ?) displays this information


started minimwatch
java -jar ../lib/minimwatch.jar
MinimWatch 0.72, Copyright © 2012, 2013 Simon Nash. All rights reserved.
Enter command (? for help), or null to exit:
>?
Commands:
about shows version and status information for this application
refresh refreshes the status of all media servers
sleep t delays execution for t seconds (can be useful for scripting)
exit (or null line) exits this application
help (or ?) displays this information
>refresh

ran ps -ef

...
root 18141 18129 0 08:42 pts/2 00:00:00 -bash
root 18157 18033 2 08:44 pts/1 00:00:04 java -jar ../lib/minimserver.jar
root 18207 18141 0 08:46 pts/2 00:00:00 java -jar ../lib/minimwatch.jar

so they're both running but as you can see from the minimwatch console output it doesn't see the minimserver. Does minimserver bind to a specific interface?
(20-05-2013 16:54)gillecaluim Wrote: [ -> ]so they're both running but as you can see from the minimwatch console output it doesn't see the minimserver. Does minimserver bind to a specific interface?

By default, MinimServer binds to all available interfaces. You can make it bind to a specific interface by using the props command to set the ohnet.subnet property.

If you have multiple interfaces on different connected subnets, MinimServer won't work correctly. In this situation, you need to choose a single subnet for MinimServer to use, and set the ohnet.subnet property to make MinimServer bind to this subnet.

MinimWatch can bind only to a single interface. This is a limitation of the ohNet UPnP stack that both MinimServer and MinimWatch use. When you start MinimWatch, it binds to the first interface that it finds. You can make MinimWatch bind to a specific interface by editing the minimwatch.config file to set the ohnet.subnet property. You need to add a line like the following:

ohnet.subnet = x.x.x.x
(20-05-2013 17:20)simoncn Wrote: [ -> ]
(20-05-2013 16:54)gillecaluim Wrote: [ -> ]so they're both running but as you can see from the minimwatch console output it doesn't see the minimserver. Does minimserver bind to a specific interface?

By default, MinimServer binds to all available interfaces. You can make it bind to a specific interface by using the props command to set the ohnet.subnet property.

If you have multiple interfaces on different connected subnets, MinimServer won't work correctly. In this situation, you need to choose a single subnet for MinimServer to use, and set the ohnet.subnet property to make MinimServer bind to this subnet.

MinimWatch can bind only to a single interface. This is a limitation of the ohNet UPnP stack that both MinimServer and MinimWatch use. When you start MinimWatch, it binds to the first interface that it finds. You can make MinimWatch bind to a specific interface by editing the minimwatch.config file to set the ohnet.subnet property. You need to add a line like the following:

ohnet.subnet = x.x.x.x

There are two nics eth0 (internet) and eth1 (localnet). The minimserver should bind to eth1. But if minimserver binds to lo,eth0&eth1 I would think that minimwatch should find it when running on the same machine no matter which interface it finds first. If I do a netstat what should i grep to see if minimserver and minimwatch are listening on?
(20-05-2013 18:01)gillecaluim Wrote: [ -> ]There are two nics eth0 (internet) and eth1 (localnet). The minimserver should bind to eth1. But if minimserver binds to lo,eth0&eth1 I would think that minimwatch should find it when running on the same machine no matter which interface it finds first. If I do a netstat what should i grep to see if minimserver and minimwatch are listening on?

If you want MinimWatch to bind to eth1 (localnet), you need to specify this by setting the ohnet.subnet property in minimwatch.config. If you haven't done this, this is probably the cause of the problem.

For eth0 and eth1, what are the IP addresses and subnet masks?

MinimServer and MinimWatch won't bind to lo if any other interface is available.

netstat -lp should show you which programs are listening on which sockets. To grep this output, you could try:

netstat -lp | grep java
trying to debug this with both minimserver&minimwatch running on same computer
netstat -lnptu | grep java
tcp 0 0 192.168.2.8:33965 0.0.0.0:* LISTEN 13704/java
tcp 0 0 192.168.2.8:46777 0.0.0.0:* LISTEN 12923/java
tcp 0 0 0.0.0.0:9790 0.0.0.0:* LISTEN 12923/java
tcp 0 0 192.168.1.1:35393 0.0.0.0:* LISTEN 12923/java
udp 0 0 239.255.255.250:1900 0.0.0.0:* 13704/java
udp 0 0 239.255.255.250:1900 0.0.0.0:* 12923/java
udp 0 0 239.255.255.250:1900 0.0.0.0:* 12923/java
udp 0 0 192.168.2.8:48020 0.0.0.0:* 13704/java
udp 0 0 192.168.2.8:42012 0.0.0.0:* 13704/java
udp 0 0 192.168.2.8:54208 0.0.0.0:* 13704/java


minimwatch appears to be listening on eth0 port 33965
minimserver appears to be listening on eth0 port 46777 | all interfaces port 9790 | eth1 port 35393

it seems that minimwatch isn't listening on any ports that minimserver is using
thanks, Robert
(20-05-2013 20:03)gillecaluim Wrote: [ -> ]trying to debug this with both minimserver&minimwatch running on same computer
netstat -lnptu | grep java
tcp 0 0 192.168.2.8:33965 0.0.0.0:* LISTEN 13704/java
tcp 0 0 192.168.2.8:46777 0.0.0.0:* LISTEN 12923/java
tcp 0 0 0.0.0.0:9790 0.0.0.0:* LISTEN 12923/java
tcp 0 0 192.168.1.1:35393 0.0.0.0:* LISTEN 12923/java

from this it appears that port 9790 is the port that minimserver is listening on? (not attached to specific interface since 0.0.0.0)
but since both minimwatch and minimserver are both java apps....how can I tell who's listening on who?
what ports are they supposed to be using to talk to each other?
thanks, Robert

PID 12923 is MinimServer and PID 13704 is MinimWatch. This means MinimWatch is listening on address 192.168.2.8 only. If you want MinimWatch to listen on address 192.168.1.1 instead, you need to set the ohnet.subnet property in minimwatch.config.

Apart from port 9790 (the default HTTP port for MinimServer), all other port numbers are assigned dynamically.
making progress....adding ohnet.subnet = 192.168.1.0 to minimwatch.conf and restarting
voila! minimwatch finds the server......
now, try to connect via windows laptop( which also has several network interfaces)
where is the minimwatch.conf located in windows?
Pages: 1 2
Reference URL's