MinimServer Forum

Full Version: BBC DASH playlist issues via Melco N1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,
I have been using successfully for over 2 years the BBC DASH playlist method for listening to BBC stations via MinimStreamer (configured on my Melco N1) and rendered via UPnP on my dCS Rossini dac...

However, recently I noticed that I cannot select and play directly a radio stream. (Rossini errors that <<could not add items to playlist. No items were added. (No playitem found.) >> ??

If I navigate via upnp folder view (on the rossini) to the 'BBC Radio DASH' folder and select Play All, then I can jump to the station I want to listen to in the queue (and then radio plays as normal).??

I am using MinimServer 2.0.8 (193) and Streamer 2.0.16, with FULL licence.
Thanks for letting me know about this.

I have reproduced the problem. It is caused by an incompatibility between Mosaic 1.1.3 and MinimServer that only affects radio streams.

I will investigate whether the problem can be fixed on the MinimServer side without changing Mosaic. This will take a few days. I will keep you posted.
Thanks Simon
I have implememented a change to MinimServer that should solve the problem. I need to do some more testing before releasing this change.
(19-07-2021 10:53)simoncn Wrote: [ -> ]I have implememented a change to MinimServer that should solve the problem. I need to do some more testing before releasing this change.

OOO, it would be good to understand what/why there had been a change on Mosaic side?

Thanks for the update.
The change was made to solve an issue related to Mosaic playlists (not MinimServer .m3u playlists). It unfortunately had the unintended side effect of causing a problem with MinimServer .m3u playlists containing radio streams.
This change is now available in MinimServer update 198. Please let me know whether it is working correctly for you.
(02-09-2021 13:14)simoncn Wrote: [ -> ]This change is now available in MinimServer update 198. Please let me know whether it is working correctly for you.

Unfortunately I have the same issue.
My apologies for this. I have sent you a PM with details of a test build that should fix the problem. Please let me know whether the test build works for you.
This fix is now available as MinimServer update 199.
Reference URL's