MinimServer Forum

Full Version: Minimserver can't read files on external drive
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi Minimserver community!

I'm new to the fold and I hope that I can help and contribute too.

I have an issue with my first installation of minimserver. I am running it on a macbook (big sur) and my music is on an exernal hard drive. I have tried to set the directory where my music is and then to do a scan but it returns the error: "unable to list files in content directory"

My Lumin D1 doe pick up the server and the directory share, but there is no music.

BTW, my Audivarna installation is working fine and I did shut it down to test minimserver.

Any help would be greatly appreciated.
Welcome to the MinimServer forum!

If you can see the external drive in Finder, drag it into the MinimServer contentDir field.

Alternatively, you can delete your current setting for contentDir and then follow the instructions in step 8 of this section.
Thanks @simoncn.

I did try that and no luck. Some added info: The disk is shared and tried again with the sharing off. Also it formatted to exFAT (8TB Segate).

Cheers
Can you see the external drive in Finder? If so, please post a screenshot. Also, what exactly happened when you tried the two things I suggested?
Hi

I have attached the screenshot. My external drive is called "My_Book".

I tried both things and when trying a rescan it does not work. I've attached the log file too.

Thanks for your efforts.
Thanks for this. Are you able to view files in My_Book using Finder? If so, please post a screenshot with a Finder window showing these files.

Edit: see following post. If this works, there is no need to post a screenshot.
If you drag the My_Book icon into the contentDir field of the MinimServer Properties dialog, this field should change to /Volumes/My_Book. After this, click OK and do a rescan.
I can see that files on the drive. Screenshot attached.


I did drag and drop and rescan. Still no luck.

Both Audirvana and Roon are reading this device with no issues.

Thanks again for the help.
Thanks for the screenshot. As you can see the WaveCast folder of the My_Book drive in Finder, there is probably a problem with your MinimServer contentDir setting.

To find the correct setting to use for contentDir, do the following:

1) In the Finder window for WaveCast, hold the Option key and click the gear icon
2) In the drop-down menu, click 'Copy "WaveCast" as Pathname'
3) In the main Finder menu on the menu bar, click Edit and then select Show Clipboard

What do you see in the Show Clipboard window? The should be the path that you need to use for the MinimServer contentDir property.

Edit: For some reason, your screenshot doesn't show a gear icon in the toolbar (step 1). This might be hidden under the "3 dots" icon. If not, use View > Customise Toolbar to add the gear icon to the toolbar.
Thanks again @simoncn!

I did what you suggested and this is what is copied to the clipboard:

/Volumes/My_Book/WaveCast

But sadly, the server still cannot list the files in that directory again.

I have tested this with and without file sharing. And I have shut down Roon and Audivarna. As far as I know nothing else is accessing the drive.

Just to re-iterate this external is a seagate 8TB drive formatted to exFAT.

Cheers
Pages: 1 2
Reference URL's