MinimServer Forum

Full Version: Please help
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

I have a Ready NAS Duo V2 running Minim Server. It has worked beautifully for 7 years.
Yesterday, the back up drive in the ReadyNas died. The original drive still seems to be intact, however, I am now unable to access the shared folder.
I tried to upgrade to the latest Minimserver 2 but it gets to 77% and gives the message unrecognised server error occurred. I also have another error: minimserver start up error, Java 7 or later is required. I have tried to download several versions without success.
I am far from being an expert here and really need your guidance please.
I am accessing on Macbook pro 2017 model.

Many thanks in advance.

Are you still able to access the shared folder named "backup"? This is not a separate drive but a folder created by RAIDiator on the main drive.

If you cannot access this "backup" shared folder, there is something wrong with the main drive and it is unlikely that you will be able to install and run MinimServer until this problem is resolved.

If you can access the "backup" shared folder, you should be able to install MinimServer 2 by following the instructions on this page. You don't need to install Java as there is a suitable version of the Java runtime in the MinimServer package.

I have not seen the "unrecognised server" error. Is this the complete and exact text of the message you are seeing when you try to install MinimServer 2? If not, please post the complete and exact text.

MinimServer 2 creates some log files in the "backup" shared folder. Please post the contents of these files. The files are named minimserver.log and minimserver-out.log.
Hi, Yes I can see the folder. Inside I can see the minimserver.log. I dont have minimserver-out.log

MinimServer 0.8.3 update 66, Copyright © 2012-2015 Simon Nash. All rights reserved.
Java™ SE Embedded Runtime Environment (build 1.8.0_51-b07)
Java HotSpot™ Embedded Client VM (build 25.51-b07, mixed mode)
Platform default charset is UTF-8
Language setting is 'en'
starting MinimServer[ReadyNAS]
MinimServer[ReadyNAS] is running

Tried what you suggested and get unrecognised server error has occurred at 44%. I am adding this at add ons > Minimserver > new add on > browse > MinimServer-2.0.16-readynas-arm.bin

Excuse my lack of knowledge. Could the share protocols be the cause of this?
I use a Linn hifi with Kazoo. It sees both minimserver & Readynas Duo V2 but they are unavailable under media servers.

Ive been at this for past 6 hours now.
Do you get the unrecognised server error during the "Uploading" phase or during the "Installing" phase?

I would expect it to be happening during the "Uploading" phase. This means there is an issue with communication between the server and the browser you are using to do the upload. From a web search for this error, a few other people have seen this with other add-on packages. In some cases they could work around it by using a different browser.

Do you have another computer or another browser you could try? If you are using a wireless connection, could you try wired instead? Is anything else running on your computer that is taking a lot of CPU or memory and could interfere with the upload?
It is the uploading phase.
Just connected my windows 10 laptop, brand new with nothing else running. Same issue.
Tried using Safari as browser rather than Chrome. Same issue.
Just plugged direct into the router via cable. Same issue

update: tried using older version of IE.
It installed however now have error: Minimserver Start up: Integrity Check value missing for minimserver.config
Glad to hear that using IE fixed the problem. The upload and install is working for me with the latest Firefox but I do need to select TLS 1.0 when logging into the ReadyNAS.

You are getting this "integrity check" error because you are migrating from a very old version of MinimServer. To complete the update to MinimServer 2, you will need to delete your previous configuration file.

Do you remember your previous configuration settings? If so, uninstall MinimServer 2 and select the option to not preserve your previous configuration and data. After this, install MinimServer 2 again and it should work. You will then need to reapply your previous settings.

If you don't remember your previous configuration settings, you should make a copy of your previous configuration file before you do the above. Let me know if this applies and I will provide instructions.
Hi, are you referring to the previous copy still in the backup folder?
I believe it’s still there. I haven’t deleted it or been asked to.
If you can send me the detail in advance I’d very much appreciate it.
The minimserver.config file isn't in the "backup" shared folder. It is in the /etc/frontview/addons/bin/MINIMSERVER/data folder. This isn't a shared folder, so you need to login to the NAS using ssh (from Windows, use putty) to access this file. To copy this file to the "backup" shared folder, enter the following command in the ssh terminal window:

cp -p /etc/frontview/addons/bin/MINIMSERVER/data/minimserver.config /c/backup
Im sorry, this is completely alien language to me.
I dont know what SSH or putty is?

Apologies, can you offer any further guidance Simon.
Please confirm whether or not you have changed your MinimServer configuration setttings from the defaults. If you have done this, do you remember what changes you made?
Pages: 1 2
Reference URL's