MinimServer Forum

Full Version: ReadyNAS V0.71 java heap space error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Hi,

I've installed MinimServer V0.71 in my ReadyNAS NV+ V2 (ARM).

It workes fine with a relatively smal database (about 8000 MP3s).

Now I have extended the numer of files (135000 MP3s) and the MininServer
crashes with the following message (end of the log):

Scanning directory Jive Bunny - The Best Of (Complete Album)
java.lang.OutOfMemoryError: Java heap space
at java.util.Arrays.copyOf(Arrays.java:2367)
at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:130)
at java.lang.AbstractStringBuilder.ensureCapacityInternal(AbstractStringBuilder.jav​a:114)
at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:415)
at java.lang.StringBuilder.append(StringBuilder.java:132)
at com.minimserver.Server.readMetadata(Server.java:4236)
at com.minimserver.Server.scanFiles(Server.java:3027)
at com.minimserver.Server.scanFiles(Server.java:3600)
at com.minimserver.Server.scanFiles(Server.java:3600)
at com.minimserver.Server.scanFiles(Server.java:3600)
at com.minimserver.Server.readFiles(Server.java:2587)
at com.minimserver.Server.doStart(Server.java:1452)
at com.minimserver.Server.start(Server.java:382)
at org.jminim.core.ContextImpl.startComponent(ContextImpl.java:156)
at org.jminim.core.ContextImpl.start(ContextImpl.java:84)
at org.jminim.core.RuntimeImpl.run(RuntimeImpl.java:393)
at org.jminim.core.LauncherImpl.run(LauncherImpl.java:681)
at org.jminim.core.LauncherImpl.launch(LauncherImpl.java:85)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.jav​a:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.jminim.launch.Launcher.launch(Launcher.java:64)
at com.minimserver.launch.LaunchServer.main(LaunchServer.java:23)

Does anyone have an idea how to solve the problem?
Guenter
(27-04-2013 09:44)guenter55 Wrote: [ -> ]Hi,

I've installed MinimServer V0.71 in my ReadyNAS NV+ V2 (ARM).

It workes fine with a relatively smal database (about 8000 MP3s).

Now I have extended the numer of files (135000 MP3s) and the MininServer
crashes with the following message (end of the log):

Scanning directory Jive Bunny - The Best Of (Complete Album)
java.lang.OutOfMemoryError: Java heap space

Does anyone have an idea how to solve the problem?
Guenter

Please set the resourceInfo property to 1000 and restart MinimServer. When it crashes, zip the log file and attach it to a post here. Many thanks!
(27-04-2013 10:33)simoncn Wrote: [ -> ]Please set the resourceInfo property to 1000 and restart MinimServer. When it crashes, zip the log file and attach it to a post here. Many thanks!

Thank you for your support!

I have done so (resourceInfo=1000) and here is the log file:
[attachment=159]
(27-04-2013 15:19)guenter55 Wrote: [ -> ]
(27-04-2013 10:33)simoncn Wrote: [ -> ]Please set the resourceInfo property to 1000 and restart MinimServer. When it crashes, zip the log file and attach it to a post here. Many thanks!

Thank you for your support!

I have done so (resourceInfo=1000) and here is the log file:

Thanks for sending this.

From what I can see in this log file, the heap usage was 94100000 bytes after 11000 tracks and stayed at the same level until 63000 tracks were read. The figure after 11000 tracks is much too high (it should be about 7000000 bytes), so I'll need to find out what happened during the first 11000 tracks that used the extra 87000000 bytes.

Unfortunately, the log doesn't contain any resource information for the first 11000 tracks. This is because the log window is limited to the last 500000 bytes of log data, and a lot of this space is taken up by additional log messages produced by the logging level being set to Verbose.

It's possible that the high 94100000 figure was caused by previous MinimServer activity before MinimServer was restarted. To eliminate this possibility, please do the following:

1) Set the logging level to Info
2) Leave resourceInfo set to 1000
3) Disable MinimServer in Frontview
4) Enable MinimServer in Frontview
5) When you get the OutOfMemoryError, save the log file (hopefully complete this time), zip it and attach it here

Many thanks!
I think I know what's causing this problem. I'm working on a fix now.
(28-04-2013 20:11)simoncn Wrote: [ -> ]I think I know what's causing this problem. I'm working on a fix now.

I was out on the weekend, so I couldn't work on that task.
This night I did a restart (by the way, I couldn't find a 'disable' or 'enable' command - so I 'stop'ed and started again by resetting the NAS)
and what should I say - the run competed.
The only change I did was restarting the NAS and limiting the log to 'info'.

Guenter
(29-04-2013 07:32)guenter55 Wrote: [ -> ]I was out on the weekend, so I couldn't work on that task.
This night I did a restart (by the way, I couldn't find a 'disable' or 'enable' command - so I 'stop'ed and started again by resetting the NAS)
and what should I say - the run competed.
The only change I did was restarting the NAS and limiting the log to 'info'.

Guenter

Thanks for letting me know. This is consistent with the problem that I discovered yesterday. It will be fixed in the upcoming 0.72 release.
[/quote]
Thanks for letting me know. This is consistent with the problem that I discovered yesterday. It will be fixed in the upcoming 0.72 release.
[/quote]

Simon, thank you for the new 0.72 release.
I installed it (without any problems).
But now again I have the Out of Memory error.
I have to admit that I added further files to the music folder
(now about 500.000 music files).
MinimServer crashed after processing 270.000 of them.
Unfortunately the begin of the log is again missing due to a big number of
warning because of ID-tags that obviouely aren't conform to the standard.
Is there a possibility to suppress these warings?

Guenter
(30-04-2013 12:03)guenter55 Wrote: [ -> ]Simon, thank you for the new 0.72 release.
I installed it (without any problems).
But now again I have the Out of Memory error.
I have to admit that I added further files to the music folder
(now about 500.000 music files).
MinimServer crashed after processing 270.000 of them.
Unfortunately the begin of the log is again missing due to a big number of
warning because of ID-tags that obviouely aren't conform to the standard.
Is there a possibility to suppress these warings?

Guenter

I've looked at the log, and the memory usage seems normal for this number of files.

MinimServer wasn't designed to handle 500,000 files, and I'm not sure how well it will work with such a large library. To get through the startup phase, you'll need to increase the Java maximum heap size to 256 MB (see instructions below). After this, you might encounter further problems. For example, the total RAM size on the NV+ v2 is only 256 MB, so MinimServer will consume all available RAM and this might cause the NAS to run very slowly. I'll be interested to hear your experiences.

To increase the Java maximum heap size, you need to edit the file /etc/frontview/addons/bin/MINIMSERVER/start.sh and change line 62 from:

LD_LIBRARY_PATH=$MINIMSERVER/libsys $JAVA -jar ../lib/minimserver.jar --noconsole </dev/null >$OUT_FILE 2>&1 &

to:

LD_LIBRARY_PATH=$MINIMSERVER/libsys $JAVA -Xmx256m -jar ../lib/minimserver.jar --noconsole </dev/null >$OUT_FILE 2>&1 &

To get access to this file, you need to install the "Enable root SSH access" ReadyNAS add-on. After installing this, you can login as root and edit the file directly on the NAS, or you can use WinSCP to copy the file to a Windows PC, edit it there, and copy the modified version back to the NAS.

After editing this file, use Frontview to stop MinimServer and then restart it. You need to do this restart from Frontview, not from MinimWatch.
Simon,

Congratulations! good work!

I followed your instructions - and it worked.
My complete music collection is tagged and MinimServer is running.

The last resource info showed 466,000 files read.
The run time was not worse then expected.

regards, Guenter
Pages: 1 2 3
Reference URL's