MinimServer Forum

Full Version: Convolution filtering
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I have the following settings:

[attachment=1855]

How can I tell that this settings actually works?

Thanks!
In the MinimServer log window, set the logging level to Verbose. When you play a file, you should see a message telling you which convolution file has been selected.
When setting the log to "verbose" nothing is shown. I set it to "debug" and some data started showing up. Have a look at the attached. Still not sure that convolution works...
The debug log shows that you are playing a FLAC file. As you have transcoding enabled for DSF files only, no other filetypes will have convolution applied. To use convolution with FLAC files, you need to add flac:wav; or flac:wav24; (the semicolon is important) to stream.transcode.
OK. Some progress. Just to be clear:

1. I need to create one convolution file per sampling rates (44.1, 48, 88.2, 96, 176.4,192)?
2. Output can only be fixed at 16bit or 24bit?
3. Output can only be WAV?

Thanks!
(16-02-2020 16:44)rompolompo Wrote: [ -> ]1. I need to create one convolution file per sampling rates (44.1, 48, 88.2, 96, 176.4,192)?

This should in theory give better quality but having one convolution file for all sample rates will work.

Quote:2. Output can only be fixed at 16bit or 24bit?

No, you can have multiple transcoding combinations and these can have input type filters. This allows you have different bit depths for the transcoding output.

Quote:3. Output can only be WAV?

No, it can be any output type that is supported by MinimStreamer and uses a stream converter program.
Simon,. Can you please provide an example to #2 and #3?
(16-02-2020 19:11)rompolompo Wrote: [ -> ]Can you please provide an example to #2 and #3?

#2 and #3
Refer to Transcoding

flac:wav
flac:wav24
flac:wav24;192
aac:mp3
mp3:mp3;64k
*:L16
*:wav
*:wav-4095MB
dsf:dopwav
dsf:wav24;176

#2
Refer to Input type filters

flac:wav, flac(>24;192):wav, flac(16;44):wav24;96
How do you set the out put to be FLAC? Also, the site does not mention how to specify 16bit transcoding for 16bit files and 24bit transcoding for 24bit files. Can you please use real examples I can use in the configuration.
You cannot transcode to FLAC. The setting flac:wav; transcodes 16-bit FLAC files to 16-bit WAV and 24-bit FLAC files to 24-bit WAV, with convolution filtering if specified in the stream.options property. Note that the semicolon at the end is required in order to use convolution filtering.
Pages: 1 2 3
Reference URL's