MinimServer Forum

Full Version: Internet Radio
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
1st post from new member with very limited computer understanding.

I own a Melco player which contains minimserver originally loaded by the dealer but which I've never knowingly used even though I was advised to install both minimserver and minimwatch on my windows 10 laptop which I did but quickly got lost when I tried to use it.

I have controlled my music collection on the Melco by using either the Melco HD user app or Mcontrol HD without difficulty and have been able to play internet radio by using v-Tuner when using MControl.

I recently introduced a Matrix Audio X-Spdif device in order to convert the USB output from the Melco to feed the I2s inputs on my PS Audio Direct Stream Dac and have experienced an uplift in sound quality when used in this configuration controlled by the Melco HD app.

Unfortunately, when I now try to use v-Tuner I get an error message saying the selected device doesn't support v-Tuner. I have therefore reacquainted myself with minimserver and have downloaded minimstreamer which seems to indicate that it might be possible to get internet radio.

However, having looked at the user guide I'm afraid I am completely lost in terms of understanding the various options that are discussed. I do not even understand how to find or create m3u playlists etc, etc.

And so, apologies for the length of this posting but can someone tell me in a simple step by step guide whether I can indeed get internet radio with my existing set up.

Thanks
Welcome to the MinimServer forum!

See this page for a step-by-step guide for playing BBC radio streams. If you are able to get this working in your setup, it should not be too difficult to add other internet radio streams.
Simon,
Thanks for responding so promptly and for the attached link. I will have a go at working my way through the various steps tomorrow and see how I get on.
Well I've spent quite a lot of time trying to follow the step by step guide but with no success. When I try to enter the name of the new BBC Radio folder I created into the content directory of minimserver located on my laptop I get a red message saying 'not an absolutepath; correct highlighted value and try again'

And so I've tried entering the folder 'BBC Radio' and then the name of the text file in that folder 'BBC Radio DASH.m3u' but neither are accepted. Although I've never used Notepad before I have confirmed that the text file saved in the BBC Radio folder has been saved with the ANSI encoding.

Not sure if its relevant but when I try to enter the name of the new folder into the content directory, there is already an existing entry relating to music files and so I've clicked on the + sign which opens a new directory box which I tried to use for the name of the new radio folder/file.
Are you running MinimServer on the Melco or on your laptop? Also, have you created the BBC Radio folder on the Melco or on your laptop?

If you are running MinimServer on the Melco and you have created the BBC Radio folder on the Melco, you should not need to add anything to the contentDir Setting because the default setting for the Melco is to scan everything on the Melco hard drive(s).

However, from your post, it sounds like the contentDir setting is not the default setting for the Melco. Perhaps the dealer has changed this from the default.
I can do my best to provide answers and further information to these points but wondered (partly to avoid further personal embarrassment) whether you would prefer me to do so via PM or here in open forum?
As you are having difficulty with this, it is very likely that others are having similar difficulty or will have similar difficulty in the future. Having the discussion on the open forum provides valuable information for these other users. For this reason, my preference is to keep discussions of this nature public on the forum.

I can assure you that there is nothing that you have posted yet that should cause embarrassment and this forum is a friendly place where we are all trying to help each other and learn from each other to solve whatever difficulties we are experiencing. This would not be the case for some other online forums.

Also, perhaps it is me who should be embarrassed because the documentation I have provided for setting this up is not sufficiently clear. Smile
I feel sure that for those who are more familiar with using and adjusting settings on computers that your existing instructions will be more than adequate. I am particularly incompetent in understanding how these things work!

Okay, so the dealer that sold me the Melco (it's a HA-1NZ) kindly installed Minimserver and upon clicking the green icon (showing the Melco's friendly name) the packages tab shows ''ffmpeg-4.1-Melco-0.1'' and ''minimstreamer-0.7.15''. The contentDir has three entries:-
/mnt/disk1/share
/mnt/expansion1
/mnt/expansion2

I also have minimserver and minimwatch installed on my Windows 10 laptop. If I click on the green icon (showing my laptop name) the packages tab shows ''minimserver-0.8-update-133'' and ''minimstreamer-0.7.15''. The contentDir has just one entry:-
''C:\Users\jj-mj\music''

I created the ''BBC Radio'' folder containing the ''BBC Radio DASH.m3u'' text file on my laptop and it is when I try to enter either the folder name or the text file name (exactly as shown above with a space) in a new contentDir box that I get the red error message 'not an absolutepath; correct highlighted value and try again'.

Does this additional information help you to spot what I'm doing wrong?
Thanks for the additional information. Your setup on the Melco is fine. On your laptop, you need to use a full absolute path such as C:\folderpath\BBC Radio (just an example, use the correct drive and path from your system).
Okay thanks. I seem to have made one step forward. I found the full folderpath for the BBC Radio folder and entered this into the contentDir box of the minimserver located on my laptop. This entry was accepted this time.

I then started the Melco HD app on my iPad and upon clicking on the minimserver icon for my laptop it shows an icon entitled [folder view] which if I click on shows two further icons 'BBC Radio' and 'music'. Both icons when clicked show another icon 'Tag View' which are both empty when opened...

Having read the 'Playing BBC MPEG-Dash' user guide I have further tried entering both 'aac:L16' and 'aac:wav' into the stream transcode box of the minimserver on my laptop but get the same red message each time ''Transcodesetting 'aac:L16' and 'aac:wav' requires a converter; correct highlighted value and retry''
Pages: 1 2 3 4
Reference URL's