MinimServer Forum

Full Version: Cannot install Minimserver after rolling back to Melco firmware v3.80
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am having problems with v3.90 firmware on the Melco N1 and want to rollback to v3.80. Unfortunately I can't get Minimserver 0.8.5.4 working again.

My steps were:

1. Uninstall Minimserver 0.8.5.4. The logs tell me the uninstall was successful.
2. Rollback the Melco to v3.80. Again successful.
3. Re-install Minimserver 0.8.5.4 following the instructions for a fresh install. After the restore settings prompt the Melco reports 'cannot restore from newer version'.

If I re-install 3.90 then everything works and I can re-install Minimserver 0.8.5.4 as normal.

I assumed rolling back firmware on the Melco would completely clean Minimserver which seems to be the case as trying to uninstall or update rather than re-install does nothing. The files are still on the hard drive however.

Is there a way to make this work?
I have tried this with 3.80 and MinimServer 0.8.5.4 is installing successfully. Before doing this, I ran Initialize Settings on 3.80.

The message you are seeing would be produced if you are trying to restore settings from a MinimServer 0.8.5.4 flash drive on a firmware version older than 3.80.

Removing MinimServer, initializing the Melco settings or downgrading the firmware uninstalls MinimServer and leaves the MinimServer files on the hard drive. This is intentional and should not cause any problem when reinstalling MinimServer.
Tried initialize settings and a re-install in v3.80 and still getting the 'cannot restore from newer version' message. The firmware is definitely v3.80. I've been running nothing older than this for a long time.
Are you using final 3.80 release or a beta version?

I have tried to check that I am using the final release but the download link for 3.80 is broken.
I've been sent a custom link by Melco -> https://clicktime.symantec.com/3Gmw5XLFw...NnAHXoCqbG
Thanks for this. I have verified that the problem occurs with this firmware file (version 3.80, build date 2018/05/09) but not with the firmware that I have on my N1A (version 3.80, build date 2018/05/11). I am working with Melco to try to resolve this issue.
The broken link on the Melco Downloads page is now fixed. If you download the 3.80 firmware from this page, you will be able to install MinimServer 0.8.5.4.
Yes that's fixed it. Downloaded the updated v3.80 from the repaired link and now able to re-install Minimserver 0.8.5.4. Thanks for your help with this. If this doesn't help to fix the original problem it would be nice if older versions of Minimserver were available to rollback to.
Reference URL's