MinimServer Forum

Full Version: Bose Soundtouch 20 Compatibility
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Simon,

Let me start by saying thank you and what a great programe you have. I have done a heap of investigation, post purchase, which has lead me to your server.

I am trying to get my music collection, currently stored on a QNAP NAS TS-251+, to play on my soundtouch 20. I also have a couple of soundtouch 300 soundbars I have recently bought to install when I move house shortly and have not currently tried to play anything on them yet.

The soundtouch 20 is currently on firmware update 20.0.10. The QNAP is running QTS build 20190328 firmware.

A number of posts on the Bose website point to your server potentially being the key component to getting the Bose speaker to see the music on the NAS?

I have tried using the Bose app on my PC, phone and I-Pad to play something via your server, but it just stops as soon as you hit play. I have run minimwatch and checked and resolved all issues in the log and am now at a bit of a loss as to why it is still not playing anything via the Bose App?

The app can see my collection, it just won't play anything on the soundtouch?

I have also tried using Hi-Fi Cast and mConnect Lite via my Android phone but none of them seem to be able to see the Bose speaker? I can however play everything via the phone from the NAS.

Any help would be gratefully received! I am starting to think I am being stupid and missing something really obvious?

Many thanks

What format are your music files? Bose says "Supported audio formats: MP3, WMA, AAC, FLAC, Apple Lossless" but I'm also pretty sure it can only play 16-bit
Hi timster,

I've checked and I can't see any files that wouldn't meet the criteria, but I will do a more thorough check with mp3tag just to make sure.


This sounds like a problem with your network. Other users have been able to use H-Fi-Cast to play music from MinimServer to the SoundTouch (see this thread). As Hi-Fi Cast can't see your SoundTouch, this suggests there might be a problem with your network blocking uPnP multicast discovery messages. For some suggestions, see the comments about multicast and IGMP in this section.
Thanks, at long last I have managed to get everything talking to each other! I just slowly went through re-setting everything on the network and making them discover-able as new. I think it was hard re-setting the Soundtouch that was probably what was needed, but every now and again it's good for a re-boot right!

I am even able to use the Bose App with your great server! Now I just need to painfully go through and check all the tags are correct!

The wife is happy she can now play her songs and you know what they say.... happy wife, happy life!
Reference URL's