MinimServer Forum

Full Version: minimwatch does not see minimserver
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I am running minimserver 0.8.5.3 update 128 on a DS411Slim Synology NAS, and minimwatch 0.8.5.3 update 62 on windows 7.

I had strictly no problem until recently, where minimwatch icon remains grey.
I am able to access minimserver gui when logged on the NAS, and checked it works as expected.
I disabled firewall on Windows and in the NAS, no change.
I also completely stopped my antivirus (Panda), no change.

My PC's IP is 192.168.1.100, and my NAS's IP is 192.168.1.64, network mask is 255.255.255.0
They are both connected to my internet provider box (livebox 4)

I went in minimwatch Properties, and tried to change the ohnnet.debug to 192.168.1.0 as advised in the network section of minimwatch, but it said that it's invalid ?
I tried different IP, no way, the only input that is accepted is "default"

Thanks for helping
You need to set ohnet.subnet to 192.168.1.0, not ohnet.debug.
Yes, just realized that after posting, it works fine now.
But I dont' understand why I need to set this now, I never needed to set it before ??
Thanks.
From a Windows command prompt, type:

ipconfig /all

This shows a list of all your network adapters. For each of these, if there is a line starting "IPv4 Address", ohNet detects this as a usable network adapter. After ohNet has identified all usable adapters, it picks one of these at random unless you have set ohnet.subnet to force the correct choice.

When you have identified the incorrect adapter that ohNet is picking at random, it might be clearer why this adapter has recently appeared as part of your Windows setup. The other possibility is that this adapter was always present but by some random chance it wasn't being chosen by ohNet.
I changed my router, everything runs fine, alas MinimWatch not. MinimWatchIcon stays gray since today.
MinimWatch searches the MinimServer at Port 9791 but the Server runs at Port 9790. I recognised that the first time, since Minim runs fine without any hassles since years!

Log:

Retrying monitor subscription for server at 10.0.0.91:9791 (attempt 18)
Retrying monitor subscription for server at 10.0.0.91:9791 (attempt 19)
Retrying monitor subscription for server at 10.0.0.91:9791 (attempt 20)
Retrying monitor subscription for server at 10.0.0.91:9791 (attempt 21)
and so on

What happened?
These messages are caused by a firewall on the machine running MinimWatch blocking inbound communication from MinimServer. If you are running MinimWatch on Windows, see this post for a solution. The port numbers are correct (9790 for HTTP, 9791 for UPnP).
Reference URL's