MinimServer Forum

Full Version: FFmpeg 4.1 support
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I tried to update ffmpeg-armhf-32bit-static from v4.0.2 to v4.1, but MinimServer show this error:

MinimStreamer: incorrect FFmpeg version

Regards
FFmpeg 4.1 is working for me. When you uploaded the ffmpeg static binary executable to the NAS, did you set execute permission on the uploaded file? This is required to enable ffmpeg to run.
No, I just copy the new ffmpeg and override the older one...

I upgrade from v4.0.2 to v4.0.3 and works fine, but not with v4.1.
Apologies for the slow response. I was away from home without access to my Synology DS115. I have now tried this on my DS115 and I see the same issue. It is caused by a change in how FFmpeg 4.1 parses and checks the command line and it will be fixed in the next release of MinimStreamer. It only affects Synology and this is why I had not seen it when running FFmpeg 4.1 on other platforms. Thanks for letting me know about this.
Thanks a lot for your support...

Happy New Year! Wink
Do you know when the new version of MinimStreamer will be released, with this issue fixed?

Thanks
There is a test build that you can try. To install it, do the following:

1) Select the Packages tab in the Properties window
2) In the 'Other package' tab, type: minimstreamer-0.7.10.3
3) Click Install and follow the prompts to install the package
4) When installation has completed, click Relaunch to relaunch MinimServer and MinimStreamer
It seems to be working fine with FFmpeg 4.1 Smile
The fix for this problem is now available in MinimStreamer 0.7.11.
Thanks!
Reference URL's