MinimServer Forum

Full Version: MinimWatch problem on Mac mini 2018
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just bought a new Mac mini 2018. This Mac contains the 'T2 chip' which might cause the problem I have. I have MinimServer running on a Synology NAS and I am using an old Mac mini and now a new one also. Settings in MinimWatch are the same on both. On the new Mac mini MinimServer is not seen by MinimWatch. I tried defining a subnet in 'ohnet.subnet' but that does not help.
On the new Mac mini I can mount the content directories of the NAS, so there is a connection.
I tried MinimWatch on a iMac running the same MacOs as the new Mac mini. No problem with MinimServer on that iMac.
Any help getting MinimWatch running on the new Mac mini would be appreciated
Please read this section carefuly, in particular steps 4, 5, 6 and 7. Did you follow all these steps exactly when you installed MinimServer on the new Mac mini?

The problem you are having might be caused by incoming connections to MinimServer being blocked by the Mac firewall. For incoming connections to work, MinimServer must be in the Applications folder (step 4) and there must be an entry in the firewall table to allow MinimServer to receive incoming connections (step 7). Please check both of these.

Also, please check that MinimServer is running by typing x.x.x.x:9790 into a web browser address bar, where x.x.x.x is the IP address of the new Mac mini.
I did not install MinimServer on the new Mac mini. MinimServer runs on my NAS. I have problems with MinimWatch not discovering MinimServer on the NAS. In my browser I see MinimServer running and I can do a rescan from there.
There is no firewall and I tried everything mentioned in the troubleshooting section. Minimwatch discovers MinimServer when running on other Mac's in my setup. Therefore I think something in the new Mac mini causes the problem for Minimwatch. The new Mac mini has the T2 chip which has various settings for security. Changing these settings does not help either. So I am stuck. That's why I asked here for help:-)
I didn't realise that MinimWatch is runnng on the new Mac mini, not MinimServer. In that case, the same comments apply about firewall settings etc. but in relation to MinimWatch rather than MinimServer. I don't think the issue is related to the T2 chip.
I tried all you advise in troubleshooting. I have MinimWatch running on several Mac's. Only this new Mac mini causes problems. Next week I'll get another new Mac mini. I will try then on the new one and see what happens.
As I said before I can rescan etc. in my browser, but I like to use MinimWatch for that.
See this post for another possibility. Are you using Little Snitch?
Yes, I am using Little Snitch 4 on a Mac mini running a clean install Of MacOs Mojave. When I switch it off MinimWatch is working fine.
On another Mac I am also using Little Snitch 4 without problems with MinimWatch. This Mac runs also MacOs Mojave. The difference is the MacOs Mojave was installed as an upgrade on MacOs High Sierra.
So, my conclusion is that Little Snitch 4/MacOs Mojave (clean) is the problem here. On the website forum are many threads about problems with this combo.
Reference URL's