MinimServer Forum

Full Version: minim server startup failed
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Problem - Log message "integrity check failed for file minimserver.config".

Have downloaded minim server 0.8 update 123 on iMac (previous version deleted).

iMac (retina 5k 2017) is running macOS High Sierra 10.13.6.
Safari 11.1.2

Java 8 Update 181 build 13 is installed

Any help appreciated.
Private email sent.
Hi, I am getting the same issue after updating to :
"MinimServer, Copyright © 2012-2017 Simon Nash. All rights reserved.
MinimStreamer 0.7.7, Copyright © 2012-2018 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_181-b13)
Java HotSpot™ 64-Bit Server VM (build 25.181-b13, mixed mode)
Java runtime options: -Dfile.encoding=UTF-8
Platform default charset is UTF-8
Integrity check failed for file minimserver.config
Startup complete"

I cannot find a minimserver.config at all on my system..
Regards, Mark
Please try the following:

1) From the red minim icon, select Properties
2) From the Properties window, select Packages
3) In the 'Other package' field, type: minimserver-0.8-update-124
4) Click Install and follow the prompts
5) When installation has completed successfully, click the Relaunch button
6) You should get a red minim icon with a message "integrity check error; no backup available"
7) From the red minim icon, select Relaunch
8) MinimServer should start normally

Edit: changed package name from test build to official release
Hi Simon,
That worked ! I did have to restart my Mac but now all is fine and music has returned to my home.
Thanks very much,
Thanks for trying this and I'm pleased to hear that it worked. Why did you need to restart the Mac?
At the '2nd Relaunch' stage' (point 7) nothing happened..
The icon became unresponsive so I restarted the computer and then all was well.
Thanks, I will try this on a Mac to check.
I have tried this on my MacBook and all steps worked as expected. It seems likely that the issue with the unresponsive icon was a one-off rather than something that would affect all users.
The fix described in post #4 above is now available in MinimServer update 124.
Reference URL's