MinimServer Forum

Full Version: convolution with acourate fir filter
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6
I understand I can use convOut to apply the convolution filter produced by Acourate. Acourate has given me a stereo wav file for 192kHz (Cor1S192.wav).

In stream.transcode I have entered flac:wav24;192 so all the files are converted to 192KHz.

I'm running minimserver on a QNAP TS-253 Pro.

minimstreamer-0.7.6 is in the list of installed packages.

What do I need to enter in stream.options?

Many thanks

Mark
This should be possible but it requires some changes to MinimStreamer to make it work. I will post back here when I have more information.
Thank you Simon

Note I don't have to convolve at 192kHz, if that is the problem. 96 or 44.1 are also possibilities.

Mark
This isn't the problem. The issue is related to how MinimStreamer handles the stream.options property. I will keep you informed of progress.
PM sent.
Hi Simon,
I would be interested as well. Do you have any update on this possibility ?
thanks
David
Testing is in progress. If and when there is a solution, I will post an update here.
Support for FIR convolution files is available now in MinimStreamer 0.7.7. For this to work, you must be using FFmpeg 3.4.0 or later.

A simple way to apply a FIR convolution file is to specify the following in stream.options:

convOut=-i f:\mark_gb\Cor1S44.wav -lavfi afir

where f:\mark_gb\Cor1S44.wav is the convolution file. Unfortunately, this introduces a delay in each track which is heard as a slight gap between tracks. This delay can be eliminated by configuring FFmpeg to remove the initial portion of each track, as follows:

convOut=-i f:\mark_gb\Cor1S44.wav -filter_complex [0]apad=pad_len=32768[2];[2][1]afir[3];[3]atrim=start_sample=32768

This eliminates the gap by removing the first 32768 samples of each track but there is still a slight click between some tracks. I don't how how to stop this happening.
(17-06-2018 22:12)simoncn Wrote: [ -> ]Support for FIR convolution files is available now in MinimStreamer 0.7.7. For this to work, you must be using FFmpeg 3.4.0 or later.

A simple way to apply a FIR convolution file is to specify the following in stream.options:

convOut=-i f:\mark_gb\Cor1S44.wav -lavfi afir

where f:\mark_gb\Cor1S44.wav is the convolution file. Unfortunately, this introduces a delay in each track which is heard as a slight gap between tracks. This delay can be eliminated by configuring FFmpeg to remove the initial portion of each track, as follows:

convOut=-i f:\mark_gb\Cor1S44.wav -filter_complex [0]apad=pad_len=32768[2];[2][1]afir[3];[3]atrim=start_sample=32768

This eliminates the gap by removing the first 32768 samples of each track but there is still a slight click between some tracks. I don't how how to stop this happening.

This looks very interesting. Thank you.
Does this feature now provide a need to invoke transcoding for wav files? Or have I missed the obvious?
This feature can be used only when FFmpeg transcoding is in effect and this is supported only for the filetypes shown as input types in this section. Because wav isn't one of these input types, you can't use this feature with music stored in .wav files. You can use it for any other filetype that can be transcoded to wav.
Pages: 1 2 3 4 5 6
Reference URL's