MinimServer Forum

Full Version: Radio problems
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have a strange problem with the radio. I have minimstreamer installed and can play the higher resolution bbc channels no problem, but I cannot for the life of me get a 320kbps radio paradise stream working with bubble upnp. I'm using mpd on debian with upmpdcli on a headless PC Engines APU board. I can use bubbleds next radio channels but I would like to figure out what I'm doing wrong as it would be good to add more and the radio paradise is a lower resolution.

I'm not transcoding anything as i think if it can play the bbc stations it should play the others and I know that mpd can decode aac with ffmpeg? I split the playlist into 2 under my main music directory to make it easier to change just the radio paradise and it makes no difference if they are all in one file. I've included a trace log of the stream being opened and the m3u of my streams as attachments.



16:57:04.993 Thread-21: Monitor response: SaveProperty
16:57:04.993 Thread-21: ErrorMsg=
16:57:09.775 Thread-23: ContentDirectory action: Browse 0$folders$f5185$*p987
16:57:09.775 Thread-23: version=1, adapter=, uriPrefix=, clientEndpoint=
16:57:09.775 Thread-23: BrowseFlag=BrowseDirectChildren StartingIndex=0 RequestedCount=16 Filter=* SortCriteria=
16:57:09.775 Thread-23: using resource URI prefix
16:57:09.775 Thread-23: adding container to cache: 0$folders$f5185$*p987
16:57:09.776 Thread-23: browsing children of container com.minimserver.Server$PlaylistContainer@231140d7
16:57:09.776 Thread-23: ContentDirectory response: Browse 0$folders$f5185$*p987
16:57:09.776 Thread-23: NumberReturned=1 TotalMatches=1 UpdateID=36
16:57:09.776 Thread-23: Result=<DIDL-Lite xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlnsBig Grinc="" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/"><item id="0$folders$f5185$*p987$*c12" parentID="0$folders$f5185$*p987" restricted="1"><dc:title>aac-320</dc:title><res protocolInfo="http-get:*:*:*"></res><upnp:class>object.item.audioItem.audioBroadcast</upnp:class></item></DIDL-Lite>
Your Radio Paradise playlist is missing #EXTM3U at the start. This will point the renderer directly at the stream instead of having the stream routed via MinimStreamer, which might cause issues with some renderers.
Thanks for the reply. Still doesn't work. Bubbleupnp refuses to add it to the playlist but will add the bbc channels happily. I checked the capabilities of the mpd through bubbleupnp and it says aac is included in the formats it can decode.

Edit: I'm sure it's something really simple that I'm not doing but cannot figure it out!
Did you do a Rescan after updating the .m3u file?
yes, full rescan. Even shutdown and restarted the server to be sure, i made sure that autoscan on start is enabled through minimwatch.. Are there any other logs I can provide? By the way minimserver is running on a hp microserver with a very minimal debian. Could there be something I need to install on the server?
In your BBC Radio.m3u file, you have added aac as the stream type. You should do the same in your Radio Paradise.m3u file, then rescan. The file should contain the following:

#EXTINF:-1,[RPA;aac] Radio Paradise 320
You are a star!! That fixed it, radio paradise in all its glory! A case of rtfm... :-)
Reference URL's