MinimServer Forum

Full Version: Error after upgrading to 8.5 - Synology and QNAP
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi
I have been updating my MinimServer package on both my Synology 215 (Arm 7) and QNAP 210 NAS drives. Both times, I received the same error. As the new version starts, I get the following message: Incorrect option name 'sortValue.ignoreThe' in property 'tagOptions'

I have this set under 'tagOptions' - all.sortValue.ignoreThe, Album.sortTags={Album, Artist}

On my QNAP, I uninstalled MinimServer and then re-installed it. However, the new installation had removed all of my Server Properties options. When I tried puting these back in (I added my old 'alphaGroup' and 'indexTags settings', I got a message reporting a JAVA error and then my QNAP MinimServer stopped.

My alphaGroup setting is: Artist=100, albums=100, Composer=100, All Artists=100, Conductor=100, Orchestra=100, Soloists=100

My index Tags setting is: Artist, Date, Genre, All Artists, Composer, Conductor, Orchestra, Composition, Soloists, -#AudioData, #AudioFormat

Clearly something is up. Any ideas?

Steve
Quick update: I restarted MinimServer on the QNAP and it seemed to run with my alphaGroup and index Tags settings shown above. However, when I then tried adding in the 'tagOptions' - all.sortValue.ignoreThe, Album.sortTags={Album, Artist}, I got the same error I reported before: Incorrect option name 'sortValue.ignoreThe' in property 'tagOptions'
You need to use all.ignore.sort={The} instead of all.sortValue.ignoreThe. The ignoreThe option was deprecated some time ago and has been removed in 0.8.5.
(15-01-2018 10:34)simoncn Wrote: [ -> ]You need to use all.ignore.sort={The} instead of all.sortValue.ignoreThe. The ignoreThe option was deprecated some time ago and has been removed in 0.8.5.

Perfect. All appears to be working now on both systems. Thanks again for the prompt (as ever) response.
Hi,
Today I noticed the following error message on minimserver status page:

This page was last updated at 20:02:15 on 18 Mar 2018
MinimServer 0.8.5.2 update 122, Copyright © 2012-2018 Simon Nash. All rights reserved.
MinimStreamer 0.7.6, Copyright © 2012-2018 Simon Nash. All rights reserved.
Media server status for MinimServer[NAS-Sparky]: Error
Incorrect option name 'sortValue.ignoreThe' in property 'tagOptions'

Is there any way to fix the problem without removing and reinstalling the Minimserver on my QNAP TS-219P+ as I do not want to lose
my configuration settings ?
The Minimwatch icon on my PC is grey so I do not have access to minimserver settings on my pc.
QNAP Rebooting as well as Minimserver stopping-relaunching did not help.
Thanks in advance for your support and looking for your assistance.
A new version of MinimServer sometimes contains changes that might require users to make adjustments to their settings. Any such changes are listed on the Release Notes page.

For MinimServer 0.8.5, there are changes to some deprecated property names including 'sortValue.ignoreThe'. See the MinimServer 0.8.5 section for details.
(19-03-2018 12:00)simoncn Wrote: [ -> ]A new version of MinimServer sometimes contains changes that might require users to make adjustments to their settings. Any such changes are listed on the Release Notes page.

For MinimServer 0.8.5, there are changes to some deprecated property names including 'sortValue.ignoreThe'. See the MinimServer 0.8.5 section for details.

O.K., but how do I apply those necessary changes (minimwatch icon is grey so there is no access to minimserver properties) ???
This message would not cause the MinimWatch icon to be grey. There must be another issue that is causing this. See the section MinimWatch can't find MinimServer for some suggestions.
(19-03-2018 22:51)simoncn Wrote: [ -> ]This message would not cause the MinimWatch icon to be grey. There must be another issue that is causing this. See the section MinimWatch can't find MinimServer for some suggestions.

Problem fixed - the ohnet.subnet minimwatch property was empty. Now everything is up and running. Thanks a lot for your kind help !
Reference URL's