MinimServer Forum

Full Version: Transcoding & Scrubbing - AAC and MP3 to WAV
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Simon

I'm using a QNAP TS-212 (ARM Processor) NAS which has MinimServer and MinimStreamer Installed and MinimWatch on my MacBook (MacOS High Sierra)

Most of my music is stored as FLAC - though my Naim streamer prefers WAV

I transcode on the fly to my Naim streamer using MinimStreamer (flac:wav24) and I am able to scrub tracks (fast forward) with ease.

I also have a few files on the NAS which are AAC and MP3

The AAC and MP3 files are not transcoded and for some reason do not allow scrubbing (fast forward) I tried using aac:wav24 and mp3:wav24 - in the hope that once transcoded to WAV, they too could be 'scrubbed'

Unfortunately, they remain as AAC and MP3 respectfully.

ffmpeg is shown on MinimWatch, but I'm not sure it is on the QNAP (?)

Am I trying to do something which can't be done?Big Grin
QNAP QTS has ffmpeg preinstalled, so this shouldn't be an issue.

Have you restarted MinimServer since you added mp3:wav24 and aac:wav24? This is required to refresh the Naim control point's view of the MinimServer library.
(21-12-2017 20:59)simoncn Wrote: [ -> ]QNAP QTS has ffmpeg preinstalled, so this shouldn't be an issue.

Have you restarted MinimServer since you added mp3:wav24 and aac:wav24? This is required to refresh the Naim control point's view of the MinimServer library.

Hi Simon

Thanks for the fast response.

Yes, the restart doesn't seem to change anything
I have tried this with MinimServer running on a TS-119 (same processor as the TS-212) using the Naim iOS app as control point and a NaimUniti as the streamer (firmware 4.40).

FLAC is playing and is able to jump forward and backward in the track both with and without wav24 transcoding. (Is this what you mean by scrubbing?) MP3 plays both with and without transcoding but can only only jump forward if transcoding is active. AAC (ADTS) plays with transcoding active and also jumps forward and backward. Without transcoding active, AAC (ADTS) doesn't play.

Are your AAC files in ADTS format or MP4/M4A format? If it is the latter, you need mp4:wav24, not aac:wav24.

Try stopping and restarting both the Naim app and the Naim streamer to be sure no incorrect information is being cached.
Thanks Simon

Yes, that is exactly what I needed - to be able to jump forward on the track.

Now using your suggested mp4:wav24 works perfect for the AAC files too!!!!!

Thank you for all your support, which is very much appreciated.

Have a fantastic Christmas Smile
(22-12-2017 16:57)simoncn Wrote: [ -> ]I have tried this with MinimServer running on a TS-119 (same processor as the TS-212) using the Naim iOS app as control point and a NaimUniti as the streamer (firmware 4.40).

FLAC is playing and is able to jump forward and backward in the track both with and without wav24 transcoding. (Is this what you mean by scrubbing?) MP3 plays both with and without transcoding but can only only jump forward if transcoding is active. AAC (ADTS) plays with transcoding active and also jumps forward and backward. Without transcoding active, AAC (ADTS) doesn't play.

Are your AAC files in ADTS format or MP4/M4A format? If it is the latter, you need mp4:wav24, not aac:wav24.

Try stopping and restarting both the Naim app and the Naim streamer to be sure no incorrect information is being cached.

Hi Simon,
I came here from Naim Forum (just like Mr Frog).
I have synology DS116 (latest DSM) and Naim Uniti 1 (4.40 firmware), minimserver and minimwatch installed, stream converter option pointing to ffmpeg.
The thing is, I presume I have ffmpeg installed although I don't find it in opt folder and I don't know how to check it.
I don't have fast forward (nor backward) in fact, I don't have anything like slider that you could move left/right. I tried it on both IOS and Android, no luck ... Regardless of the file type (it's mostly flac that I am using)
I would appreciate any help.
Since I am here, one more question...
Since Naim Uniti 1 does not support DSD would it be possible to play DSD files (dff or dsf?) on it by using ffmeg transcoding dff:dopwav, dsf:dopwav?
many thanks
Ratko
You shouldn't need to transcode FLAC in order to enable scrubbing, the Uniti <should> support it 'out of the box'. Have you tried disabling uPNP compatibility mode in the Naim app settings?

Re DSD: I'm pretty sure Minimserver handles dff:dopwav and dsf:dopwav itself without actually needing ffmpeg or other converter program.
DoP/WAV is still DSD, just a different formatting of the DSD-encoded audio data. To play DSD on a NaimUniti 1, I think you would need to transcode DSF to WAV (PCM), which requires ffmpeg. ffmpeg is preinstalled in Synology DSM, so this should be OK.
Simon, you are completely correct, of course - I completely missed the bit in the post that the Uniti 1 had no DSD support. Blush
Reference URL's