MinimServer Forum

Full Version: MinimWatch: running but no icon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
The MinmWatch icon suddenly disappeared from my system tray (Win7 64-bit). So I decided to reinstall. But the installer told me that MinimWatch was already running and I needed to exit it before installing. I started Task Manager but don't see any reference to MinimWatch in either the applications or processes tabs. So I decided to uninstall it in Programs and Features. I got the same message about needed to exit -- which I can't do since I have no access to the icon. I did set up MinimWatch to run automatically on startups, so I poked around in Control Panel looking for startup options but didn't seem to find the right thing. Any suggestions?
The icon is probably in the system tray overflow area (click the upward-pointing arrow).
Thanks, but the tray overflow was the first place I looked. Just looked again. No dice. The option "Additional Icons in Taskbar" is checked. The MinimWatch icon was always on the main screen, not in the overflow, for whatever that's worth. I tried enlarging the system tray area but the icon did not reappear.
The icon can sometimes move to the overflow area for no obvious reason (perhaps when Java is updated?)

The other way to exit MinimWatch is to kill its javaw.exe process from Task Manager.
I have twice looked through the Processes tab in Task Manager but cannot find javaw.exe. (Windows still claims that MinimWatch is running.) FWIW, this situation has continued despite several reboots.

Perhaps my Java installation has gotten corrupted? I opened the Java control panel and it says that I am running Java 8, update 141. That looks OK but I really don't know.

Update: I decided to reinstall Java just to see what happened. I uninstalled Java from the Control Panel/Programs and Features, then rebooted the computer. I went back to Programs and Features, intending to uninstall MinmWatch before reinstalling Java. I get the same message that MinimWatch is currently running. This is bizarre -- MinimWatch can't run without Java, right?!?
There was a problem in earlier versions of MinimWatch that could cause the installer to think it is running when it isn't. This problem is fixed in the latest download available from this page.

Edit: The above link no longer works because is no longer available. See the Downloads page for the current version.
Thank you, Simon -- this seems to have fixed the problem.
Thanks for letting me know. I think MinimWatch had crashed for some reason and this caused the icon to disappear. The crash also caused a "lock" file to be left around instead of being deleted on normal exit from MinimWatch. The MinimWatch installer saw the "lock" file and took this as indicating that MinimWatch was still running. The installer is a bit smarter and deletes the "lock" file if the MinimWatch process isn't running.
That makes perfect sense. When I started the 8.4.7 installer, I thought to myself "Hope this doesn't get caught on the 'MinmWatch is running' issue." It went right through the installation with no error messages, so the mechanism you have added to the new version seems to work as intended.
I have the same issue where the Task Bar icon for Watch is suddenly missing. When I tried the download of the error 404 Not Found popped up.
The server runs but no icon. Not in the "upward pointing arrow" either.

Windows 10

Thanks. Rich
Pages: 1 2
Reference URL's