MinimServer Forum

Full Version: Problem with installing MinimWatch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

I'm a newbie here and I've just started using MinimServer which is installed on my Synology 216j NAS. From what I understand I should install MinimWatch on my Windows PC if I want to have greater control tagging my audio files.

So, I've downloaded the MinimWatch (0.8.4-install.exe) to my laptop and the icon is on my desktop, although it is grey. I mistakenly opened it with Word so I've tried to uninstall and then re-install but it still now automatically tries to open in Word,

The question I have, what do I do now? What should I open the app with? If I open with IE, a "View and track your downloads" window pops up but when I click on Open for the mwatch.jar (whatever that is), it just tries to open in Word.

I've looked at the instructions (Installing or updating MinimWatch on Windows) but this hasn't helped.

I'm totally ignorant about all this so any help would be appreciated.

Welcome to MinimServer and the forum.

This link points to the Windows install page for MinimWatch

My first question would be do you have Java installed?
If not follow the instructions and install it.
If you do have it installed then its possible Windows has associated the wrong program with the file - see note below.

Post back how you get on, there are many people on the forum that can help.

From Simon in other post (MinimServer developer):
I'm sorry to hear about the problems you have been having with getting MinimWatch to run on Windows 10. Other users have resported similar problems with the .jar file association on Windows 10. I haven't experienced these problems myself, so I haven't been able to debug the issue.

If the .jar file association is correct, double-clicking on the MinimWatch launch icon should display a small minim icon in your system tray. Sometimes Windows moves this icon to the overflow area where it isn't visible. You can show the icons in the overflow area by clicking the upward-pointing arrow in the system tray. To move an icon from the overflow area to the taskbar, right-click on the taskbar and select Properties, then click on Notification area: Customize. On this screen, click "Select which icons appear on the taskbar". You should see an entry for Java ™ Platform SE binary and you can change the setting from Off to On to make the minim icon appear.
Hi Peter,

Thanks for getting back to me so quickly. Yes, I do have Java installed.

Unfortunately, the post from Simon does not help. When I double click on the MinimWatch icon, it opens up in Word. If I open in IE, a "View and track downloads" window pops up (see attached). If I click on Open, again, it just opens in Word. So, a Minim icon does not appear in my system tray.

Any other ideas as to what's happening?

Sounds like Windows has lost the file association, follow the steps in this post to reassociate .jar files with Java.
Thanks BlueDog,

I've uninstalled and re-installed both Java and MinimWatch again and installed Jarfix.

It looks like I've fixed the file association (well, sort of). See attached image. The problem is that it's not an "Executable Jar File". It's just a "Jar File"". I assume this is a problem? Also, the icon next to.jar in the attached image looks like a Word icon. When I go to Program files in File Explorer, the icons next to some of the files also are Word icons. Also, I don't know why the "Date Modified" is 2015 or 2016 as I hadn't even heard of MinimServer back then!

Any other ideas?
John: No, that's correct - a jar file isn't technically an executable in the Windows sense, think of it more as a script that runs under the Java Runtime.

I think there is a switch in Jarfix that lets you restore the default icon for jar files. Have a look at the documentation on the Jarfix site although it's no big deal if the icon is incorrect, as long as it executes in the JRE.

Date Modified will be the date Simon compiled those files and again, nothing to worry about.

What happens when you double-click on the desktop launch shortcut for MinimWatch (grey icon with musical stave and two minim notes)? Do you see a small minim icon (single musical note) in the Windows system tray?

If this isn't working, the problem is caused by not having "Executable JAR file" in the .jar file association. This causes Java to run the file as

java -jar jarname

rather than

java jarname
Hi Simon,

Yes, when I double click on the desktop icon, the small Minim icon with the single note does appear in the Windows system tray. It's a grey icon.
Also, it looks like I now have the "Executable JAR file" (see attached image).

Seeing the icon is grey which means no instances of MinimServer are detected, what do I do now?

Probably the old multiple subnet issue again - I'm assuming you can ping the NAS from the PC?

Right-click the Minimwatch icon and select Options -> Properties (watch) and enter the correct subnet in the ohnet.subnet field.

For example, if your NAS IP is you need to enter for the subnet. Basically, the NAS IP with a zero as the last number.
Another possible reason is the Windows firewall configuration. As a test, try completely disabling the Windows firewall (for both private and public networks) to see if this makes a difference.
Pages: 1 2
Reference URL's