MinimServer Forum

Full Version: update ffmpeg on QNAP
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Should I update ffmpeg on my QNAP?
My QNAP is running version 0.8.10 and I can see version 3.1.3 is available.
Does version 3.1.3 provide any benefits for transcoding?

How can update the ffmpeg module?

Thanks,
Chip
The 0.8.10 version of ffmpeg is very old. You can update your MinimServer configuration to use the 2.8 version of ffmpeg by puttting the following into the stream.converter property:

/mnt/ext/opt/medialibrary/bin/ffmpeg

There is no simple way to use a later version than this.
I have two copies of the old version.
/usr/bin/ffmpeg -version
ffmpeg version 0.8.10, Copyright © 2000-2011 the FFmpeg developers

/mnt/ext/opt/ffmpeg/usr/bin/ffmpeg -version
ffmpeg version 0.8.10, Copyright © 2000-2011 the FFmpeg developers


And I have found two newer versions on my QNAP.

/mnt/ext/opt/medialibrary/bin/ffmpeg -version
ffmpeg version 2.8 Copyright © 2000-2015 the FFmpeg developers

/share/CACHEDEV1_DATA/.qpkg/Qffmpeg/bin/ffmpeg -version
ffmpeg version 3.1.3 Copyright © 2000-2016 the FFmpeg developers

Should I use 2.8 or 3.1.3?
Any advantage to either?
I wasn't aware of the Qffmpeg package. Thanks for letting me know about this. I can't try it myself because my NAS is an ARM model. I don't know of any reason to use 3.1.3 instead of 2.8 but it shouldn't do any harm.
I was given this link from QNAP Support.
https://forum.qnap.com/viewtopic.php?t=109648

So I can use:
/share/CACHEDEV1_DATA/.qpkg/Qffmpeg/bin/ffmpeg
in "stream.transcode" property and restart MinimServer to activate 3.1.3?

Is this correct?

If yes, I will try it later today.
Yes, this will change your ffmpeg version to 3.1.3.
Hi,
I added /share/CACHEDEV1_DATA/.qpkg/Qffmpeg/bin/ffmpeg to stream.transcode and restarted MinimServer.

Can I confirm in the log file that this is the version actually being used?

Chip
The log file does not give the ffmpeg version. You can be confident that MinimStreamer is doing the right thing. Smile
Just for clarification,

I have downloaded ffmpeg from http://johnvansickle.com/ffmpeg/ to get the Soxr library, and installed it on my Synology (Intel one, DS415play)
I have added /volume1/MinimServer/opt/bin/ffmpeg to stream.converter value, and convOut=-af aresample=resampler=soxr:precision=28 to stream.options

now : if I read the user's guide :

flac:wav24 does not use ffmpeg
but flac:wav24; does, because of the ;

is this correct ?
(05-10-2016 15:24)lyapounov Wrote: [ -> ]Just for clarification,

I have downloaded ffmpeg from http://johnvansickle.com/ffmpeg/ to get the Soxr library, and installed it on my Synology (Intel one, DS415play)
I have added /volume1/MinimServer/opt/bin/ffmpeg to stream.converter value, and convOut=-af aresample=resampler=soxr:precision=28 to stream.options

If ffmpeg is installed in the opt/bin directory and you remove any previous setting in stream.converter, MinimStreamer should find the opt/bin version of ffmpeg automatically without your needing to set this path explicitly.

Quote:now : if I read the user's guide :

flac:wav24 does not use ffmpeg
but flac:wav24; does, because of the ;

is this correct ?

Yes.
Reference URL's