MinimServer Forum

Full Version: Problem with display of 2-disc albums
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I am using dBPoweramp Mac version and a Synology DS416 with DSM 6.
Both discs of a 2-CD album appear to rip successfully, with the same album art etc. When selected on the NAIM app on my iPad the first disc is displayed correctly, but the second is shown correctly for a second, then shows a completely unrelated album cover and title, and track 01 as >>Disc 2. Please see screen shots attached. This has now happened several times with 'double' albums ( I hesitate to try 3 or 4 disc sets!). Has anyone else seen this fault?
Regards,
nimonic
[attachment=1204][attachment=1205]
(30-05-2016 16:59)nimonic Wrote: [ -> ]I am using dBPoweramp Mac version and a Synology DS416 with DSM 6.
Both discs of a 2-CD album appear to rip successfully, with the same album art etc. When selected on the NAIM app on my iPad the first disc is displayed correctly, but the second is shown correctly for a second, then shows a completely unrelated album cover and title, and track 01 as >>Disc 2. Please see screen shots attached. This has now happened several times with 'double' albums ( I hesitate to try 3 or 4 disc sets!). Has anyone else seen this fault?
Regards,
nimonic
I do recognize this, the "old" Cambridge Audio StreamMagic app had the same issue.
[attachment=1210][attachment=1211][attachment=1212][attachment=1213][attachment=1206][attachment=1207][attachment=1208][attachment=1209]
(img 676, 677, 678, 679 StreamMagic app: Disc 2 and 3 with >>).
(img 672, 673, 674, 675 Connect app: without >>).

Regards,
Peter
(30-05-2016 16:59)nimonic Wrote: [ -> ]I am using dBPoweramp Mac version and a Synology DS416 with DSM 6.
Both discs of a 2-CD album appear to rip successfully, with the same album art etc. When selected on the NAIM app on my iPad the first disc is displayed correctly, but the second is shown correctly for a second, then shows a completely unrelated album cover and title, and track 01 as >>Disc 2. Please see screen shots attached. This has now happened several times with 'double' albums ( I hesitate to try 3 or 4 disc sets!). Has anyone else seen this fault?
Regards,
nimonic

What is the significance of the second screenshot that you posted (Concertos & Sonatas for Oboe, Disc 1)?

What Album tags do you have for the discs? If they are "Album Name, Disc 1" and "Album Name, Disc 2", you should change them to "Album Name [Disc 1]" and "Album Name [Disc 2]". This will enable MinimSerer to merge both discs into a single album. See this section for details.
(30-05-2016 21:06)simoncn Wrote: [ -> ]
(30-05-2016 16:59)nimonic Wrote: [ -> ]I am using dBPoweramp Mac version and a Synology DS416 with DSM 6.
Both discs of a 2-CD album appear to rip successfully, with the same album art etc. When selected on the NAIM app on my iPad the first disc is displayed correctly, but the second is shown correctly for a second, then shows a completely unrelated album cover and title, and track 01 as >>Disc 2. Please see screen shots attached. This has now happened several times with 'double' albums ( I hesitate to try 3 or 4 disc sets!). Has anyone else seen this fault?
Regards,
nimonic

What is the significance of the second screenshot that you posted (Concertos & Sonatas for Oboe, Disc 1)?

What Album tags do you have for the discs? If they are "Album Name, Disc 1" and "Album Name, Disc 2", you should change them to "Album Name [Disc 1]" and "Album Name [Disc 2]". This will enable MinimSerer to merge both discs into a single album. See this section for details.

The 2nd screenshot is for the first disc of the set; the second disc should look like this but with the appropriate contents. I will try merging the two discs, which looks like a better approach. Many thanks, nimonic.
Hi,
I had the same problem, which seemed to come and go and affect some multi-disc albums but not others. It got worse the more albums I ripped. It was only a problem when looking under the albums selection rather than, say, finding an album under genre or artist. I have all my album titles as "Album name, Disc n" - as that's dbpoweramp default. I've ripped thousands of CDs and didn't want to re-rip and have never wanted to merge the multi-disc albums anyway. Sometimes emptying the image cache helped but not always. In the end I deleted the Naim app and re-installed it and this seems to have sorted the problem for now.
Hope that helps.
(02-06-2016 02:12)Bill74 Wrote: [ -> ]Hi,
I had the same problem, which seemed to come and go and affect some multi-disc albums but not others. It got worse the more albums I ripped. It was only a problem when looking under the albums selection rather than, say, finding an album under genre or artist. I have all my album titles as "Album name, Disc n" - as that's dbpoweramp default. I've ripped thousands of CDs and didn't want to re-rip and have never wanted to merge the multi-disc albums anyway. Sometimes emptying the image cache helped but not always. In the end I deleted the Naim app and re-installed it and this seems to have sorted the problem for now.
Hope that helps.

I wasn't aware that dBpoweramp is using "Album name, Disc n" by default. MinimServer could automatically detect this format in addition to "Album name [Disc n]" and "Album name (Disc n)". Would this be a useful change?
(02-06-2016 11:49)simoncn Wrote: [ -> ]I wasn't aware that dBpoweramp is using "Album name, Disc n" by default. MinimServer could automatically detect this format in addition to "Album name [Disc n]" and "Album name (Disc n)". Would this be a useful change?

I think it would. dBpoweramp does indeed use this default (see attachment), and, on a first look, it doesn't seem to offer any of the options currently used by MinimServer.

David

[attachment=1214]
(02-06-2016 02:12)Bill74 Wrote: [ -> ]Hi,
I had the same problem, which seemed to come and go and affect some multi-disc albums but not others. It got worse the more albums I ripped. It was only a problem when looking under the albums selection rather than, say, finding an album under genre or artist. I have all my album titles as "Album name, Disc n" - as that's dbpoweramp default. I've ripped thousands of CDs and didn't want to re-rip and have never wanted to merge the multi-disc albums anyway. Sometimes emptying the image cache helped but not always. In the end I deleted the Naim app and re-installed it and this seems to have sorted the problem for now.
Hope that helps.
It has been a while since I had the same problem (using the "old" StreamMagic app)and was convinced it had nothing to do with tagging.
I recently noticed that albums with a separate Disc tag (Disc 1/2, 2/2 e.g.) do have the >> Disc 2 appearance and albums without this tag don't.
Maybe the same for the Naim app.

Regards, Peter
(02-06-2016 11:49)simoncn Wrote: [ -> ]
(02-06-2016 02:12)Bill74 Wrote: [ -> ]Hi,
I had the same problem, which seemed to come and go and affect some multi-disc albums but not others. It got worse the more albums I ripped. It was only a problem when looking under the albums selection rather than, say, finding an album under genre or artist. I have all my album titles as "Album name, Disc n" - as that's dbpoweramp default. I've ripped thousands of CDs and didn't want to re-rip and have never wanted to merge the multi-disc albums anyway. Sometimes emptying the image cache helped but not always. In the end I deleted the Naim app and re-installed it and this seems to have sorted the problem for now.
Hope that helps.

I wasn't aware that dBpoweramp is using "Album name, Disc n" by default. MinimServer could automatically detect this format in addition to "Album name [Disc n]" and "Album name (Disc n)". Would this be a useful change?

I think that would be useful. Although I've titled a fair few of my multi-disc albums with a qualifier after the disc number, e.g. "Album name, Disc n, Live" or "Album name, Disc n, Studio" - how would that affect things? Thanks for looking at this.
(04-06-2016 12:10)Peter StreamMagic Wrote: [ -> ]
(02-06-2016 02:12)Bill74 Wrote: [ -> ]Hi,
I had the same problem, which seemed to come and go and affect some multi-disc albums but not others. It got worse the more albums I ripped. It was only a problem when looking under the albums selection rather than, say, finding an album under genre or artist. I have all my album titles as "Album name, Disc n" - as that's dbpoweramp default. I've ripped thousands of CDs and didn't want to re-rip and have never wanted to merge the multi-disc albums anyway. Sometimes emptying the image cache helped but not always. In the end I deleted the Naim app and re-installed it and this seems to have sorted the problem for now.
Hope that helps.
It has been a wile since I had the same problem (using the "old" StreamMagic app)and was convinced it had nothing to do with tagging.
I recently noticed that albums with a separate Disc tag (Disc 1/2, 2/2 e.g.) do have the >> Disc 2 appearance and albums without this tag don't.
Maybe the same for the Naim app.

Regards, Peter

Hi, the Naim app will give a normal display for the first disc in the series (i.e. Disc 1/3) but will then show the >> Disc 2 appearance for those tagged as 2/3, >> Disc 3 for 3/3 etc.. It doesn't really matter until it starts losing the correct album art which it only does for the second or subsequent discs. Cheers.
Pages: 1 2 3
Reference URL's