MinimServer Forum

Full Version: Access is denied error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Every morning when I run MinimServer it fails to start with this error message:

unexpected exception java.lang.UnsatisfiedLinkError: C:\Users\Mark\AppData\Local\Temp\minim-native-0\ohNet.dll: Access is denied

I uninstall and receive this message:
Some elements could not be removed. These can be removed manually.

I install again and it works until the next day.

I know this message is something to do with 32 bit versions on 64 bit windows 7 but I now have 64 bit Java AND MinimServer installed.

If the error is due to the uninstall leaving something behind - what am I looking for?

Many thanks!
This message isn't caused by a 32-bit/64-bit mismatch.

The message from uninstall probably means you have not exited MinimWatch before doing the uninstall.

The message from startup might be caused by an antivirus program preventing access to the C:\Users\Mark\AppData\Local\Temp\minim-native-0 folder. The location of the ohNet.dll file changed in a recent MinimServer update and this appears to be causing problems for a few users. I am working on a solution for this.
Thanks Simon - I have AVG antivirus and Zone Alarm running. Let me know if you want me to try anything to narrow it down.
(07-04-2016 09:59)buginblue Wrote: [ -> ]Thanks Simon - I have AVG antivirus and Zone Alarm running. Let me know if you want me to try anything to narrow it down.

Can you disable these (one at a time) and let me know whether this solves the problem?
MinimServer had the error message this morning. I killed Zone Alarm and tried to restart (same error) then stopped AVG anti-virus and link scanner but no luck. There was one AVG process running that I couldn't stop using task manager (avg user interface process). I uninstalled and reinstalled to get MinimServer working again. Thanks.
(08-04-2016 10:19)buginblue Wrote: [ -> ]MinimServer had the error message this morning. I killed Zone Alarm and tried to restart (same error) then stopped AVG anti-virus and link scanner but no luck. There was one AVG process running that I couldn't stop using task manager (avg user interface process). I uninstalled and reinstalled to get MinimServer working again. Thanks.

I have released MinimServer update 80 which should fix this problem. Please install this update and let me know what happens.
Download has same version as before - MinimServer-0.8.3a-install-x64 - is that the right one? Thanks
(08-04-2016 11:52)buginblue Wrote: [ -> ]Download has same version as before - MinimServer-0.8.3a-install-x64 - is that the right one? Thanks

No, you need to install the update by selecting About from the minim icon and clicking 'Show updates'.
MinimServer started without error this morning - thanks Simon.
Reference URL's