MinimServer Forum

Full Version: Port 9790 in use - can't install MinimServer
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Synology DS212 NAS
DSM 5.2 Update 3
Java SE Embeded 8u71

I updated DSM to latest version (Above) and then Java to 8u71.

I then uninstalled MinimServer 0.8.3.1 (armV5) and went to install 0.8.3.4 (armV5) but got an error that Java wasn't installed properly. The Java install had displayed a message at the end saying that it had installed successfully but checking the log showed problems (patters then fixed the 8u71 download and I installed it successfully and it is running fine).

I then retried installing MinimServer 0.8.3.4 (and also retried 0.8.3.1) but get a message saying that Port 9790 is in use.

I have rebooted the NAS and the laptop a couple of times each and retried but get the same error.

Nothing else on the NAS or laptop has changed. The MinimServer installation instructions just say that this issue should disappear after a couple of minutes, but it doesn't.

I searched the forum but couldn't find a fix.

Can anyone help?
(26-01-2016 23:49)DSK Wrote: [ -> ]Synology DS212 NAS
DSM 5.2 Update 3
Java SE Embeded 8u71

I updated DSM to latest version (Above) and then Java to 8u71.

I then uninstalled MinimServer 0.8.3.1 (armV5) and went to install 0.8.3.4 (armV5) but got an error that Java wasn't installed properly. The Java install had displayed a message at the end saying that it had installed successfully but checking the log showed problems (patters then fixed the 8u71 download and I installed it successfully and it is running fine).

I then retried installing MinimServer 0.8.3.4 (and also retried 0.8.3.1) but get a message saying that Port 9790 is in use.

I have rebooted the NAS and the laptop a couple of times each and retried but get the same error.

Nothing else on the NAS or laptop has changed. The MinimServer installation instructions just say that this issue should disappear after a couple of minutes, but it doesn't.

I searched the forum but couldn't find a fix.

Can anyone help?

For future reference, you should not uninstall MinimServer before installing a later version of MinimServer or Java. You should just install the later version and it will automatically update your current installation.

It seems that the problem with the failed Java installation has caused the MinimServer installation script to malfunction. I will look into this.

To recover from the problem, you need to follow the instructions in this post.
I have checked the MinimServer installation script and it isn't clear to me how this problem with port 9790 could have happened.

From your earlier post, I think you did the following in this order:

1) With MinimServer 0.8.3.1 installed, install the faulty Java package
2) Uninstall MinimServer 0.8.3.1 - this works OK
3) Install MinimServer 0.8.3.4 - this fails with a message about Java not starting correctly
4) Uninstall MinimServer?? or Java ?? or both ?? in which order ??
5) Reinstall MinimServer?? or Java ?? or both ?? in which order ??

If you could confirm this and provide more detail about 4) and 5), this would be very helpful. Many thanks!
1) With MinimServer 0.8.3.1 installed, uninstalled Java
2) Installed the faulty Java package
3) Uninstall MinimServer 0.8.3.1 - this works OK
4) Install MinimServer 0.8.3.4 - this fails with a message about Java not being installed or starting correctly
5) Uninstalled Java and re-attempted Java installation - unsuccessful
6) Updated DSM from 5.1 Update 1 to 5.2 Update 3 - successful
7) Uninstalled Java and re-attempted Java installation - unsuccessful
8) Patters updated the Java file to work
9) Uninstalled Java and installed Java - this time successfully
10) Install MinimServer 0.8.3.4 - still fails with a message that port 9790 is in use
11) Tried to re-install MinimServer 0.8.3.1 - fails with a message that port 9790 is in use

As best I can remember, this was the order of events. I also rebooted NAS and laptop after most install attempts.

FWIW all downloads were performed with latest FireFox browser.
I'm guessing that uninstalling MinimWatch on the laptop won't make any difference to this issue but please let me know if you think I should do this.
No difference at all. You need to do what I posted in this response.
1) Login to the NAS as root using SSH

2) Enter this command:

/usr/syno/bin/servicetool --remove-configure-file --package MinimServer.sc



I'm not quite sure what step 1 means ... I'll have to google it tomorrow.
(30-01-2016 14:34)DSK Wrote: [ -> ]1) Login to the NAS as root using SSH

2) Enter this command:

/usr/syno/bin/servicetool --remove-configure-file --package MinimServer.sc

I'm not quite sure what step 1 means ... I'll have to google it tomorrow.

Do you have a Windows laptop? If so, you should download PuTTY and use this to login to the NAS via SSH. When prompted for a username, enter root. At the password prompt, enter the password that you normally use to login to DSM.

If this works, you will get a terminal window containing a command prompt. Type the command in step 2 exactly as written and press the enter/return key to run the command.
Almost there I think but get the attached error ...
Doh! I just realised you said to login as root.

It worked perfectly.

Many Thanks!
Pages: 1 2
Reference URL's