MinimServer Forum

Full Version: Minimwach is "grayed" out
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am not aware of anything that changed on my Windows 10 PC to cause this. The Minimwatch icon no longer goes "green" indicating connection to the MinimServer running on my Synology NAS on the same network. If I go to Options > properties > Packages it shows minimwatch-0.8-update-33


[Image: 6F327B72-6EA0-4C00-82AC-5AF4069D76B7_zpstpte5fy1.jpg]


Thanks,
Paul
(06-11-2015 16:00)pdf1964 Wrote: [ -> ]I am not aware of anything that changed on my Windows 10 PC to cause this. The Minimwatch icon no longer goes "green" indicating connection to the MinimServer running on my Synology NAS on the same network. If I go to Options > properties > Packages it shows minimwatch-0.8-update-33

Thanks,
Paul

This has two likely causes:

1) The Windows firewall might be blocking inbound connections to Java. To confirm this, try completely disabling the firewall as a test to see if this fixes the problem.

2) The PC might have more than one active network adapter (real or virtual) and MinimWatch might have selected the wrong adapter. To check for this, select Options > Show log (watch) from the minim icon and look for the line that shows the active subnet. If this doesn't match the correct subnet for your NAS, MinimWatch is using the wrong network adapter and you need to set the ohnet.subnet property for MinimWatch as described in this section.
Good call on the Windows firewall! I was going down the road of TrendMicro AV blocking something. Thanks for the quick response. As usual, outstanding support!
Simon, hi. been lurker on forum before but never needed help, so . . .

This Minimwatch greyed out - I am getting that now but never had before last updates.

Concern is it all usd to work OK, Minimserver on Synology NAS and Minimwatch on Windows PC and also a Macbook Air. Regularly updated the Minimserver but rather let the watch go as just used the server stop /start when re-indexing.

Latest Minimserver update is fine. However, the Minimwatch, also updated, just shows gray - on either the PC or the Mac. I have not changed anything network-wise, the firewall is not blocking and have tried switching it off also anyway. The PC is wired by ethernet into a switch - same switch as the NAS. The switch is also a wireless access point - which is used by the Mac. All are on the same subnet. The ohnet.subnet field in properties (watch) is blank however. I have tried inputting the correct subnet 192.168.1.0 but MinimWatch justcomes back with "Unknown component name".
Alos strange- when I try refresh - I get An unexpected exception has occurred java. lang. NullPointerException. OK to relaunch etc. Then the log window won't close and Minim watch hangs and has to be force closed.

Not firewall, don't understand why subnet cannot be entered, but happens on both the Win version and the OSX. Me, I'm at wits end. Possibly Java?.

Neither machine has any problem accessing the NAS music and both and ipad/iphone can access Minimserver via UpnUp over my Cyrus. it's just Minimwatch.

Any help gratefully appreciated, thanks, Mike
I have tried setting ohnet.subnet in Properties (watch) and it is working for me.

Which version of MinimWatch are you running? You can find this by selecting Options > About (watch).

When you get the java.lang.NullPointerException message, what is the full stack trace? You should be able to find this by selecting Options > Show log (watch) or by looking for a crash dump file (on Windows) in the folder

C:\Users\your-user-name\AppData\Roaming\MinimWatch\data

The AppData folder is hidden by default in Windows Explorer, so you need to type the above path into the Explorer address bar.
belay that - I have no idea why but I just went again and minimwatch stopped - grey icon disappeared. Clicked on shortcut again and immediately got the firewall warning, clicked allow and it started - green. Must be something irregular java? or maybe on the NAS. whatever, now to try the Mac ;-(

sorry to bother you. Mike

ah, edit - replies crossed - update 34. The nullpointer message was only when tried refresh. last attached. No hidden files on my machine . . . Thanks Mike
(28-11-2015 22:12)birdmanmike Wrote: [ -> ]belay that - I have no idea why but I just went again and minimwatch stopped - grey icon disappeared. Clicked on shortcut again and immediately got the firewall warning, clicked allow and it started - green. Must be something irregular java? or maybe on the NAS. whatever, now to try the Mac ;-(

sorry to bother you. Mike

ah, edit - replies crossed - update 34. The nullpointer message was only when tried refresh. last attached. No hidden files on my machine . . . Thanks Mike

Thanks for posting this. I've checked the code and this problem was fixed in MinimWatch update 31. You probably got the message after installing MinimWatch 0.8.3 and before this was updated (manually or automatically) to update 34.
Reference URL's