MinimServer Forum

Full Version: Server 2012 R2 Launch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi -

I am new to MinimServer and was referred by JPlay. I am trying to find the easiest way to launch MinimServer in Audiophile Optimizer Core mode on windows 2012 R2? I saw the other posts but did not see a clear answer I could apply.

Could someone please help as I am a beginner and like the your software over the JRiver DLNA software! Can I use the minimWatch on another PC to launch MS in AO core mode with no GUI?

Thanks for your patience and timeBig Grin


Trueaudiofile
(27-07-2015 00:06)trueaudiofile Wrote: [ -> ]Hi -

I am new to MinimServer and was referred by JPlay. I am trying to find the easiest way to launch MinimServer in Audiophile Optimizer Core mode on windows 2012 R2? I saw the other posts but did not see a clear answer I could apply.

Could someone please help as I am a beginner and like the your software over the JRiver DLNA software! Can I use the minimWatch on another PC to launch MS in AO core mode with no GUI?

Thanks for your patience and timeBig Grin

Trueaudiofile

Welcome to the MinimServer forum!

Other users have been able to run MinimServer in Windows Server 2012 core mode. If you want to use MinimStreamer and ffmpeg.exe for transcoding, you need to add a couple of DLLs as described in this post.

To launch MinimServer in console mode (no GUI), use the following commands:

cd "C:\Program Files\MinimServer\lib"
java -jar mserver.jar --set watch.view=console

This assumes that you have installed MinimServer in the folder "C:\Program Files\MinimServer".

MinimWatch doesn't launch MinimServer. It enables you to manage and configure MinimServer from another machine on your local network. This other machine can be using a GUI.
excuse my laziness but is there any way to simplify the launch of console mode by not having to type those two lines every time?
(13-03-2016 19:13)Ho5457 Wrote: [ -> ]excuse my laziness but is there any way to simplify the launch of console mode by not having to type those two lines every time?

You could create a .bat or .cmd file containing these two lines.
(13-03-2016 21:42)simoncn Wrote: [ -> ]
(13-03-2016 19:13)Ho5457 Wrote: [ -> ]excuse my laziness but is there any way to simplify the launch of console mode by not having to type those two lines every time?

You could create a .bat or .cmd file containing these two lines.

Great will look into that. Cheers!
(27-07-2015 09:25)simoncn Wrote: [ -> ]Welcome to the MinimServer forum!

Other users have been able to run MinimServer in Windows Server 2012 core mode. If you want to use MinimStreamer and ffmpeg.exe for transcoding, you need to add a couple of DLLs as described in this post.

To launch MinimServer in console mode (no GUI), use the following commands:

cd "C:\Program Files\MinimServer\lib"
java -jar mserver.jar --set watch.view=console

This assumes that you have installed MinimServer in the folder "C:\Program Files\MinimServer".

MinimWatch doesn't launch MinimServer. It enables you to manage and configure MinimServer from another machine on your local network. This other machine can be using a GUI.

Hi,

I'm a new user of Minimserver and want to use it Win Server 2016 Core mode.

I have set up the path "C:\Program Files\java \jre1.8.0_31\bin". Then

cd "C:\Program Files\MinimServer\lib"
java -jar mserver.jar --set watch.view=console

Then
"Error: loading: "C:\Program Files\java \jre1.8.0_31\bin\server\jvm.dll"
shown.

What should I do?
Try removing your PATH setting and using the full path to the java executable, as follows:

"C:\Program Files\java\jre1.8.0_31\bin\java" -jar mserver.jar --set watch.view=console

Note that there is no space after 'java'.
(05-03-2017 08:25)simoncn Wrote: [ -> ]Try removing your PATH setting and using the full path to the java executable, as follows:

"C:\Program Files\java\jre1.8.0_31\bin\java" -jar mserver.jar --set watch.view=console

Note that there is no space after 'java'.

Thanks for the reply. I tried but get the same error message.
"Error: loading: "C:\Program Files\java \jre1.8.0_31\bin\server\jvm.dll"

Let me state more clearly what I did before.

I used the following jre.cmd:
pushd %~dp0
start /wait jre-8u31-windows-x64.exe INSTALLCFG=%~dp0jre.cfg

with the following jre.cfg
INSTALL_SILENT=Enable
SPONSORS=Disable
NOSTARTMENU=Enable
REBOOT=Disable
EULA=Disable
AUTO_UPDATE=Disable
STATIC=Enable
to install java. Then I use the method "C:\Program Files\java\jre1.8.0_31\bin\java" -jar mserver.jar --set watch.view=console

Does it matter?

By the way, the folder of MinimServer was covered from the Windows that MinimServer was installed successfully and the package MinimStreamer installed afterwards. Does it matter?
Hi,

After updated to the jre1.8.0.0_121, the command worked. How can I install the MinimStreamer then?
Pages: 1 2
Reference URL's