MinimServer Forum

Full Version: Minimserver takes long to show up
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi Simon,

sometimes it takes quite long (some minutes) for minimserver to show up on my naim uniti and naim app, while the Synology media server as well as two BubbleUPnPServer instances (one proxy for the synology media server and on for the minimserver!) are available without a delay.

It happens after the NAS has waken up from standby (The DS213+ offers not only a disk standby mode but also an system deep sleep mode. You can wake it up by a normal access via e.g. http and do not need a wake on lan package.). While the original minimserver instance is not visible I can play music vie the bubbleserver-minimserver-proxy. So minimserver is up and running what is stated by the minimserver web status page, too.

What could be the problem?

My system:

Synology NAS DS213+ hardwired connected to an Asus RT ac66u router that is running as an access point. This access point is hard wired to an avm fritz box that is the internet DSL router. My naim uniti is hard wired to this fritz box, too. An android phone or apple tablet are running the naim app and connect via wifi to the asus router.

I am running the latest minimserver version.

Gert
(16-06-2015 21:13)tarnkappe Wrote: [ -> ]Hi Simon,

sometimes it takes quite long (some minutes) for minimserver to show up on my naim uniti and naim app, while the Synology media server as well as two BubbleUPnPServer instances (one proxy for the synology media server and on for the minimserver!) are available without a delay.

It happens after the NAS has waken up from standby (The DS213+ offers not only a disk standby mode but also an system deep sleep mode. You can wake it up by a normal access via e.g. http and do not need a wake on lan package.). While the original minimserver instance is not visible I can play music vie the bubbleserver-minimserver-proxy. So minimserver is up and running what is stated by the minimserver web status page, too.

What could be the problem?

My system:

Synology NAS DS213+ hardwired connected to an Asus RT ac66u router that is running as an access point. This access point is hard wired to an avm fritz box that is the internet DSL router. My naim uniti is hard wired to this fritz box, too. An android phone or apple tablet are running the naim app and connect via wifi to the asus router.

I am running the latest minimserver version.

Gert

This might be an issue with IGMP snooping on your network. When the DS213+ is sleeping, it doesn't respond to IGMP queries and would be dropped from the SSDP multicast group. The simplest solution is to disable IGMP snooping on your router (or possibly both your routers).

Some servers compensate for problems like this by flooding the network with SSDP "alive" announcements at very frequent intervals. The ohNet stack that MinimServer uses for UPnP communications doesn't do this.
IGMP is activated for wifi and I can deactivate this. (I will test if this will be an advantage for the different upnp apps that I am using.) But as the hardwired uniti does not see the minimserver, too, I tried to find out if the two routers have IGMP activated for their LAN ports. This is difficult as I could not find a clear statement. It seems that at least the fritz box has IGMP enabled. For the asus router I could not find an information. Also I could not find an option in both routers to de/activate it for LAN.

Does a multicast member (an UPnP server) not have a chance to send an IGMP "here I am" package after starting up but has to wait for a IGMP query from the current IGMP master? Maybe ohNet should send such SSDP alive packages for a while until it received an IGMP package.

As far as I understand, IGMP is a good thing that one should have enabled, because it lowers the number of network packages flooding around with multicast traffic. It would be a pity if UPnP conflicts with this conceptionally.
(20-06-2015 10:48)tarnkappe Wrote: [ -> ]IGMP is activated for wifi and I can deactivate this. (I will test if this will be an advantage for the different upnp apps that I am using.) But as the hardwired uniti does not see the minimserver, too, I tried to find out if the two routers have IGMP activated for their LAN ports. This is difficult as I could not find a clear statement. It seems that at least the fritz box has IGMP enabled. For the asus router I could not find an information. Also I could not find an option in both routers to de/activate it for LAN.

Does a multicast member (an UPnP server) not have a chance to send an IGMP "here I am" package after starting up but has to wait for a IGMP query from the current IGMP master? Maybe ohNet should send such SSDP alive packages for a while until it received an IGMP package.

As far as I understand, IGMP is a good thing that one should have enabled, because it lowers the number of network packages flooding around with multicast traffic. It would be a pity if UPnP conflicts with this conceptionally.

There is no conflict between IGMP snooping and UPnP/SSDP. I am running my network with IGMP snooping enabled and UPnP/SSDP working correctly. This took a long time and a lot of learning/experimentation to achieve.

If you want to keep IGMP snooping enabled, you will need to add your DS213+ as a fixed manual entry to the SSDP multicast group in the switch or router to which it is connected. You will need to do the same for this switch or router all the way back to the master router (the IGMP querier). This will prevent the DS213+ from being dropped from the SSDP multicast group when it enters deep sleep mode.

ohNet doesn't know about IGMP messages or multicast group membership because these are handled by a lower layer in the operating system. I'm not sure whether ohNet can detect that the NAS has entered "deep sleep" mode. This would depend on whether ohNet receives a notification from the operating system that the network adapter has been disabled/enabled. If ohNet doesn't receive such a notification, it wouldn't be able to detect that the NAS has awoken from deep sleep and know that an SSDP "alive" notification needs to be sent.

I don't have a NAS that can enter "deep sleep" mode in this way. If you would like to produce a MinimServer debug log from your NAS, I will look at it and let you know what is happening inside ohNet. Please do the following:

1) Stop and restart MinimServer from the Package Center
2) Make sure that MinimServer is visible on the network
3) In the Properties window, set the ohnet.debug property to All-Timer
4) In the log window, set the logging level to Debug
5) Close the log window
6) Allow the DS213+ to enter deep sleep mode and note the time
7) Awaken the DS213+ from deep sleep mode and note the time
8) In File Station, navigate to the MinimServer > appData folder and copy the minimserver.log file to minimserver1.log
9) Reset the ohnet.debug property and the logging level to their original values
10) Zip the minimserver1.log file and attach it to a post here together with the times of entering and leaving deep sleep mode. Please let me know if the zipped file is too large to attach.
(20-06-2015 10:48)tarnkappe Wrote: [ -> ]IGMP is activated for wifi and I can deactivate this. (I will test if this will be an advantage for the different upnp apps that I am using.) But as the hardwired uniti does not see the minimserver, too, I tried to find out if the two routers have IGMP activated for their LAN ports. This is difficult as I could not find a clear statement. It seems that at least the fritz box has IGMP enabled. For the asus router I could not find an information. Also I could not find an option in both routers to de/activate it for LAN.

Does a multicast member (an UPnP server) not have a chance to send an IGMP "here I am" package after starting up but has to wait for a IGMP query from the current IGMP master? Maybe ohNet should send such SSDP alive packages for a while until it received an IGMP package.

As far as I understand, IGMP is a good thing that one should have enabled, because it lowers the number of network packages flooding around with multicast traffic. It would be a pity if UPnP conflicts with this conceptionally.
Hi Gert,

I do own a Asus N66U,it might be settings are the same
[attachment=886]
Peter
Hi Peter,

thanks for the screenshot. Unfortunately my LAN settings page only offers a tab "LAN-IP" where I can set up the ip address and dns if it is not retrieved automatically. Maybe this is because I run the router as wifi access point. Or is there a way to enable a kind of expert mode for the settings to see more options? I could not find a hint in the web regarding this.

Greetings,
Gert
(20-06-2015 18:39)tarnkappe Wrote: [ -> ]Hi Peter,

thanks for the screenshot. Unfortunately my LAN settings page only offers a tab "LAN-IP" where I can set up the ip address and dns if it is not retrieved automatically. Maybe this is because I run the router as wifi access point. Or is there a way to enable a kind of expert mode for the settings to see more options? I could not find a hint in the web regarding this.

Greetings,
Gert

You would need to disable IGMP snooping on your main router (the router that generates IGMP queries).
As far as I have read there can be several IGMP query instances in a network. But only one is the main instance who is doing the queries. If you switch off this one, another instance can become the main instance. (similar as SMB works AFAIR.) So this main instance does not need to be the main router, does it?

But I could not find an option for this in the main router fritz box anyway. You can "hack" into the router and turn it off manually by stopping/configuring a daemon, but I do not like to touch this important device that way because there will be an annoyed family if internet access does not work anymore if I am doing something wrong... Wink
Hi Simon,

"If you would like to produce a MinimServer debug log from your NAS"

I would like to, but it seems it will not work. The ohnet.debug property All-Timer logs information to the minimserver.log frequently (every minute?). But the deep sleep of the NAS is entered 1 minute after disk sleep has happened. Because of the frequent log-file write access the discs will not sleep, so no deep sleep will happen. I will keep the NAS running to see if it goes asleep the next hours, but I have only little hope.
Update: No, no deep sleep possible with these debug options turned on. I think I have to cancel this way of debugging.
Pages: 1 2
Reference URL's