MinimServer Forum

Full Version: Please help, upgraded to allow -/+ on albums sorted by date
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

Please help, today I upgraded to the latest minimserver on Ubuntu 14.10, basically so I could select an artist, then select albums and get the following view:

2001 first album released
2004 second album released

It is showing it sorted by date but the other way around by using '-' in front (I tried '+' as well) of 'date' and I cannot get it to flip.

Also minimserver has stopped auto starting on boot, I tried running setup again and enabling, no dice.

Thanks for looking.

Cheers
Richard
(02-05-2015 11:07)rthorntn Wrote: [ -> ]Hi,

Please help, today I upgraded to the latest minimserver on Ubuntu 14.10, basically so I could select an artist, then select albums and get the following view:

2001 first album released
2004 second album released

It is showing it sorted by date but the other way around by using '-' in front (I tried '+' as well) of 'date' and I cannot get it to flip.

Also minimserver has stopped auto starting on boot, I tried running setup again and enabling, no dice.

Thanks for looking.

Cheers
Richard

Where exactly did you put the + setting in front of Date? Did you restart MinimServer after applying this setting?

I'm away from home ay the moment and I'm unable to test automatic startup on Ubuntu 14.10. I will do this when I'm back home in a couple of weeks.
(02-05-2015 21:32)simoncn Wrote: [ -> ]
(02-05-2015 11:07)rthorntn Wrote: [ -> ]Hi,

Please help, today I upgraded to the latest minimserver on Ubuntu 14.10, basically so I could select an artist, then select albums and get the following view:

2001 first album released
2004 second album released

It is showing it sorted by date but the other way around by using '-' in front (I tried '+' as well) of 'date' and I cannot get it to flip.

Also minimserver has stopped auto starting on boot, I tried running setup again and enabling, no dice.

Thanks for looking.

Cheers
Richard

Where exactly did you put the + setting in front of Date? Did you restart MinimServer after applying this setting?

I'm away from home ay the moment and I'm unable to test automatic startup on Ubuntu 14.10. I will do this when I'm back home in a couple of weeks.

Thanks Simon.

I tried every position of the + setting that I could think of, rebooted after every change, it didn't seem to matter, right now it's at:

"minimserver.tagOptions = Album.sortTags={-Date}"

Can you confirm exactly how that should read please?

I think the startup issue is a problem with Linux permissions for starting minimserver on boot...

/opt/minim/minimserver/bin$ ./startc
Unable to delete file /opt/minim/minimserver/data/tmp/native/libohNetJni.so"

"/opt/minim/minimserver/bin$ ./startd
rm: cannot remove ‘/opt/minim/minimserver/data/minimserver.pipe’: Permission denied"

"/opt/minim/minimserver/bin$ sudo ./startd" works.
(11-05-2015 06:58)rthorntn Wrote: [ -> ]Thanks Simon.

I tried every position of the + setting that I could think of, rebooted after every change, it didn't seem to matter, right now it's at:

"minimserver.tagOptions = Album.sortTags={-Date}"

Can you confirm exactly how that should read please?

The tagOptions property should be set to:

Album.sortTags={+Date}

This is working for me. If it isn't working for you (after restarting MinimServer and your control point), it might be that your control point is ignoring the sort order sent by MinimServer.

Quote:I think the startup issue is a problem with Linux permissions for starting minimserver on boot...

/opt/minim/minimserver/bin$ ./startc
Unable to delete file /opt/minim/minimserver/data/tmp/native/libohNetJni.so"

"/opt/minim/minimserver/bin$ ./startd
rm: cannot remove ‘/opt/minim/minimserver/data/minimserver.pipe’: Permission denied"

"/opt/minim/minimserver/bin$ sudo ./startd" works.

If you run setup using sudo, you will also need to run startc and startd using sudo.

If you run setup as a regular user, you should also run startc and startd as a regular user.

The automatic startup will run MinimServer using the same username that you used when you ran setup.

It is recommended to run setup, startc and startd as a regular user unless you have a good reason to run them using sudo.

The simplest way to fix the problem you currently have is to run uninstall using sudo and then reinstall MinimServer taking care to follow the above recommendations.
Thanks Simon, all sorted.
Reference URL's