MinimServer Forum

Full Version: Minimserver Properties screen on Windows Server 2012 R2 Core Edition
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi,

I'm looking for a way to access the properties of minimserver using windows 2012 R2 Core Edition so that I can configure it. As there is no task tray (icon), there is no way that I know of that allows me to access the properties. I was able to launch the server, so it is actually running, just not configured.

Does anybody have a solution or a workaround?

Thanks for helping me out!

Regards

Pascal
Do you have another PC or Mac where you could run MinimWatch to configure MinimServer running on your windows 2012 machine?

Alternatively, take a look at Controlling MinimServer using console commands

http://minimserver.com/ug-control.html
Hi,

Thank you, that helped! One issue remains. I'm unable to enter the following setting under stream.options: convOut=-af aresample=resampler=soxr:precision=28
This worked on minimserver when I was able to access the gui, but it doesn't work when I try doing it using minimwatch from another machine. I Keep getting the message: 'convOut' setting incorrect for converter; correct highlighted value and retry.

Any idea?

regards

Pascal
I've not used that.

Don't know if any of the discussion in this thread may help

http://forum1613.minimserver.com/showthr...263&page=5
(19-04-2015 10:10)Pascal Wrote: [ -> ]I'm unable to enter the following setting under stream.options: convOut=-af aresample=resampler=soxr:precision=28
This worked on minimserver when I was able to access the gui, but it doesn't work when I try doing it using minimwatch from another machine. I Keep getting the message: 'convOut' setting incorrect for converter; correct highlighted value and retry. Any idea?

Was the FFMPEG build you were using under the GUI the same as the one you are using now? Not all FFMPEG builds incorporate soxr (which is required for these options), though I thought that all the Windows builds from Zeranoe do so (Zeranoe lists libsoxr as one of the external libraries used).

David
@Peter: the syntax they are suggesting is the same that I used. Like I said, it works on minimserver, but not on minimwatch.

@David, it is exactly the same version. I am using the same pc for this. Changed from GUI to core mode, but minimserver lost its configuration during the conversion. The correct ffmpeg.exe file is still there though. I used a zeranoe build from the following website: http://ffmpeg.zeranoe.com/builds/
(19-04-2015 13:18)Pascal Wrote: [ -> ]@Peter: the syntax they are suggesting is the same that I used. Like I said, it works on minimserver, but not on minimwatch.

@David, it is exactly the same version. I am using the same pc for this. Changed from GUI to core mode, but minimserver lost its configuration during the conversion. The correct ffmpeg.exe file is still there though. I used a zeranoe build from the following website: http://ffmpeg.zeranoe.com/builds/

Do you have the full path to the correct version of ffmpeg.exe in the stream.converter property?
Simon,

I have the full path in there: c:\Program Files\MinimServer\ffmpeg.exe
(19-04-2015 16:42)Pascal Wrote: [ -> ]Simon,

I have the full path in there: c:\Program Files\MinimServer\ffmpeg.exe

Can you run a program from the command line? If so please run the following command and post the output here:

"c:\Program Files\MinimServer\ffmpeg.exe" -f s16le -i - -f s16le -af aresample=resampler=soxr:precision=28 -y - <NUL:
I ran the command. It doesn't display anything and just goes to the next line. This made me wonder. Tried launching just 'ffmpeg.exe' and the same thing happened.
Tried it on my other pc(with windows 8.1) and when I typed the command there I got output.

Went back to my w2012 core and converted back to gui mode. Everything worked again. ffmpeg gave the same output as on windows 8.1. Went back to core(using audiophile optimizer) and it didn't work anymore. Went to minimal server interface. Config got lost again, but in that mode I was able to add the streamer.option setting using Minimwatch. My guess is that going to core mode disables something that doesn't allow ffmpeg to run.
Pages: 1 2
Reference URL's