MinimServer Forum

Full Version: Warning: ID3v2 TYER frame has incorrect value '0'
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I've got these warnings in the log file:
Warning: ID3v2 TYER frame has incorrect value '0' at offset 280 in file Mariinsky Orchestra/Pictures/12 Recording, 2015-03-05 22_40.mp3 (length 5869970)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 280 in file Mariinsky Orchestra/Pictures/12 Recording, 2015-03-05 22_40.mp3 (length 5869970)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 280 in file Mariinsky Orchestra/Pictures/12 Recording, 2015-03-05 22_40.mp3 (length 5869970)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 159 in file Mariinsky Orchestra/Pictures/00 Night on Bare Mountain.mp3 (length 30919199)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 159 in file Mariinsky Orchestra/Pictures/00 Night on Bare Mountain.mp3 (length 30919199)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 211 in file Madonna/Confessions on a Dancefloor Qobuz/Hung Up.mp3 (length 13740384)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 279 in file Mariinsky Orchestra/Pictures/01 Recording, 2015-03-05 22_31.mp3 (length 3934818)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 159 in file Mariinsky Orchestra/Pictures/00 Night on Bare Mountain.mp3 (length 30919199)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 280 in file Mariinsky Orchestra/Pictures/14 Recording, 2015-03-05 22_45.mp3 (length 8002607)

My dac doesn't like changes in samplerate. When the sample rate changes I always mis the first 5 seconds of the song. Therefore I'm using Minimstreamer to convert all files to the same samplerate: (stream.transcode settings: aac:wav;96, alac:wav;96, mp4:wav;96, mp3:wav;96, flac:wav;96). I noticed that songs not always get converted. Most of the time the conversion works, but sometimes a song is skipped or halted or gets played in the original format. Could it be the DS112 NAS is not up to the task? Or is there a problem with the files. All of the above files are files that I have recorded from streams. The problems occured with the above files mentioned in the log.

Greetings,
(05-04-2015 20:20)jaaptina Wrote: [ -> ]Hello,

I've got these warnings in the log file:
Warning: ID3v2 TYER frame has incorrect value '0' at offset 280 in file Mariinsky Orchestra/Pictures/12 Recording, 2015-03-05 22_40.mp3 (length 5869970)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 280 in file Mariinsky Orchestra/Pictures/12 Recording, 2015-03-05 22_40.mp3 (length 5869970)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 280 in file Mariinsky Orchestra/Pictures/12 Recording, 2015-03-05 22_40.mp3 (length 5869970)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 159 in file Mariinsky Orchestra/Pictures/00 Night on Bare Mountain.mp3 (length 30919199)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 159 in file Mariinsky Orchestra/Pictures/00 Night on Bare Mountain.mp3 (length 30919199)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 211 in file Madonna/Confessions on a Dancefloor Qobuz/Hung Up.mp3 (length 13740384)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 279 in file Mariinsky Orchestra/Pictures/01 Recording, 2015-03-05 22_31.mp3 (length 3934818)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 159 in file Mariinsky Orchestra/Pictures/00 Night on Bare Mountain.mp3 (length 30919199)
Warning: ID3v2 TYER frame has incorrect value '0' at offset 280 in file Mariinsky Orchestra/Pictures/14 Recording, 2015-03-05 22_45.mp3 (length 8002607)

The year value '0' is incorrect because there was no year 0. The year 1 AD immediately followed the year 1 BC. To fix these warnings, your need to retag your files with a valid year.

Quote:My dac doesn't like changes in samplerate. When the sample rate changes I always mis the first 5 seconds of the song. Therefore I'm using Minimstreamer to convert all files to the same samplerate: (stream.transcode settings: aac:wav;96, alac:wav;96, mp4:wav;96, mp3:wav;96, flac:wav;96). I noticed that songs not always get converted. Most of the time the conversion works, but sometimes a song is skipped or halted or gets played in the original format. Could it be the DS112 NAS is not up to the task? Or is there a problem with the files. All of the above files are files that I have recorded from streams. The problems occured with the above files mentioned in the log.

Greetings,

Is it always the same files that fail to convert? If so what is the type of these files (aac, alac, mp4, mp3 or flac)?

The warnings about year '0' are not related to this conversion problem.
Quote:The year value '0' is incorrect because there was no year 0. The year 1 AD immediately followed the year 1 BC. To fix these warnings, your need to retag your files with a valid year.

Thanks for the immediate response. That will be a lot of tags to fix! But I'll manage.

Quote:Is it always the same files that fail to convert? If so what is the type of these files (aac, alac, mp4, mp3 or flac)?

It happened suddenly this morning. It might be related to the files. I changed to this fixed sample rate setting yesterday. I'll try for a few more days to see if I can find a pattern.

Greetings,
Jaap
(05-04-2015 20:36)jaaptina Wrote: [ -> ]Thanks for the immediate response. That will be a lot of tags to fix! But I'll manage.

If it's easier, you could remove the incorrect year tags instead of fixing them.
Quote:If it's easier, you could remove the incorrect year tags instead of fixing them.

Yes, I noticed that. I've got a lot of tracks without a year tag, but only 51 tracks with the year "0".
Reference URL's