MinimServer Forum

Full Version: configuring transcoding
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi,

I have trouble making transcoding to work in my installation. The idea is to enable gapless playback on my Denon renderer for all music. My Denon supports gapless playback just for lossless media (like flac), so I figured by transcoding to lossless I enjoy gapless for everything. I installed ffmpeg as the converter. I installed MinimStreamer. In the properties of MinimWatch I see the additional property stream.converter, which was automatically set to ffmpeg. I have tried different values for stream.transcode, *:L24, *:L16, *:wav. There is no error-message when I apply the configuration. I restarted MinimServer several times. I tested with BubbleUPnP as renderer, which in each case still shows the original format in the metadata of various media (for example mp3 or flac). Also, when I playback, the original format is shown. So I assume no transcoding is taking place? Logging is showing nothing special. Is there anything missing in my configuration?

Thanks,
airflow
(04-03-2015 00:28)airflow Wrote: [ -> ]Hi,

I have trouble making transcoding to work in my installation. The idea is to enable gapless playback on my Denon renderer for all music. My Denon supports gapless playback just for lossless media (like flac), so I figured by transcoding to lossless I enjoy gapless for everything. I installed ffmpeg as the converter. I installed MinimStreamer. In the properties of MinimWatch I see the additional property stream.converter, which was automatically set to ffmpeg. I have tried different values for stream.transcode, *:L24, *:L16, *:wav. There is no error-message when I apply the configuration. I restarted MinimServer several times. I tested with BubbleUPnP as renderer, which in each case still shows the original format in the metadata of various media (for example mp3 or flac). Also, when I playback, the original format is shown. So I assume no transcoding is taking place? Logging is showing nothing special. Is there anything missing in my configuration?

Thanks,
airflow

The * input type isn't doing what you think it is. It is used only for network streams of unspecified type, as described in this section. For local files, you need to specify mp3:wav24, flac:wav24 and so on.
(04-03-2015 08:08)simoncn Wrote: [ -> ]The * input type isn't doing what you think it is. It is used only for network streams of unspecified type, as described in this section. For local files, you need to specify mp3:wav24, flac:wav24 and so on.

OK, thanks for the clarification. I read the guide, but misinterpreted the meaning of "unspecified". With adapted settings, it works (log also shows "MinimStreamer: transcode setting is 'mp3:wav24'" etc).

While transcoding seems to work with a lot of my files, during testing I found that some recordings are problematic. With these files (which play perfectly normal when transcoding is off), playback doesn't start. The source-format is MP3. They show up normally when browsing the collection, meta-data is shown correctly (with modified stream-properties because of transcoding). But when I want to playback those, BubbleUPnP shows it stuck at 0:00 and it will not play. Log of MinimServer shows nothing. With these files, it doesn't make a difference what output-format I chose, it won't work with any of them. Also, there is no difference whether I use BubbleUPnP as renderer or an external renderer. Any idea what could be the problem here?
(04-03-2015 10:54)airflow Wrote: [ -> ]
(04-03-2015 08:08)simoncn Wrote: [ -> ]The * input type isn't doing what you think it is. It is used only for network streams of unspecified type, as described in this section. For local files, you need to specify mp3:wav24, flac:wav24 and so on.

OK, thanks for the clarification. I read the guide, but misinterpreted the meaning of "unspecified". With adapted settings, it works (log also shows "MinimStreamer: transcode setting is 'mp3:wav24'" etc).

While transcoding seems to work with a lot of my files, during testing I found that some recordings are problematic. With these files (which play perfectly normal when transcoding is off), playback doesn't start. The source-format is MP3. They show up normally when browsing the collection, meta-data is shown correctly (with modified stream-properties because of transcoding). But when I want to playback those, BubbleUPnP shows it stuck at 0:00 and it will not play. Log of MinimServer shows nothing. With these files, it doesn't make a difference what output-format I chose, it won't work with any of them. Also, there is no difference whether I use BubbleUPnP as renderer or an external renderer. Any idea what could be the problem here?

This might be caused by the audio data starting in the middle of an MP3 frame. Are there any messages in the MinimServer log when this happens?
(04-03-2015 11:19)simoncn Wrote: [ -> ]This might be caused by the audio data starting in the middle of an MP3 frame. Are there any messages in the MinimServer log when this happens?

No, there are no messages in the MinimServer log-file. The files play normally when not converted. I also tried checking the files for any corruptions by using the tool MP3val, which you recommended in another thread here for detecting problems with MP3-files. All files are found to be OK.
(04-03-2015 11:59)airflow Wrote: [ -> ]No, there are no messages in the MinimServer log-file. The files play normally when not converted. I also tried checking the files for any corruptions by using the tool MP3val, which you recommended in another thread here for detecting problems with MP3-files. All files are found to be OK.

Starting in the middle of an MP3 frame isn't a corruption. The player is supposed to locate the start of the next frame and play the stream from there. It might be that ffmpeg isn't doing this.

Please set the logging level to Debug, then try playing one of these files and click 'Save as' in the log window to save the log output. Zip the log file and attach it to a post here. Many thanks!
A possible cause: when transcoding FLAC to mp3, the -vn ffmpeg option must be used to exclude album art (seen by ffmpeg as a mjpeg track) from the transcode as it will the transcode to fail.
(04-03-2015 12:52)bubbleguuum Wrote: [ -> ]A possible cause: when transcoding FLAC to mp3, the -vn ffmpeg option must be used to exclude album art (seen by ffmpeg as a mjpeg track) from the transcode as it will the transcode to fail.

The OP is transcoding in the opposite direction (from mp3 to wav). Is there a similar issue if the transcoding input mp3 file contains album art inside an ID3v2 tag?
(04-03-2015 12:19)simoncn Wrote: [ -> ]Please set the logging level to Debug, then try playing one of these files and click 'Save as' in the log window to save the log output. Zip the log file and attach it to a post here. Many thanks!

I attached the requested info. I think it has to do with filename-encoding. It seems that if there a special characters in filenames, the ffmpeg-execution fails.
(04-03-2015 14:21)airflow Wrote: [ -> ]I attached the requested info. I think it has to do with filename-encoding. It seems that if there a special characters in filenames, the ffmpeg-execution fails.

Thanks for the quick response. Are you running this on FreeBSD? I will try running it on Linux to see what happens.
Pages: 1 2
Reference URL's