MinimServer Forum

Full Version: Audio sounds slow
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi I am running mimimserver/streamer on a windows PC, streaming to WDTV Live Hub to access the BBC HLS streams (cant get NP30 to run). The Audio is running slow so that voices are at a lower pitch and the music runs at a slightly slower beat, like running a record at a slightly slower speed. Any ideas?
(22-02-2015 12:34)pnadams Wrote: [ -> ]Hi I am running mimimserver/streamer on a windows PC, streaming to WDTV Live Hub to access the BBC HLS streams (cant get NP30 to run). The Audio is running slow so that voices are at a lower pitch and the music runs at a slightly slower beat, like running a record at a slightly slower speed. Any ideas?

Are you playing the stream using the instructions on this MinimStreamer page or this MinimRadio page?

Do you have anything in the stream.transcode property?
(22-02-2015 15:56)simoncn Wrote: [ -> ]
(22-02-2015 12:34)pnadams Wrote: [ -> ]Hi I am running mimimserver/streamer on a windows PC, streaming to WDTV Live Hub to access the BBC HLS streams (cant get NP30 to run). The Audio is running slow so that voices are at a lower pitch and the music runs at a slightly slower beat, like running a record at a slightly slower speed. Any ideas?

Are you playing the stream using the instructions on this MinimStreamer page or this MinimRadio page?

Do you have anything in the stream.transcode property?

Thanks for replying

I am using instructions from the MinimStreamer page. I have tried *:L16 and *:wav in the transcode property both with the same result.

I am using bubble to control it,
(22-02-2015 17:21)pnadams Wrote: [ -> ]Thanks for replying

I am using instructions from the MinimStreamer page. I have tried *:L16 and *:wav in the transcode property both with the same result.

I am using bubble to control it,

I understand why this would happen with *:L16. MinimStreamer is computing the stream audio information used by the renderer when it reads the playlist, not when the stream starts playing. For an L16 stream, this information includes the stream sample rate and MinimStreamer is using a default value of 44100 Hz instead of the actual value of 48000 Hz for the BBC HLS streams. To fix this, you need to put the correct sample rate in the playlist #EXTINF line, for example:

#EXTINF:-1,[*R3;48000] BBC Radio 3

instead of:

#EXTINF:-1,[*R3] BBC Radio 3

After changing the playlist, you need to do a Rescan from the minim icon.

This problem wouldn't occur with WAV streaming because the sample rate is taken from the WAV header instead of from the playlist stream audio information. I suspect that you were still getting L16 streaming after you changed stream.transcode to *:wav because the stream URL used by the renderer wasn't refreshed after you made this change. To ensure this URL is refreshed after you change transcoding settings, you can stop the stream playing and then do a Restart from the minim icon.
(22-02-2015 17:47)simoncn Wrote: [ -> ]
(22-02-2015 17:21)pnadams Wrote: [ -> ]Thanks for replying

I am using instructions from the MinimStreamer page. I have tried *:L16 and *:wav in the transcode property both with the same result.

I am using bubble to control it,

I understand why this would happen with *:L16. MinimStreamer is computing the stream audio information used by the renderer when it reads the playlist, not when the stream starts playing. For an L16 stream, this information includes the stream sample rate and MinimStreamer is using a default value of 44100 Hz instead of the actual value of 48000 Hz for the BBC HLS streams. To fix this, you need to put the correct sample rate in the playlist #EXTINF line, for example:

#EXTINF:-1,[*R3;48000] BBC Radio 3

instead of:

#EXTINF:-1,[*R3] BBC Radio 3

After changing the playlist, you need to do a Rescan from the minim icon.

This problem wouldn't occur with WAV streaming because the sample rate is taken from the WAV header instead of from the playlist stream audio information. I suspect that you were still getting L16 streaming after you changed stream.transcode to *:wav because the stream URL used by the renderer wasn't refreshed after you made this change. To ensure this URL is refreshed after you change transcoding settings, you can stop the stream playing and then do a Restart from the minim icon.

I tried adding 48000 into the #EXTINF INF line it doesn't seem to change anything the Amp is still reporting the input as 44.1KHz. Did you mean to put a : or ; before 48000?
It would appear that the WDTV Live hub can't accept the WAV files as I get no output after I restart MinimStreamer.
(22-02-2015 20:51)pnadams Wrote: [ -> ]I tried adding 48000 into the #EXTINF INF line it doesn't seem to change anything the Amp is still reporting the input as 44.1KHz. Did you mean to put a : or ; before 48000?
It would appear that the WDTV Live hub can't accept the WAV files as I get no output after I restart MinimStreamer.

The syntax is as I showed in my previous post:

#EXTINF:-1,[*R3;48000] BBC Radio 3

Did you Rescan after doing this?
(22-02-2015 22:12)simoncn Wrote: [ -> ]
(22-02-2015 20:51)pnadams Wrote: [ -> ]I tried adding 48000 into the #EXTINF INF line it doesn't seem to change anything the Amp is still reporting the input as 44.1KHz. Did you mean to put a : or ; before 48000?
It would appear that the WDTV Live hub can't accept the WAV files as I get no output after I restart MinimStreamer.

The syntax is as I showed in my previous post:

#EXTINF:-1,[*R3;48000] BBC Radio 3

Did you Rescan after doing this?

Thanks for your help on this. I done some more digging around on the WDTV Live Hub and I think that's where the problem is, it doesn't appear to be able to handle the 48000hz and down scales it to 44100Hhz.
I am going to have to look for another solution. I see from another thread that my Cambridge Audio NP30 that was working quite happily on the old AAC streams cant run from Minimstreamer so it looks like the BBC have left me out of pocket.
(23-02-2015 21:02)pnadams Wrote: [ -> ]Thanks for your help on this. I done some more digging around on the WDTV Live Hub and I think that's where the problem is, it doesn't appear to be able to handle the 48000hz and down scales it to 44100Hhz.
I am going to have to look for another solution. I see from another thread that my Cambridge Audio NP30 that was working quite happily on the old AAC streams cant run from Minimstreamer so it looks like the BBC have left me out of pocket.

If the NP30 was working in internet radio mode with the old BBC AAC streams, you should be able to get it working with the new streams by following the instructions on this page (assuming the NP30 can handle a sample rate of 48 kHz). Please let me know how you get on with this.
(23-02-2015 21:14)simoncn Wrote: [ -> ]
(23-02-2015 21:02)pnadams Wrote: [ -> ]Thanks for your help on this. I done some more digging around on the WDTV Live Hub and I think that's where the problem is, it doesn't appear to be able to handle the 48000hz and down scales it to 44100Hhz.
I am going to have to look for another solution. I see from another thread that my Cambridge Audio NP30 that was working quite happily on the old AAC streams cant run from Minimstreamer so it looks like the BBC have left me out of pocket.

If the NP30 was working in internet radio mode with the old BBC AAC streams, you should be able to get it working with the new streams by following the instructions on this page (assuming the NP30 can handle a sample rate of 48 kHz). Please let me know how you get on with this.

I have entered the URL with the ip address for my pc into the NP30 but it just seems to continuously search, very occasionally it says connecting briefly but then returns to searching. There are no errors in the log. I see from other posts that some devices need a value for the subnet could this be the problem with the NP30. Ive tried various values but I am not really sure what I am doing
(24-02-2015 22:48)pnadams Wrote: [ -> ]I have entered the URL with the ip address for my pc into the NP30 but it just seems to continuously search, very occasionally it says connecting briefly but then returns to searching. There are no errors in the log. I see from other posts that some devices need a value for the subnet could this be the problem with the NP30. Ive tried various values but I am not really sure what I am doing

What was the exact URL that you entered into the NP30?

You should not need to set the subnet.

Apart from the subnet, have you changed any of the MinimServer or MinimStreamer configuration settings?
Pages: 1 2
Reference URL's