MinimServer Forum

Full Version: Can't access Properties tabs for MinimServer
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
With my desktop pc still out of action, I've brought my old mid-'90s machine back into action, running Ubuntu 10.04, and installed MinimWatch on it. No problem, and it's found MinimServer running on the QNAP TS-109. Having managed to reinstall MinimServer on the QNAP (see an earlier post - thank you, Simon!) following a problematic shutdown, I now want to reinstall MinimStreamer so I can listen to internet radio. But I can't access the Properties of MinimServer, which I need to do of course to install the MinimStreamer package. The other items in the MinimWatch menu all work, and the MinimWatch log has several repeated lines as follows:

Error 1 [Unknown] invoking GetProperty on remote runtime monitor

The MinimServer log doesn't appear to contain anything relevant, merely listing various tagging errors and stating that MinimStreamer is needed to play the internet radio playlists.

Any suggestions as to what I should do to garner further information in order to diagnose the problem and put it right? And is there any other way of installing MinimStreamer on the QNAP?
(19-02-2015 19:19)nickc Wrote: [ -> ]With my desktop pc still out of action, I've brought my old mid-'90s machine back into action, running Ubuntu 10.04, and installed MinimWatch on it. No problem, and it's found MinimServer running on the QNAP TS-109. Having managed to reinstall MinimServer on the QNAP (see an earlier post - thank you, Simon!) following a problematic shutdown, I now want to reinstall MinimStreamer so I can listen to internet radio. But I can't access the Properties of MinimServer, which I need to do of course to install the MinimStreamer package. The other items in the MinimWatch menu all work, and the MinimWatch log has several repeated lines as follows:

Error 1 [Unknown] invoking GetProperty on remote runtime monitor

The MinimServer log doesn't appear to contain anything relevant, merely listing various tagging errors and stating that MinimStreamer is needed to play the internet radio playlists.

Any suggestions as to what I should do to garner further information in order to diagnose the problem and put it right? And is there any other way of installing MinimStreamer on the QNAP?

The problem sorted itself after an update of the desktop OS running MinimWatch. Still having problems playing some internet radio stations (including BBC) but that's another issue and I haven't yet read thoroughly all the discussion and guidance following the changes to BBC streams.
This problem has returned. I've now upgraded the OS to Ubuntu 12.04 and installed java 7. This afternoon I reinstalled MinimWatch and was immediately given the option of updating MinimStreamer on the NAS to v 0.5.4. which executed flawlessly. I brought up the properties dialogue from the minim tray icon to check my settings, which at a quick glance looked fine. The other menu items also worked. At last I thought I could return to my main problem - inability to play BBC radio streams, or indeed any internet radio streams. Reading through the thread on that topic I noticed a post referring to a blank transcoder field, so went back to the properties dialogue to check my settings more carefully. But now the properties dialogue won't load. I turned on debug level and this is the section from my recent attempt to access the properties:
Code:
MinimServer[QNAP-TS-109] is running
Error 1 [Unknown] invoking GetProperty on remote runtime monitor
Error 1 [Unknown] invoking GetProperty on remote runtime monitor
16:00:56.076 Thread-66: saveProperty: compName=null propName=logLevel propValue=debug
16:04:48.460 AWT-EventQueue-0: TrayView: properties action
16:04:48.467 Thread-67: ServerControl: showProperties action
16:04:48.469 Thread-67: TrayControl: getting property names for component minimserver
16:19:12.322 AWT-EventQueue-0: TrayView: properties action
16:19:12.330 Thread-68: ServerControl: showProperties action
16:19:12.330 Thread-68: TrayControl: getting property names for component minimserver

Since that last entry at 16:19:12:330 there has been no response whatever to a couple of further attempts to bring up the properties dialogue, either in the log or a pop-up message, both of which happened previously.

I am wondering if the problem could be some sort of mega delay in the system. After attempting unsuccessfully to play several internet radio channels earlier, I eventually gave up and came to write this post. A good few minutes later, I was startled when the music suddenly leapt into life! Now I can switch stations and the change is almost instantaneous, as it always was before. (But still no BBC Huh Edit: Just found the problem - I'm in France! Thanks to entdgc's post on the Linn forums http://forums.linn.co.uk/bb/showthread.p...#pid348973 I've finally got the BBC back on stream. Hooray!) I'm on wired ethernet throughout, by the way.

Any suggestions?
(26-02-2015 16:35)nickc Wrote: [ -> ]This problem has returned. I've now upgraded the OS to Ubuntu 12.04 and installed java 7. This afternoon I reinstalled MinimWatch and was immediately given the option of updating MinimStreamer on the NAS to v 0.5.4. which executed flawlessly. I brought up the properties dialogue from the minim tray icon to check my settings, which at a quick glance looked fine. The other menu items also worked. At last I thought I could return to my main problem - inability to play BBC radio streams, or indeed any internet radio streams. Reading through the thread on that topic I noticed a post referring to a blank transcoder field, so went back to the properties dialogue to check my settings more carefully. But now the properties dialogue won't load. I turned on debug level and this is the section from my recent attempt to access the properties:
Code:
MinimServer[QNAP-TS-109] is running
Error 1 [Unknown] invoking GetProperty on remote runtime monitor
Error 1 [Unknown] invoking GetProperty on remote runtime monitor
16:00:56.076 Thread-66: saveProperty: compName=null propName=logLevel propValue=debug
16:04:48.460 AWT-EventQueue-0: TrayView: properties action
16:04:48.467 Thread-67: ServerControl: showProperties action
16:04:48.469 Thread-67: TrayControl: getting property names for component minimserver
16:19:12.322 AWT-EventQueue-0: TrayView: properties action
16:19:12.330 Thread-68: ServerControl: showProperties action
16:19:12.330 Thread-68: TrayControl: getting property names for component minimserver

It sounds like the MinimServer instance running on the QNAP may have crashed.

What happens if you click Refresh from the minim icon? If MinimServer has crashed, the minim icon will change from green to grey.

If MinimServer has crashed, please do the following:

1) From the QNAP admin GUI, disable the MinimServer package
2) This will create a file named minimserver-diag.tar.gz in the Public share of the QNAP
3) Copy this file before you restart MinimServer
4) Attach this file to a post here (or let me know if it's too large to attach)
5) From the QNAP admin GUI, enable the MinimServer package

Many thanks!
Thanks Simon. I'm pretty certain MinimServer hadn't crashed. I'm going from memory now of course, but I'm pretty sure that at the same time that I couldn't access the properties I had music playing, because I was trying at the time to get BBC radio back up, and kept checking that MinimServer itself was ok by playing ordinary files from my library. I definitely remember clicking on 'refresh', more than once, and not seeing any visible change.

I now think what may have happened is that MiinimServer was still rescanning (following changes I'd made to the radio playlist file), even though the tray icon had turned green. Once before after a rescan I noticed that the icon had turned green even though the pop-up tag was still saying MinimServer was restarting, so I'm wondering if there's a minor notification glitch, or simply a delay on this very antiquated pc!

In any case, the properties tag is coming up fine again today, so only time will tell if this is a one (or two) -off occurrence. I don't need to refer to the properties tag very often, especially now everything else is up to date and working correctly.

Thanks again for your help.
(28-02-2015 13:24)nickc Wrote: [ -> ]Thanks Simon. I'm pretty certain MinimServer hadn't crashed. I'm going from memory now of course, but I'm pretty sure that at the same time that I couldn't access the properties I had music playing, because I was trying at the time to get BBC radio back up, and kept checking that MinimServer itself was ok by playing ordinary files from my library. I definitely remember clicking on 'refresh', more than once, and not seeing any visible change.

If MinimServer hadn't crashed, this could only be caused by some kind of network problem that prevented communication between MinimWatch and MinimServer. Does this provide any clues?

Quote:I now think what may have happened is that MiinimServer was still rescanning (following changes I'd made to the radio playlist file), even though the tray icon had turned green. Once before after a rescan I noticed that the icon had turned green even though the pop-up tag was still saying MinimServer was restarting, so I'm wondering if there's a minor notification glitch, or simply a delay on this very antiquated pc!

On Ubuntu, notification messages in MinimWatch can be very delayed. Changes to the icon colour should not be delayed and should reflect the current situation in real time. The message delay happens because Ubuntu won't display the next message until it has removed the preoious message, which might take 20 seconds. If MinimServer sends three messages in quick succession, the last one might be delayed by up to a minute. I don't know of any way for MinimServer to tell Ubuntu to remove a message and speed this up.

Quote:In any case, the properties tag is coming up fine again today, so only time will tell if this is a one (or two) -off occurrence. I don't need to refer to the properties tag very often, especially now everything else is up to date and working correctly.

Thanks again for your help.

Next time this happens, please try a Refresh from the minim icon and let me know what happens. Thanks!
Reference URL's