MinimServer Forum

Full Version: Missing icon in systray
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have installed minimserver 0.8.3 update 57,in /opt and I had to give 777 permissions to /opt/minimserver/data folder (no other way to make it work, I would have preferred a directory in /home/user/.config for data)

The only way I can connect to minimserver for configuration is http://localhost:9790/ (and this after a lot of tentatives!).

I have not an icon in systray both in Plasma 5 (with libappindicator installed) and lxqt desktop. I have tried trayer but also there no icon, so no real setup.

Note:
I see that minimserver is trying to update itself, but this it is not possible if installed in a root directory. How can I disable this?
I forgot to say that minimserver is started as user with the following systemd service (systemctl start minimserver@user):

Code:
[Unit]
Description=MinimServer

[Service]
User=%I
ExecStart=/bin/bash /opt/minimserver/bin/startc
ExecStop=/bin/bash /opt/minimserver/bin/stopall

[Install]
WantedBy=network.target
(28-01-2015 18:21)hifi25nl Wrote: [ -> ]I forgot to say that minimserver is started as user with the following systemd service (systemctl start minimserver@user):

Code:
[Unit]
Description=MinimServer

[Service]
User=%I
ExecStart=/bin/bash /opt/minimserver/bin/startc
ExecStop=/bin/bash /opt/minimserver/bin/stopall

[Install]
WantedBy=network.target

The minimserver/bin/setup command supports systemd directly and will create the correct systemd service definition file when you enable automatic startup from minimserver/bin/setup. MinimServer is unlikely to work correctly if you don't do this. You should delete your hand-edited service definition file and create a new service definition file by using minimserver/bin/setup while logged in as the user that you want to use to run MinimServer.

To get the MinimServer icon on your desktop, you need to use the minimserver/bin/setup command to enable desktop integration.
This is the result of launching setup as root (as user it was asking my sudo password but my system is configured to not use a general sudo password)

Code:
[root@archlinux bin]# ./setup

MinimServer desktop integration is disabled
MinimServer automatic startup is disabled

Do you want to change these settings (y/n)?
y
Enable desktop integration for MinimServer (y/n)?
y
MinimServer desktop integration has been enabled

Enable automatic startup for MinimServer (y/n)?
y
User name is not available

Abiut the icon, I was speaking before about icon in systray with right mouse options not the aplication icon in Desktop. In systray there is nothing.


(28-01-2015 19:00)simoncn Wrote: [ -> ][quote='hifi25nl' pid='13549' dateline='1422465718']

The minimserver/bin/setup command supports systemd directly and will create the correct systemd service definition file when you enable automatic startup from minimserver/bin/setup. MinimServer is unlikely to work correctly if you don't do this. You should delete your hand-edited service definition file and create a new service definition file by using minimserver/bin/setup while logged in as the user that you want to use to run MinimServer.

To get the MinimServer icon on your desktop, you need to use the minimserver/bin/setup command to enable desktop integration.
(28-01-2015 19:19)hifi25nl Wrote: [ -> ]This is the result of launching setup as root (as user it was asking my sudo password but my system is configured to not use a general sudo password)

If you launch setup as root, MinimServer will run under the root user. From your previous post, I think you don't want this.

Quote:Enable automatic startup for MinimServer (y/n)?
y
User name is not available

This error message means that the logname command isn't working. Do you have the logname command on your system? What version of Linux are you running?

Quote:Abiut the icon, I was speaking before about icon in systray with right mouse options not the aplication icon in Desktop. In systray there is nothing.

With desktop integration enabled, you should get the system tray icon if you launch MinimServer from the application icon.
I am in Archlinux updated to...today. /usr/bin/logname is installed with package coreutils.
I cannot call setup as user because my archlinux system (as in most debian systems) is not configured with a general sudo password and setup will ask for it at some time.

To summarize the problems (if installed in /opt/minimserver not in home directory)

1) At first launch is not asking for configuration
2) At first launch localhost:9790 is not working
3) Launching manually as user will not show the icon in systray
4) No setup as user (asking for sudo password) or as root : "User name is not available"
5) Cannot write to /opt/minimserver/data because the directory is owned by root
6) minimserver try to update itself but since /opt/minimserver is owned by root this can't be possible.
Personally I think that this option should be absolutely DISABLED AS DEFAULT.
7) minimserver never create systemd unit (also launching it as root)

Some tricks I have used to solve only some of the problems:
1) launch startc in a terminal as root and write the music directory at the prompt.
2) chmod 777 /opt/minimserver/data and evenutally make a symbolic link to /home/<user>/.config/minimserver/data
3) install manually a systemd service
With these tricks and my systemd service it is working but no icon on systray and so not right mouse context menu for changing configuration.
This systemd service will start "startc" as user (see above) but it is not working with "startd".
I have taken a look at the scripts and I see that at some time setup or update are called, but this will give an error because it is started as user (remember the problem with sudo).
For some reason "startc" is working (with errors about setup) where startd it is not.

Yesterday I have made a test folder
with the various files in the right directory (following general rules of most linux distrubutions):
1) applications in /usr/bin
2) libraries in /usr/lib
3) license in /usr/share/licenses/minimserver/
4) icon in /usr/share/minimserver/icons/
5) systemd service in /usr/lib/systemd/system
5) configuration files in /home/<user>/.config/minimserver/data
and I discovered that minimserver need a minimserver folder above that folders...and there is the problem that the folder data is at the same "level" of /bin and I should create a symbolic link to /home/<user>/.config/minimserver/data from that level of directory, not a good thing.

So, as a daily user of minimserver, I would like a more standard package with "launching" separate from "setup" or "update" or creation of systemd or init services or whatever automatic configuration, but this is your choice...
(29-01-2015 13:30)hifi25nl Wrote: [ -> ]So, as a daily user of minimserver, I would like a more standard package with "launching" separate from "setup" or "update" or creation of systemd or init services or whatever automatic configuration, but this is your choice...

Thank you for these comments and suggestions. The changes you are suggesting would require a major restructure of the MinimServer package. I will bear them in mind if I decide to do something like this in the future.
Reference URL's