MinimServer Forum

Full Version: Difficulties launching MinimWatch with MinimServer on Windows 8.1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have had MinimServer and MinimWatch running together normally on my Windows 7 machine for some time now, but only today decided to install them on my Windows 8.1 machine.

MinimServer starts normally on its own, with the following log:

MinimServer 0.8.3 update 55, Copyright © 2012-2014 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot™ 64-Bit Server VM (build 25.25-b02, mixed mode)
Platform default charset is windows-1252
Language setting is 'eng'
starting MinimServer[XYZ]
MinimServer[XYZ] is running
Startup complete


If I then attempt to start MinimWatch, it fails (no instances of MinimServer elsewhere on the network are reported, and the tray icon has a red minim) with the following log:

MinimWatch 0.8.3 update 30, Copyright © 2012-2014 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot™ 64-Bit Server VM (build 25.25-b02, mixed mode)
Platform default charset is windows-1252
Unable to delete old module file C:\Users\Owner\AppData\Roaming\MinimServer\libext\jminim-0.6.201.jar
Startup complete


If I then close MinimServer, and try to start MinimWatch on its own, it still fails, but with a different error message:

MinimWatch 0.8.3 update 30, Copyright © 2012-2014 Simon Nash. All rights reserved.
MinimStreamer 0.5, Copyright © 2012-2014 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot™ 64-Bit Server VM (build 25.25-b02, mixed mode)
Platform default charset is windows-1252
Previously installed package minimstreamer-0.5 conflicts with this installation
Startup complete


For comparison, the corresponding MinimWatch log on my Windows 7 machine (reporting on instances of MinimServer on the NAS and the Windows 8.1 machine) is as follows:

MinimWatch 0.8.3 update 30, Copyright © 2012-2014 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.7.0_25-b17)
Java HotSpot™ 64-Bit Server VM (build 23.25-b01, mixed mode)
Platform default charset is windows-1252
Active subnet is 192.168.0.0
Startup complete
MinimServer[XYZ] is running
MinimServer[ABC-NAS] is running


(Note that the to me surprising reference to MinimStreamer does not appear in this log.)

If I then try to start MinimServer with the MinimWatch tray icon still showing, I get the red mimim tray icon and the following log:

MinimServer 0.8.3 update 50, Copyright © 2012-2014 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot™ 64-Bit Server VM (build 25.25-b02, mixed mode)
Platform default charset is windows-1252
Unable to delete old module file C:\Users\Owner\AppData\Roaming\MinimServer\libext\jminim-0.6.201.jar
Startup complete


It appears that whichever of MinimServer and MinimWatch is started second fails with the "Unable to delete ..." message.

I'd be grateful for advice on these findings.

David
I now have a working combination of MinimServer and MinimWatch on the Windows 8.1 machine.

I remembered that I still had a copy of the MinimWatch 0.8.3 install file. With this, the install was quite normal, and MinimWatch produced a green icon and identified the running instance of MinimServer on my NAS.

For comparison, the 'good' log is

MinimWatch 0.8.3 update 30, Copyright © 2012-2014 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot™ 64-Bit Server VM (build 25.25-b02, mixed mode)
Platform default charset is windows-1252
Active subnet is 192.168.0.0
Startup complete
MinimServer[ABC-NAS] is running

So the problem seems to be with the 0.8.3a install file. Could the MinimStreamer package have been included or referenced in it by accident?

David
(05-01-2015 00:40)DavidHB Wrote: [ -> ]I now have a working combination of MinimServer and MinimWatch on the Windows 8.1 machine.

I remembered that I still had a copy of the MinimWatch 0.8.3 install file. With this, the install was quite normal, and MinimWatch produced a green icon and identified the running instance of MinimServer on my NAS.

For comparison, the 'good' log is

MinimWatch 0.8.3 update 30, Copyright © 2012-2014 Simon Nash. All rights reserved.
Java™ SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot™ 64-Bit Server VM (build 25.25-b02, mixed mode)
Platform default charset is windows-1252
Active subnet is 192.168.0.0
Startup complete
MinimServer[ABC-NAS] is running

So the problem seems to be with the 0.8.3a install file. Could the MinimStreamer package have been included or referenced in it by accident?

David

Thanks for reporting this problem. It is now fixed in the 0.8.3b Windows download for MinimWatch.

In 0.8.3a, MinimWatch was looking at the directory

C:\Users\Owner\AppData\Roaming\MinimServer\libext

for installed extensions. The correct directory is

C:\Users\Owner\AppData\Roaming\MinimWatch\libext

Because of this incorrect directory, the installations of MinimServer and MinimWatch on the same machine were conflicting with each other.
Thank you, Simon. I seem to have been roughly on the right track for once. More importantly, I should take this opportunity to congratulate you on the speed and effectiveness with which you always deal with issues of this kind.

In case any other user refers to this thread, I should make it clear that I did a full uninstall (including manually deleting folders in \Program Files and [User]\AppData\Roaming) before reinstalling from the 'good' download. I find this is a sensible precaution when dealing with problem installations.

David
Reference URL's