MinimServer Forum

Full Version: DSD and 44.1/16 only. Other bitrate PCM = silence...
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Just to put this this to rest in case anyone has a similar problem.

Someone over on the PS Audio board suggested that my problem may come from a broken file. This seemed silly at first as it happened with a number of files. Like lots and lots of them. All with >44.1/16

Upon further investigation, I finally found that EVERY FILE that is (a) Apple Lossless AND (b) is NOT 44.1/16 are affected. These files I got from HDTracks and I don't know what happened to them, but converting them to FLAC seems to work. The DS can now play over both USB from Audirvana and ethernet.

Just want to thank you again, Simon, for being so patient with me. Have a great 2015.
(03-01-2015 14:03)x838nwy Wrote: [ -> ]Just to put this this to rest in case anyone has a similar problem.

Someone over on the PS Audio board suggested that my problem may come from a broken file. This seemed silly at first as it happened with a number of files. Like lots and lots of them. All with >44.1/16

Upon further investigation, I finally found that EVERY FILE that is (a) Apple Lossless AND (b) is NOT 44.1/16 are affected. These files I got from HDTracks and I don't know what happened to them, but converting them to FLAC seems to work. The DS can now play over both USB from Audirvana and ethernet.

Just want to thank you again, Simon, for being so patient with me. Have a great 2015.

I can guess at what might be causing this problem.

Reading the Apple Lossless file format correctly is quite tricky. The sample rate information appears in two places in the file and only one of these is correct for hi-res files. I suspect the PS Audio bridge isn't handling these files correctly and is reading the sample rate information from the wrong location in the file. Do you still have the original version of any of these files?
(03-01-2015 14:12)simoncn Wrote: [ -> ]
(03-01-2015 14:03)x838nwy Wrote: [ -> ]Just to put this this to rest in case anyone has a similar problem.

Someone over on the PS Audio board suggested that my problem may come from a broken file. This seemed silly at first as it happened with a number of files. Like lots and lots of them. All with >44.1/16

Upon further investigation, I finally found that EVERY FILE that is (a) Apple Lossless AND (b) is NOT 44.1/16 are affected. These files I got from HDTracks and I don't know what happened to them, but converting them to FLAC seems to work. The DS can now play over both USB from Audirvana and ethernet.

Just want to thank you again, Simon, for being so patient with me. Have a great 2015.

I can guess at what might be causing this problem.

Reading the Apple Lossless file format correctly is quite tricky. The sample rate information appears in two places in the file and only one of these is correct for hi-res files. I suspect the PS Audio bridge isn't handling these files correctly and is reading the sample rate information from the wrong location in the file. Do you still have the original version of any of these files?

Sure do. Let me know if I can help in any way Smile
(03-01-2015 14:21)x838nwy Wrote: [ -> ]Sure do. Let me know if I can help in any way Smile

Please upload one of these files (small if possible) to my FTP server and I will take a look at it. I will PM you the server details.
(03-01-2015 14:41)simoncn Wrote: [ -> ]Please upload one of these files (small if possible) to my FTP server and I will take a look at it. I will PM you the server details.

Thanks for uploading the file. It is a 24/48000 file and both locations in the file show the correct bit depth and sample rate. The file is playing for me and I have no idea why the PS Audio bridge can't handle it.
Pages: 1 2
Reference URL's