MinimServer Forum

Full Version: MinimServer Red Icon & error message
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Can anyone tell me what is causing this and how do I resolve?
I just did a rescan and the MinimServer icon is now red and I get this error message.

[MinimServer]: Exception while processing action request: java.lang.OutOfMemoryError: Java heap space
(09-11-2014 15:02)leighton buzzard Wrote: [ -> ]Can anyone tell me what is causing this and how do I resolve?
I just did a rescan and the MinimServer icon is now red and I get this error message.

[MinimServer]: Exception while processing action request: java.lang.OutOfMemoryError: Java heap space

How many files are in your library?

Which platform are you using to run MinimServer?

You can set the resourceInfo property to make MinimServer write memory usage information to the MinimServer log. A value of 5000 should be suitable.
(09-11-2014 15:50)simoncn Wrote: [ -> ]
(09-11-2014 15:02)leighton buzzard Wrote: [ -> ]Can anyone tell me what is causing this and how do I resolve?
I just did a rescan and the MinimServer icon is now red and I get this error message.

[MinimServer]: Exception while processing action request: java.lang.OutOfMemoryError: Java heap space

How many files are in your library?

Which platform are you using to run MinimServer?

You can set the resourceInfo property to make MinimServer write memory usage information to the MinimServer log. A value of 5000 should be suitable.

Hi

I run a QNap NAS & a MacBook. There's about 4500 albums on the NAS. It's been working fine up until this morning. What's causing the problem and how do I go about the fix that you mention? Sorry, not very technically minded when it comes to stuff like this. Undecided

Thanks.
(09-11-2014 16:12)leighton buzzard Wrote: [ -> ]Hi

I run a QNap NAS & a MacBook. There's about 4500 albums on the NAS. It's been working fine up until this morning. What's causing the problem and how do I go about the fix that you mention? Sorry, not very technically minded when it comes to stuff like this. Undecided

Thanks.

I don't know what's causing the problem yet. I'm surprised this happens with only 4500 albums.

When you get the red icon, are you using MinimServer running on the MacBook ar are you using MinimServer running on the NAS?

For the next step in diagnostics, please do the following:

1) From the minim icon, select Properties
2) In the Advanced tab of the Properties dialog, set the resourceInfo property to 3000
3) Restart MinimServer
4) When you get the red icon, use 'Show log' to display the log window
5) From the log window, click 'Save as' to save a log file
6) Attach the saved log file to a post here

This information in the log file should give me some idea of what might be causing the problem.
Hi Simon

Minimserver is installed on the NAS. The red Icon is in the toolbar on the MAC where I run Minimwatch.

I followed your instructions and set the ResourceInfo property to 3000. Restarted Minimserver and no Red Icon this time.

Great news from my perspective but not sure if that helps with your diagnosis?
(09-11-2014 17:41)leighton buzzard Wrote: [ -> ]Hi Simon

Minimserver is installed on the NAS. The red Icon is in the toolbar on the MAC where I run Minimwatch.

I followed your instructions and set the ResourceInfo property to 3000. Restarted Minimserver and no Red Icon this time.

Great news from my perspective but not sure if that helps with your diagnosis?

Please attach the saved log file. This would help with my diagnosis.
Reference URL's