MinimServer Forum

Full Version: Synology DS213+ ALAC to WAV24 not working, otherwise fine
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello

When I add alac:wav24 or a alac:wav to the stream.transcode field I get "connecting..." then "can't play" on my Naim Uniti.

mp3:wav24, flac:wav24 in the stream.transcode setting works just fine and the Uniti/n-stream reports WAV corectly as the format for both MP3 and FLAC input local files. stream.convertor value is ffmpeg

ALAC streams fine from MinimServer when MinimStream is not set to try and transcode ALAC.

Any ideas?

I'm running:
Synology DS213+ DSM 5.0-4493 Update 3
Minimserver 0.8.2 update35
Minimstreamer 0.4.1
Java SE Embedded 7 1.7.0_60-0027

Thanks
Calum
(23-08-2014 13:42)mcraecalum Wrote: [ -> ]Hello

When I add alac:wav24 or a alac:wav to the stream.transcode field I get "connecting..." then "can't play" on my Naim Uniti.

mp3:wav24, flac:wav24 in the stream.transcode setting works just fine and the Uniti/n-stream reports WAV corectly as the format for both MP3 and FLAC input local files. stream.convertor value is ffmpeg

ALAC streams fine from MinimServer when MinimStream is not set to try and transcode ALAC.

Any ideas?

I'm running:
Synology DS213+ DSM 5.0-4493 Update 3
Minimserver 0.8.2 update35
Minimstreamer 0.4.1
Java SE Embedded 7 1.7.0_60-0027

Thanks
Calum

I have tried this on two renderers and it is working fine for me. Please produce a trace log by doing the following:

1) Stop n-Stream
2) From the Synology Package Center, stop and restart MinimServer
3) Set the stream.transcode property to alac:wav
4) From the minim icon, select 'Show log'
5) From the log window, change the logging level to Trace
6) Restart n-Stream
7) Try to play an ALAC file
8) From the minim icon, click 'Save as' to save a log file
9) From the log window, change the logging level back to Info
10) Zip the log file and attach it to a post here

Many thanks!
Thanks Simon

I've attached the file. Some success. A clean stop/start using the package manager and closing nstream appears to give greater consistency. I was previously using restart from minimwatch and not stopping nstream.

I will go and do further testing with alac:wav24 and flac and mp3 transcoding.
(24-08-2014 09:39)mcraecalum Wrote: [ -> ]Thanks Simon

I've attached the file. Some success. A clean stop/start using the package manager and closing nstream appears to give greater consistency. I was previously using restart from minimwatch and not stopping nstream.

I will go and do further testing with alac:wav24 and flac and mp3 transcoding.

Thanks for this log. Was any audio playing when you clicked 'Save as' to capture the log data?

The log shows that output is being sent to the renderer, but I don't see anything being read from the ALAC file. The log window wraps when it reaches a certain size, so the log doesn't include what happened when the file first started playing. For this, I would need you to capture another trace log and post the minimserver.log file from the Synology (available via File Station in the MinimServer/appData folder). To capture this trace log, please do the following:

1) Stop n-Stream
2) Make sure the MinimServer logging level is set to Info
3) From the Synology Package Center, stop and restart MinimServer
4) Set the stream.transcode property to alac:wav
5) From the minim icon, select 'Show log'
6) From the log window, change the logging level to Trace
7) Restart n-Stream
9) Try to play an ALAC file
10) After 20 seconds, use the log window to change the logging level back to Info
11) Use Synology File Station to upload the minimserver.log file from the MinimServer/appData folder to your computer
12) Zip the minimserver.log file and attach it to a post here

Many thanks!
Thanks again Simon

Here's the log from the server attached. The music file played on the Uniti and nstream reported it as wav.

All looks good and consistent now that I know how to get a clean restart.

I've now tried the setting "alac:wav24, flac:wav24" and it is looks to be stable, transcoding alac and flac files up to 24/192.

Should I expect the "alac:wav24, flac:wav24, mp3:wav" to work?


Regards
Calum
(24-08-2014 14:33)mcraecalum Wrote: [ -> ]Thanks again Simon

Here's the log from the server attached. The music file played on the Uniti and nstream reported it as wav.

All looks good and consistent now that I know how to get a clean restart.

I've now tried the setting "alac:wav24, flac:wav24" and it is looks to be stable, transcoding alac and flac files up to 24/192.

Thanks for this log. Everything looks normal. There aren't any log entries from reading the ALAC file because ffmpeg is doing this.

Quote:Should I expect the "alac:wav24, flac:wav24, mp3:wav" to work?

Regards
Calum

Yes
Thanks Simon

I've noticed that if I close nStream and have left it on a track somewhere on the folder hierarchy, there are sometimes problems when I reopen nStream later in the day - I get the connecting message and the track doesn't play. I have to force a clean restart - as per your instructions - to set all back to normal.

I've tried placing nStream and the Uniti at the top level of the Synology Media player i.e. not using Minimserver - before I close nStream. That seems to work and both nStream and Minimserver work first time when I then play a track via Minimserver.

Could it be a connection is somehow left open? Guesswork on my part Smile

I'll continue to experiment.

I'll post back if I can narrow the behaviour down and give a consistent test case.

Thanks again for your help and for the software.
(25-08-2014 20:00)mcraecalum Wrote: [ -> ]Thanks Simon

I've noticed that if I close nStream and have left it on a track somewhere on the folder hierarchy, there are sometimes problems when I reopen nStream later in the day - I get the connecting message and the track doesn't play. I have to force a clean restart - as per your instructions - to set all back to normal.

I've tried placing nStream and the Uniti at the top level of the Synology Media player i.e. not using Minimserver - before I close nStream. That seems to work and both nStream and Minimserver work first time when I then play a track via Minimserver.

Could it be a connection is somehow left open? Guesswork on my part Smile

I'll continue to experiment.

I'll post back if I can narrow the behaviour down and give a consistent test case.

Thanks again for your help and for the software.

It sounds like this is likely to be a problem with n-Stream or the Naim renderer. I haven't had any other reports of this.

If you can find a way to reproduce this problem consistently, please create a trace log by doing the following:

1) Before you reopen n-Stream, set the MinimServer logging level to Trace
2) Reopen n-Stream

If the track doesn't play,

3) Wait 20 seconds, then set the logging level back to Info
4) Zip the minimserver.log file from the Synology and attach it to a post here

I will look at the log and let you know what is happening.
Reference URL's