MinimServer Forum

Full Version: MinimServer (0.8.2) & Kazoo
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Hi Simon

I've had issues with Kazoo on Windows (iPad is OK). Linn have looked at various versions and coredumps and they suggest that Minim is the issue. Could you take a look through the enclosed and see what you think ? (rename from .txt to .msg)

Thanks!
Mike
(05-08-2014 10:56)MikeSpragg Wrote: [ -> ]Hi Simon

I've had issues with Kazoo on Windows (iPad is OK). Linn have looked at various versions and coredumps and they suggest that Minim is the issue. Could you take a look through the enclosed and see what you think ? (rename from .txt to .msg)

Thanks!
Mike

I tried renaming the file to .msg but my computer doesn't know how to open a .msg file. Can you reformat this into plain text?
(05-08-2014 11:12)simoncn Wrote: [ -> ]I tried renaming the file to .msg but my computer doesn't know how to open a .msg file. Can you reformat this into plain text?

I have downloaded a utility that is able to display the file.
(05-08-2014 10:56)MikeSpragg Wrote: [ -> ]Hi Simon

I've had issues with Kazoo on Windows (iPad is OK). Linn have looked at various versions and coredumps and they suggest that Minim is the issue. Could you take a look through the enclosed and see what you think ? (rename from .txt to .msg)

Thanks!
Mike

If you can reproduce the problem, please do the following:

1) In the MinimServer log window, set the logging level to Debug
2) In the log window, click Clear
3) Leave the log window open
4) Browse using Kazoo until the problem occurs
5) In the log window, click 'Save as' to save the log data to a file
6) In the log window, set the logging level back to Info
7) Zip the saved log file and attach it to a post here

Many thanks!
(05-08-2014 15:28)simoncn Wrote: [ -> ]
(05-08-2014 10:56)MikeSpragg Wrote: [ -> ]Hi Simon

I've had issues with Kazoo on Windows (iPad is OK). Linn have looked at various versions and coredumps and they suggest that Minim is the issue. Could you take a look through the enclosed and see what you think ? (rename from .txt to .msg)

Thanks!
Mike

If you can reproduce the problem, please do the following:

1) In the MinimServer log window, set the logging level to Debug
2) In the log window, click Clear
3) Leave the log window open
4) Browse using Kazoo until the problem occurs
5) In the log window, click 'Save as' to save the log data to a file
6) In the log window, set the logging level back to Info
7) Zip the saved log file and attach it to a post here

Many thanks!

Thanks Simon, will do - I'm able to use Kazoo against the same library on QNAP directly (their own DLNA Server) without issues. I've noticed the problem is more with the All Artists selection. Will grab the log file...
(05-08-2014 19:15)MikeSpragg Wrote: [ -> ]
(05-08-2014 15:28)simoncn Wrote: [ -> ]
(05-08-2014 10:56)MikeSpragg Wrote: [ -> ]Hi Simon

I've had issues with Kazoo on Windows (iPad is OK). Linn have looked at various versions and coredumps and they suggest that Minim is the issue. Could you take a look through the enclosed and see what you think ? (rename from .txt to .msg)

Thanks!
Mike

If you can reproduce the problem, please do the following:

1) In the MinimServer log window, set the logging level to Debug
2) In the log window, click Clear
3) Leave the log window open
4) Browse using Kazoo until the problem occurs
5) In the log window, click 'Save as' to save the log data to a file
6) In the log window, set the logging level back to Info
7) Zip the saved log file and attach it to a post here

Many thanks!

Thanks Simon, will do - I'm able to use Kazoo against the same library on QNAP directly (their own DLNA Server) without issues. I've noticed the problem is more with the All Artists selection. Will grab the log file...

Here you go - Kazoo hung at the last log entry.
(05-08-2014 19:17)MikeSpragg Wrote: [ -> ]
(05-08-2014 19:15)MikeSpragg Wrote: [ -> ]
(05-08-2014 15:28)simoncn Wrote: [ -> ]
(05-08-2014 10:56)MikeSpragg Wrote: [ -> ]Hi Simon

I've had issues with Kazoo on Windows (iPad is OK). Linn have looked at various versions and coredumps and they suggest that Minim is the issue. Could you take a look through the enclosed and see what you think ? (rename from .txt to .msg)

Thanks!
Mike

If you can reproduce the problem, please do the following:

1) In the MinimServer log window, set the logging level to Debug
2) In the log window, click Clear
3) Leave the log window open
4) Browse using Kazoo until the problem occurs
5) In the log window, click 'Save as' to save the log data to a file
6) In the log window, set the logging level back to Info
7) Zip the saved log file and attach it to a post here

Many thanks!

Thanks Simon, will do - I'm able to use Kazoo against the same library on QNAP directly (their own DLNA Server) without issues. I've noticed the problem is more with the All Artists selection. Will grab the log file...

Here you go - Kazoo hung at the last log entry.

Also, if it helps, I'm using a debug version of Kazoo and enclosed is their error log which, as you can see, also stops at 19:16 but then continues after I scroll up, exit.
(05-08-2014 19:17)MikeSpragg Wrote: [ -> ]Here you go - Kazoo hung at the last log entry.

Thanks for the quick response. It looks like MinimServer is either deadlocked or hung in a CPU loop. Please do the following while the problem is occuring:

1) Login to the NAS via SSH using putty

2) Issue the command:

ps | grep java

to find the Minimserver process, which will look like this:

10132 admin 70300 S /usr/local/jre/bin/java -jar ../lib/mserver.jar --noconsole --nohup

3) Note the process ID (10132 in this example)

4) Issue this command with the correct process ID:

kill -quit 10132

5) This won't kill or quit MinimServer but it will write a thread dump to the file /tmp/minimserver-out-10132.log

6) Attach the contents of this file to a post here

Many thanks!
(05-08-2014 19:47)simoncn Wrote: [ -> ]
(05-08-2014 19:17)MikeSpragg Wrote: [ -> ]Here you go - Kazoo hung at the last log entry.

Thanks for the quick response. It looks like MinimServer is either deadlocked or hung in a CPU loop. Please do the following while the problem is occuring:

1) Login to the NAS via SSH using putty

2) Issue the command:

ps | grep java

to find the Minimserver process, which will look like this:

10132 admin 70300 S /usr/local/jre/bin/java -jar ../lib/mserver.jar --noconsole --nohup

3) Note the process ID (10132 in this example)

4) Issue this command with the correct process ID:

kill -quit 10132

5) This won't kill or quit MinimServer but it will write a thread dump to the file /tmp/minimserver-out-10132.log

6) Attach the contents of this file to a post here

Many thanks!

Thanks Simon, here you go !
(05-08-2014 19:56)MikeSpragg Wrote: [ -> ]
(05-08-2014 19:47)simoncn Wrote: [ -> ]
(05-08-2014 19:17)MikeSpragg Wrote: [ -> ]Here you go - Kazoo hung at the last log entry.

Thanks for the quick response. It looks like MinimServer is either deadlocked or hung in a CPU loop. Please do the following while the problem is occuring:

1) Login to the NAS via SSH using putty

2) Issue the command:

ps | grep java

to find the Minimserver process, which will look like this:

10132 admin 70300 S /usr/local/jre/bin/java -jar ../lib/mserver.jar --noconsole --nohup

3) Note the process ID (10132 in this example)

4) Issue this command with the correct process ID:

kill -quit 10132

5) This won't kill or quit MinimServer but it will write a thread dump to the file /tmp/minimserver-out-10132.log

6) Attach the contents of this file to a post here

Many thanks!

Thanks Simon, here you go !

Actually, not quite confident in whether it was hanging (as it didn't do what it ordinarily do - display some files). Managed to repeat it and here's the new log file.
Pages: 1 2 3
Reference URL's