MinimServer Forum

Full Version: Minimserver crash on Windows 8.1 (64bit)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I installed minimserver on my Windows 8.1 64 bit pc, using the 64-bit version of Minimserver and found it to load very slow. Also a rescan is very slow (compared to my previous install on Windows 7 and even older server 2003).

The latest java and Minimserver with all updates is installed.

When doing a search for a track using my Denon app on iPad the minimserver crashes.

Here's the log output :

MinimServer[Mars] is running
MinimServer: exception while processing action request: java.lang.NullPointerException
java.lang.NullPointerException
at com.minimserver.Server$AlbumListView.populateArtists(Server.java:13975)
at com.minimserver.Server$AlbumListView.childContainer(Server.java:13931)
at com.minimserver.Server$AlbumListContainer.childContainer(Server.java:14029)
at com.minimserver.Server.getContainer(Server.java:5431)
at com.minimserver.Server.populateContainer(Server.java:5494)
at com.minimserver.Server.access$16200(Server.java:93)
at com.minimserver.Server$ContentDirectoryProvider.doSearch(Server.java:15577)
at com.minimserver.Server$ContentDirectoryProvider.search(Server.java:15463)
at org.openhome.net.device.providers.DvProviderUpnpOrgContentDirectory1$DoSearch.ac​tionInvoked(DvProviderUpnpOrgContentDirectory1.java:1049)
starting MinimServer[Mars]

Is there something I should check ?
(07-07-2014 08:53)ppienter Wrote: [ -> ]I installed minimserver on my Windows 8.1 64 bit pc, using the 64-bit version of Minimserver and found it to load very slow. Also a rescan is very slow (compared to my previous install on Windows 7 and even older server 2003).

The latest java and Minimserver with all updates is installed.

When doing a search for a track using my Denon app on iPad the minimserver crashes.

Here's the log output :

MinimServer[Mars] is running
MinimServer: exception while processing action request: java.lang.NullPointerException
java.lang.NullPointerException
at com.minimserver.Server$AlbumListView.populateArtists(Server.java:13975)
at com.minimserver.Server$AlbumListView.childContainer(Server.java:13931)
at com.minimserver.Server$AlbumListContainer.childContainer(Server.java:14029)
at com.minimserver.Server.getContainer(Server.java:5431)
at com.minimserver.Server.populateContainer(Server.java:5494)
at com.minimserver.Server.access$16200(Server.java:93)
at com.minimserver.Server$ContentDirectoryProvider.doSearch(Server.java:15577)
at com.minimserver.Server$ContentDirectoryProvider.search(Server.java:15463)
at org.openhome.net.device.providers.DvProviderUpnpOrgContentDirectory1$DoSearch.ac​tionInvoked(DvProviderUpnpOrgContentDirectory1.java:1049)
starting MinimServer[Mars]

Is there something I should check ?

I understand what is causing the crash and I will fix it in the next update. Thanks for reporting this problem.

I don't understand why MinimServer would be slower on Windows 8.1 than on Windows 7. Have you looked at Task Manager to see if any programs are consuming excessive system resources?
(07-07-2014 22:30)simoncn Wrote: [ -> ]I understand what is causing the crash and I will fix it

Thanks!

(07-07-2014 22:30)simoncn Wrote: [ -> ]I don't understand why MinimServer would be slower on Windows 8.1 than on Windows 7. Have you looked at Task Manager to see if any programs are consuming excessive system resources?

Nothing in particular. I have less than 10% cpu usage.
(08-07-2014 13:55)ppienter Wrote: [ -> ]Nothing in particular. I have less than 10% cpu usage.

What about memory usage? 64-bit Windows uses more memory than 32-bit Windows. You might need to install additional RAM on the machine.
(08-07-2014 14:50)simoncn Wrote: [ -> ]
(08-07-2014 13:55)ppienter Wrote: [ -> ]Nothing in particular. I have less than 10% cpu usage.

What about memory usage? 64-bit Windows uses more memory than 32-bit Windows. You might need to install additional RAM on the machine.

I have 16 GB installed with 24% usage.
CPU is Intel i7-3770 @ 3.4 GHz

If I do a rescan it takes easily 20 minutes. At my parents on older windows server 2003 with similar library only 2 to 3 mins.
(14-07-2014 09:49)ppienter Wrote: [ -> ]I have 16 GB installed with 24% usage.
CPU is Intel i7-3770 @ 3.4 GHz

If I do a rescan it takes easily 20 minutes. At my parents on older windows server 2003 with similar library only 2 to 3 mins.

Is your library on a network share, a USB drive or a local HDD? If it is on a network share, this is the cause of the performance problem.
(14-07-2014 10:34)simoncn Wrote: [ -> ]
(14-07-2014 09:49)ppienter Wrote: [ -> ]I have 16 GB installed with 24% usage.
CPU is Intel i7-3770 @ 3.4 GHz

If I do a rescan it takes easily 20 minutes. At my parents on older windows server 2003 with similar library only 2 to 3 mins.

Is your library on a network share, a USB drive or a local HDD? If it is on a network share, this is the cause of the performance problem.

It's on a network share (1Gbit lan) but it's the same at my parents. I'll try to use my local copy of it to see if it will be faster.

Thanks.
(14-07-2014 12:21)ppienter Wrote: [ -> ]I'll try to use my local copy of it to see if it will be faster.
Thanks.

You're right ! It takes less than 2 minutes to do the rescan when the library is on my local disk Shy
(15-07-2014 17:04)ppienter Wrote: [ -> ]You're right ! It takes less than 2 minutes to do the rescan when the library is on my local disk Shy

This is caused by the overheads of the SMB/CIFS protocol for network disk access. The recommended approach is to run MinimServer on the NAS that you're using to store your data. Even with a slower CPU in the NAS, a rescan should be much faster.
Reference URL's