MinimServer Forum

Full Version: A full function linux control point?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9
On installing the deb, all went well, except I had to install libupnp6, not libupnp3 as requested. Is that OK?

I've just a play with one of my renderers (and all firewalls off for a few minutes!) and using minimserver as the server.

When I manage to select something it plays fine thus far (although the volume control doesn't seem to do anything). The main issue is that I don't seem to be able to do anything other than select and add one track at a time. I can add more tracks individually but I often want to select a whole Album or other set of tracks.

The right click menu hardly ever appears (I haven't worked out exactly when it does and does not). If I drag from the minimserver menu it looks as if it is going to work (the icon is OK) but nothing gets added. Clicking or doubleclicking an album does nothing. Similarly using the folder view I can't seem to do anything other than select and play individual tracks.

Have I missed something? (knowing me that wouldn't be unusual!).

I'm on a fully up to date ubuntu 14.04 64 bit system.

Having said the above, this does look very promising Smile
(05-10-2014 15:53)Pastim Wrote: [ -> ]On installing the deb, all went well, except I had to install libupnp6, not libupnp3 as requested. Is that OK?

I've just a play with one of my renderers (and all firewalls off for a few minutes!) and using minimserver as the server.

When I manage to select something it plays fine thus far (although the volume control doesn't seem to do anything). The main issue is that I don't seem to be able to do anything other than select and add one track at a time. I can add more tracks individually but I often want to select a whole Album or other set of tracks.

The right click menu hardly ever appears (I haven't worked out exactly when it does and does not). If I drag from the minimserver menu it looks as if it is going to work (the icon is OK) but nothing gets added. Clicking or doubleclicking an album does nothing. Similarly using the folder view I can't seem to do anything other than select and play individual tracks.

Have I missed something? (knowing me that wouldn't be unusual!).

I'm on a fully up to date ubuntu 14.04 64 bit system.

Having said the above, this does look very promising Smile
A quick update - the right click menu seems to work 1st time on a whole album, and then not on subsequent selections.
(05-10-2014 14:46)simoncn Wrote: [ -> ]This sounds very interesting! Smile

I am still on 12.04 and I'm planning to upgrade to 14.04 soon. Can the .deb binary package be installed on 12.04?

The 14.04 package has little chance to run on 12.04, but I can easily build a 12.04 package. What architecture are you running (I'd guess intel, so the question narrows to 32 or 64 bits) ?

Otoh, don't get your expectations too high, this is really a rough app. It does not seem to crash (at least on my setup), but you will not find the niceties of "real" CPs.

Cheers,

jf
(05-10-2014 15:53)Pastim Wrote: [ -> ]On installing the deb, all went well, except I had to install libupnp6, not libupnp3 as requested. Is that OK?

Yes, this is ok (necessary, indeed). The name of the library changed between 12.04 and 14.04, I guess I that forgot to update the package dependancies.

(05-10-2014 15:53)Pastim Wrote: [ -> ]I've just a play with one of my renderers (and all firewalls off for a few minutes!) and using minimserver as the server.

When I manage to select something it plays fine thus far (although the volume control doesn't seem to do anything).

The volume control seems to work for me, but it makes sense that this might depend on the renderer. What are you testing with ?

(05-10-2014 15:53)Pastim Wrote: [ -> ]The main issue is that I don't seem to be able to do anything other than select and add one track at a time. I can add more tracks individually but I often want to select a whole Album or other set of tracks.

The right click menu hardly ever appears (I haven't worked out exactly when it does and does not). If I drag from the minimserver menu it looks as if it is going to work (the icon is OK) but nothing gets added. Clicking or doubleclicking an album does nothing. Similarly using the folder view I can't seem to do anything other than select and play individual tracks.

Have I missed something? (knowing me that wouldn't be unusual!).

I'm on a fully up to date ubuntu 14.04 64 bit system.

Having said the above, this does look very promising Smile

A quick update - the right click menu seems to work 1st time on a whole album, and then not on subsequent selections.

It's the second time that the disappearing right-click menu is reported, and I spent a few hours this morning trying to reproduce it, with no success. I am going to try an install from scratch in a brand new VM to try and reproduce it. I'll assume that you are using Minim as a Media Server, and the regular ubuntu desktop (not xubuntu or kubuntu) ?
(05-10-2014 16:44)medoc92 Wrote: [ -> ]
(05-10-2014 15:53)Pastim Wrote: [ -> ]On installing the deb, all went well, except I had to install libupnp6, not libupnp3 as requested. Is that OK?

Yes, this is ok (necessary, indeed). The name of the library changed between 12.04 and 14.04, I guess I that forgot to update the package dependancies.

Should have checked before answering, this is a doc bug actually, the web page is wrong, the package is correct. Fixing it.
(05-10-2014 16:44)medoc92 Wrote: [ -> ]The volume control seems to work for me, but it makes sense that this might depend on the renderer. What are you testing with ?
A Marantz CR603. I'll try later tonight with another renderer.
Quote:It's the second time that the disappearing right-click menu is reported, and I spent a few hours this morning trying to reproduce it, with no success. I am going to try an install from scratch in a brand new VM to try and reproduce it. I'll assume that you are using Minim as a Media Server, and the regular ubuntu desktop (not xubuntu or kubuntu) ?
I'm using plain (fully up to date) desktop ubuntu 14.04 64 bit and minimserver on a different system. I'll be trying later with an xubuntu system (also 14.04).
Hi again,

I think that I have fixed the popup menu issue. It was only happening on non-openhome renderers, which is why I had missed it.

About the volume control issue, I have an idea of what can be wrong, but the fix will take a bit more time (not today). If you experiment with this, be prudent and set the hardware volume reasonably low (if you have an independant hardware volume control), I think that the slider could unexpectedly set the volume to the maximum in some situations.

I am uploading updated packages to the web site, I added the Ubuntu 12.04 ones (for 32 and 64 bits).

jf
(05-10-2014 18:05)medoc92 Wrote: [ -> ]I am uploading updated packages to the web site, I added the Ubuntu 12.04 ones (for 32 and 64 bits).

I'm using Intel 64-bit Ubuntu 12.04. I downloaded the .deb file and tried to install it. dpkg complained about missing packages libqtwebkit4 and upmpdcli. I tried to install these packages using apt-get and got messages saying that libqtwebkit4 requires upmpdcli and upmpdcli is not available. I have two questions:

1) What should I do to install the missing dependencies?

2) Does upplay use MPD? It seems that upmpdcli is a client for MPD. I don't wish to install MPD or use it as my renderer.
I have downloaded the new version, and the menu right-click issue is fixed - thanks very much.

As to the volume control, it doesn't change the volume on my renderers (Marantz and also Musical Fidelity M1CLiC), but if I change the volume on them using a remote control, the slider moves on the upplay screen. So there is some form of communication going on, but one way.

By doing:
Code:
sudo rm /etc/init.d/upmpdcli
as on your downloads page, upmpdcli no longer starts - thanks.

I have a few other observations to make - I hope they'll be taken in the spirit intended - ie. a few notes, not complaints!

Gapless works on my better renderer (M1CLiC) but not the Marantz - much as expected and consistent with other control points.

On my xubuntu laptop there's no slider for the list of tracks, whereas on ubuntu there is. It's not important, but when there are hundreds of items it takes a little to scroll down while using PgDn or down-arrow. I assume this is something to do with different versions of QT.

It would be nice to be able to resize the now-playing window. Many of my classical tracks have long names.

If the last renderer used is not powered on, upplay won't start (checked in a terminal window). I get a message like:
Code:
Renderer uuid:5f9ec1b3-ff59-19bb-8530-0006780950ce not found
Can't connect to media renderer
It would be neater if it started and asked for a device to use.

All in all I now have a very usable linux control point for minimserver. This in turn means I'll use that more often as well. I hope you get many more users and get to a point where it's a fully supported ubuntu application. It's already miles better than anything else I have tried Smile
(05-10-2014 18:52)simoncn Wrote: [ -> ]
(05-10-2014 18:05)medoc92 Wrote: [ -> ]I am uploading updated packages to the web site, I added the Ubuntu 12.04 ones (for 32 and 64 bits).

I'm using Intel 64-bit Ubuntu 12.04. I downloaded the .deb file and tried to install it. dpkg complained about missing packages libqtwebkit4 and upmpdcli. I tried to install these packages using apt-get and got messages saying that libqtwebkit4 requires upmpdcli and upmpdcli is not available. I have two questions:

1) What should I do to install the missing dependencies?

2) Does upplay use MPD? It seems that upmpdcli is a client for MPD. I don't wish to install MPD or use it as my renderer.

for libqtwebkit, you need to install the libqtwebkit4 package, this is standard from the Ubuntu repositories.

upplay does not use MPD, it needs the upmpdcli installation because of a shared library which comes with upmpdcli and which is used by upplay. The shared lib contains UPnP code and has nothing to do with MPD.

There is no link betweeen upmpdcli and upplay other than they use the same library, and that the easiest way to get this library at the moment is to install upmpdcli, which will also need libmpdclient2 as a dependancy.

This is just a temporary inconvenience, and it does not mean that you need to run MPD in any way. I'll clean up the package structure (separate the library) ASAP, but upmpdcli is being integrated as the UPnP front-end for a few specialized distributions at the moment and I want to wait for this to be stabilized before I shake the tree.

To prevent upmpdcli from starting up, just delete its init file:

rm /etc/init.d/upmpdcli
Pages: 1 2 3 4 5 6 7 8 9
Reference URL's