MinimServer Forum

Full Version: Qnap TS220 installation problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have recently purchased QNAP TS 220 to work with Naim NDX.
I have read many favourable reports on the Naim forum about Minimserver and decided to try it.
Everything appeared to be ok with the installation until the Minimserver application was enabled, after about 10 seconds it was disabled with the following message in the system log :-minimserver start error: /share/MDO_DATA/.qpkg/minimserver.sh:line 84/usr/local/jre/bin/java: No such file or directory.

I disabled and re-enabled minimserver and then restarted the nas as suggested but the problem remained.

Any suggestions/ advice would be appreciated.

Huh
(27-03-2014 19:57)QTEC Wrote: [ -> ]I have recently purchased QNAP TS 220 to work with Naim NDX.
I have read many favourable reports on the Naim forum about Minimserver and decided to try it.
Everything appeared to be ok with the installation until the Minimserver application was enabled, after about 10 seconds it was disabled with the following message in the system log :-minimserver start error: /share/MDO_DATA/.qpkg/minimserver.sh:line 84/usr/local/jre/bin/java: No such file or directory.

I disabled and re-enabled minimserver and then restarted the nas as suggested but the problem remained.

Any suggestions/ advice would be appreciated.

Huh

You need to install Java on the NAS before installing MinimServer. For detailed instructions, see this page. You should uninstall MinimServer before you install Java. After you have successfully installed Java, install MinimServer again and MinimServer should start without producing an error message.
(27-03-2014 23:08)simoncn Wrote: [ -> ]
(27-03-2014 19:57)QTEC Wrote: [ -> ]I have recently purchased QNAP TS 220 to work with Naim NDX.
I have read many favourable reports on the Naim forum about Minimserver and decided to try it.
Everything appeared to be ok with the installation until the Minimserver application was enabled, after about 10 seconds it was disabled with the following message in the system log :-minimserver start error: /share/MDO_DATA/.qpkg/minimserver.sh:line 84/usr/local/jre/bin/java: No such file or directory.

I disabled and re-enabled minimserver and then restarted the nas as suggested but the problem remained.

Any suggestions/ advice would be appreciated.

Huh

You need to install Java on the NAS before installing MinimServer. For detailed instructions, see this page. You should uninstall MinimServer before you install Java. After you have successfully installed Java, install MinimServer again and MinimServer should start without producing an error message.

Thanks for your prompt response.
I did follow your installation guide for QNAP NAS.
I copied the java file to the public share file in the tar.gz format.
The file size is 32mb.
I installed the JRE_7qpkg and enabled it in the QNAP admin console.
I then installed the minimserver qpkg and enabled it.
I then got the above error message.
It appears that the JRE7 is not unpacking the tar.gz file in the public folder.
(28-03-2014 15:24)QTEC Wrote: [ -> ]Thanks for your prompt response.
I did follow your installation guide for QNAP NAS.
I copied the java file to the public share file in the tar.gz format.
The file size is 32mb.
I installed the JRE_7qpkg and enabled it in the QNAP admin console.
I then installed the minimserver qpkg and enabled it.
I then got the above error message.
It appears that the JRE7 is not unpacking the tar.gz file in the public folder.

Does the JRE QPKG show as enabled (orange icon) in the QPKG Center?

Did you get any error messages in the system log when you installed or enabled the JRE QPKG?

Did you copy the correct Java file to the Public share? The version you need is either "ARMv5 Linux - Headless EABI, SoftFP ABI, Little Endian" (for Java 7) or "ARMv5 Linux - Headless EABI, SoftFP, Little Endian" (for Java 6). What was the exact filename of the Java download that you copied?
(28-03-2014 15:53)simoncn Wrote: [ -> ]
(28-03-2014 15:24)QTEC Wrote: [ -> ]Thanks for your prompt response.
I did follow your installation guide for QNAP NAS.
I copied the java file to the public share file in the tar.gz format.
The file size is 32mb.
I installed the JRE_7qpkg and enabled it in the QNAP admin console.
I then installed the minimserver qpkg and enabled it.
I then got the above error message.
It appears that the JRE7 is not unpacking the tar.gz file in the public folder.

Does the JRE QPKG show as enabled (orange icon) in the QPKG Center?

Did you get any error messages in the system log when you installed or enabled the JRE QPKG?

Did you copy the correct Java file to the Public share? The version you need is either "ARMv5 Linux - Headless EABI, SoftFP ABI, Little Endian" (for Java 7) or "ARMv5 Linux - Headless EABI, SoftFP, Little Endian" (for Java 6). What was the exact filename of the Java download that you copied?

That was the problem Simon, I had downloaded the client compiler version.
Everything appears to be ok now.
Many thanks for your prompt assistance.
I will give it a try now.
(28-03-2014 17:24)QTEC Wrote: [ -> ]That was the problem Simon, I had downloaded the client compiler version.
Everything appears to be ok now.
Many thanks for your prompt assistance.
I will give it a try now.

You're very welcome!

Don't forget to reinstall MinimServer after you have reinstalled Java. if you don't do this, MinimServer might not start correctly when the NAS is rebooted.
Reference URL's