MinimServer Forum

Full Version: MS doesn't scan filenames with special chars
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I discovered that MinimServer is not able to scan files with filenames containing special (accented) not-English characters.

For instance:

Blue Rondo à la Turk.flac
Si può dare di più.mp3
Senza pietà.flac

To be scanned, it's necessary to manually change their file name, e.g.

Blue Rondo a la Turk.flac
Si puo dare di piu.mp3
Senza pieta.mp3

In European Countries, you'll find such charachters very often in filenames...

Bye

My configuration:
MinimServer ARM5 last version on Buffalo NAS

P.S. Of course such files are perfectly recognized and managed by NAS file system and other servers like Twonky
P.S. 2: MinimServer log doesn't trace it's skipping this kind of files
same problem with special chars in folder names.
Even if the file name is "clean" from special chars, if any special char is in the folder name, entire folder is skipped (without being logged).

This cause the missing scan of LOTS of files
I can confirm that MinimServer can handle these special characters perfectly well. Simon has previously advised that issues of this kind are typically caused by a mismatch between the character set the computer or NAS OS is using and the one MinimServer expects. Which NAS are you running MinimServer on? And when MinimServer is started, what does the log say as to which character set is in use?

David
(01-02-2014 01:57)thetalm Wrote: [ -> ]same problem with special chars in folder names.
Even if the file name is "clean" from special chars, if any special char is in the folder name, entire folder is skipped (without being logged).

This cause the missing scan of LOTS of files

Try adding the line

export LANG="en_US.utf8"

to the startd script, just before the line starting with LD_LIBRARY_PATH.

This setting is normally provided by the NAS. It seems your Buffalo NAS doesn't do this.

Without this setting, Java doesn't inform MinimServer about the existence of these folders and files, so it isn't possible for MinimServer to produce any log messages about them.
(01-02-2014 09:41)simoncn Wrote: [ -> ]Try adding the line

export LANG="en_US.utf8"

to the startd script, just before the line starting with LD_LIBRARY_PATH.

Done, with no results. No log, no scan

Do lines below tell you anything ? Have I to install locales ?
Code:
login as: root
root@192.168.0.112's password:
Last login: Sat Feb  1 11:23:20 2014 from 192.168.0.120
root@Buffalo:~# locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
root@Buffalo:~# dpkg -l locales
No packages found matching locales.
(01-02-2014 11:40)thetalm Wrote: [ -> ]Done, with no results. No log, no scan

Do lines below tell you anything ? Have I to install locales ?
Code:
login as: root
root@192.168.0.112's password:
Last login: Sat Feb  1 11:23:20 2014 from 192.168.0.120
root@Buffalo:~# locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
root@Buffalo:~# dpkg -l locales
No packages found matching locales.

Please check the MinimServer log. It will tell you which platform default charset MinimServer is using. This value should be UTF-8. What do you see?

As the LANG setting in startd didn't work, it sounds like you might need to set the default system locale to something that includes the UTF-8 charset. You should be able to use the locale -a command to list all available locales. Perhaps you can find some help for doing this on a Buffalo forum.
(01-02-2014 14:14)simoncn Wrote: [ -> ]Please check the MinimServer log. It will tell you which platform default charset MinimServer is using. This value should be UTF-8. What do you see?

I was not able to see anything about charset in the log. Even in trace mode. See yourself in the attachment. (log in trace mode saved by minimwatch installed on a Windows 8.1 PC)
Note the Evertest playlist at the end of the log is my "probe" to see if Minimserver was able to scan the files with strange filenames...

(01-02-2014 14:14)simoncn Wrote: [ -> ]As the LANG setting in startd didn't work, it sounds like you might need to set the default system locale to something that includes the UTF-8 charset. You should be able to use the locale -a command to list all available locales.

Here is what I see...it seems the locale is there Huh
Code:
login as: root
root@192.168.0.112's password:
Last login: Sat Feb  1 16:12:15 2014
root@Buffalo:~# locale -a
C
POSIX
en_US.UTF-8
Found after NAS reboot !!!

Code:
MinimServer 0.8.1 update 17, Copyright (c) 2012-2014 Simon Nash. All rights reserved.
Java(TM) SE Embedded Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) Embedded Client VM (build 24.51-b03, mixed mode)
Platform default charset is US-ASCII
received signalSIGHUP
starting Music Server
(01-02-2014 16:59)thetalm Wrote: [ -> ]Here is what I see...it seems the locale is there Huh
Code:
login as: root
root@192.168.0.112's password:
Last login: Sat Feb  1 16:12:15 2014
root@Buffalo:~# locale -a
C
POSIX
en_US.UTF-8

In that case, you just need to set this as your default locale. I am extremely surprised that exporting the LANG variable in the startd script didn't work. Are you sure you did this correctly? Did you stop and restart the MinimServer process after making this change?
Now that I learnt that restarting from Minimwatch doesn't show the default character set in the log, I spent a couple hours in the SSH console, changing "export" values and then starting MS with STARTC. This allowed me to show in Minimwatch log the default charset used.

So doing, I solved the problem with
export LC_ALL=en_US.UTF-8

After placing the above line in the STARTD file, all is going well.

P.S.
Simon, it's just a couple days I'm trying MinimServer after 5 years of various Twonky releases.
MinimServer seems to be a great piece of software. Now I'll keep it running for some days with my audio equipments and letting my wife playing with it. For now, let me thank you for your kind support.
Pages: 1 2
Reference URL's