MinimServer Forum

Full Version: Buffalo NAS: minimserver doesn't autostart
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
As a Linux newbye, I installed MinimServer 0.81 on my - previously opened gaining root access - Buffalo Linkstation Duo LS-WXL with most recent Fw (1.68)

After solving some issues - see below - I got MinimServer perfectly up and running. The update to 0.81.17 also worked well.

The only problem is that when I restart the NAS, MinimServer doesn't start.
Running SETUP in the console gives the message "MinimServer automatic startup is enabled" so I don't know what to do.
My NAS is configured to shutdown every night and startup every morning, so this is a problem for me.

Any idea ? Thanks for your help

EDIT
Googling around I understood that Linux autostart involves some files in /etc/init.d and /etc/rc.d
I found that in /etc/init.d is there a "minimserver" file, without the .sh extension
I found also that in NONE of /etc/rc.d subdirectories there is a file with a name like "SXX_minimserver.sh", that I suppose should there be.
Hope this help...


P.S. Problems solved during installation:
1) I had to manually edit line 82 in SETUP, changing it in
SCRIPTNAME="$(readlink -f "$0")"
because the existing -e parameter caused an abend with error
2) I had to manually edit STARTC and STARTD files with the full path to the unpacked directory of the Jave EJRE anvironment
(31-01-2014 01:21)thetalm Wrote: [ -> ]P.S. Problems solved during installation:
1) I had to manually edit line 82 in SETUP, changing it in
SCRIPTNAME="$(readlink -f "$0")"
because the existing -e parameter caused an abend with error

This will be fixed in the next release (not update) of MinimServer.

Quote:2) I had to manually edit STARTC and STARTD files with the full path to the unpacked directory of the Jave EJRE anvironment

These scripts assume the java executable is available on the path. The usual way to ensure this is to put a symbolic link in /usr/local/bin. I have updated the Linux installation instructions to clarify this.
Probably isn't the regular way, but I got MinimServer autostart at NAS boot with this workaround:

1) Copied etc/init.d/minimserver to /etc/init.d/minimserverstart.sh
2) I cleaned all the contents of the new file, leaving only the following line:

su "root" -c "/home/minimserver/bin/startd"

3) From the /etc/init.d directory I executed the following commands:

Code:
ln -s /etc/init.d/minimserverstart.sh /etc/rc.d/extensions.d/S40_minimserverstart.sh
ln -s /etc/init.d/minimserverstart.sh /etc/rc.d/extensions.d/K40_minimserverstart.sh

(I just emulated the twonky service behaviour)

After done so, MinimServer seems to auto start correctly at NAS boot.
Reference URL's